?
Solved

Can't ping or access hosts on PIX VPN connection

Posted on 2004-11-04
12
Medium Priority
?
827 Views
Last Modified: 2008-01-09
I've just setup PIX 506e 6.3(3) firewall and sucsessfully connected to the internal LAN through Cisco VPN client 3.6.4 (WinXP SP2)
However I can't ping anything on the network.
Here is my config

interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password  encrypted
passwd  encrypted
hostname pixfirewall
domain-name some.lan
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol tftp 69
names
access-list inside_outbound_nat0_acl permit ip any 10.10.8.0 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip any 10.10.8.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 10.10.10.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool1 10.10.8.1-10.10.8.250
pdm location 10.10.10.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 10.10.10.0 255.255.255.0 inside
http 10.10.8.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup Remotes address-pool vpnpool1
vpngroup Remotes dns-server 10.10.10.1
vpngroup Remotes default-domain some.lan
vpngroup Remotes idle-time 1800
vpngroup Remotes password *************
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
username***** privilege 15
terminal width 80

I think ithe problem is with NAT entries.
I do not have a router on the client side.
Thanks!
0
Comment
Question by:vdoisan
  • 4
  • 4
  • 2
  • +1
11 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 12499160
>client 3.6.4 (WinXP SP2)
I think SP2 requires upgrade to 4.50 or 4.6 VPN client

Also, try adding:

   access-list split_tunnel_acl permit ip 10.10.10.0 255.255.255.0 10.10.8.0 255.255.255.0
   vpngroup Remotes split-tunnel split_tunnel_acl

You can make these more specific, but I don't think it will change anything:
  >access-list inside_outbound_nat0_acl permit ip any 10.10.8.0 255.255.255.0
  >access-list outside_cryptomap_dyn_20 permit ip any 10.10.8.0 255.255.255.0

to:
   access-list inside_outbound_nat0_acl permit ip 10.10.10.0 255.255.255.0 10.10.8.0 255.255.255.0
   access-list outside_cryptomap_dyn_20 permit ip 10.10.10.0 255.255.255.0 10.10.8.0 255.255.255.0
0
 

Author Comment

by:vdoisan
ID: 12505660
No go.
I've upgraded to VPN client 4.6 as well wit the same result.

When I test the following setup it wotks fine though with 3.6 and 4.6 :me confused:

VPN Client (192.168.1.101/VPN-10.10.8.01) ---> Dlink Router <----PIX (10.10.10.254) --- LAN (10.10.10.0)
I can ping, browse test lan and all.
As soon as I establish VPN connection over the Internet, I cant do any of that.


0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12506316
>As soon as I establish VPN connection over the Internet, I cant do any of that.

Me confused, too...
How exactly are you testing now?
Do you have a Dlink connected directly to the PIX with a PC VPN client on the other side of the Dlink?
Can you ping the outside IP of the pIX from your Internet connection?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 5

Expert Comment

by:martap
ID: 12513028

Try adding this line to your PIX config:

isakmp nat-traversal
0
 

Author Comment

by:vdoisan
ID: 12524010
None of the config changes helped :(

The working test environment looks like this.

Dlink broadband router provides 192.168.0.x IPs to the client AND the PIX firewall

                                                     DLINK Router(192.168.0.X)
                                                         /                  \
                                                       /                      \
                                                     /                          \
                                       Client(192.168.0.101)         (192.168.0.100)PIX Firewall(10.10.10.X) ---------(test lan)

When I initiate VPN tunnel with this setup, everything works fine.

However when I go on the Internet with the following setup I can establish VPN tunnel, but cant ping anything on the inside.
I can ping outside PIX ip (69.x.x.Y) or DHCP assigned one.

                                                               

                 VPN Software Client              @@@@                          
              Internet DHCP (24.x.x.Z)--------(   i-net  )-------   Internet DHCP (24.x.x.Y) PIX 506 (10.10.10.X) --- real LAN
                                        or                 @@@@                               or
                           Static (69.x.x.Z)                                              Static (69.x.x.Y)                      



0
 
LVL 5

Expert Comment

by:martap
ID: 12524764

If the test environment is working then it's definitly not your PIX firewall. The problem then lies with your router on the internet or your ISP who's blocking ports.
0
 

Author Comment

by:vdoisan
ID: 12525495
I do not have a router between the pix and the Internet, I connect directly.
I am also trying 2 different ISPs.
0
 

Author Comment

by:vdoisan
ID: 12538530
Problem solved.
When I moved from the test LAN to the live network, workstations are using the original default gateway (x.x.x.240) which still in use until the full deployment of PIX.
As soon as I moved one of the clients to the PIX as the default gateway, I gained access.
Sigh, 4 days for such a simple fix, you live & u learn...
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13737607
Do you need any more assistance or information?
Can you close out this long-forgotten question?
Here's how:
http://www.experts-exchange.com/help.jsp#hs5

Thanks!
<8-}
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 15492870
OK by me..
0
 
LVL 5

Accepted Solution

by:
Netminder earned 0 total points
ID: 15515712
Closed, 500 points refunded.
Netminder
Site Admin
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For a while, I have wanted to connect my HTC Incredible to my corporate network to take advantage of the phone's powerful capabilities. I searched online and came up with varied answers from "it won't work" to super complicated statements that I did…
This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question