Can't create Web Folders with IIS 6

I have been using Words "Template on my Web sites" folder to store network templates for our offices in other locations.  My network administrator has now upgraded the server to use IIS 6 and now we can no longer address the folders.  One thing that I have noticed is that I can not address the folder through an http address where when we used IIS 5, I could.

What is missing from the configuration of the server to make this work again? Any clues?  The following page is the registry information for the Templates on My Web Sites folder:
http://support.microsoft.com/default.aspx?scid=kb;en-us;291141
 

LVL 19
dlc110161Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

humeniukCommented:
If I understand correctly what you are trying to do, you can access those files by configuring a virtual directory.  Go to Internet Services Manager and right-click on your default website -> select 'New' -> 'Virtual Directory'.  This will launch the Virtual Directory Creation Wizard.  You will create an alias for your virtual directory, ie. if you use 'templates' as an alias, then you will access them in your browser at http://<IPaddress>/templates (nb - <IPaddress> can be a URL or machine name, essentially whatever you use to access the website).  Next, you will select a path to the directory that contains the files - this can be a local path, ie. C:\Documents and Settings\user name\Application Data\Microsoft\Templates or a network share, ie. \\<machinewithfiles>\<sharename>.  Next you will configure read/write permissions, etc.

To admin the virtual directory, expand the website tree in your Internet Services Manager, right-click the virtual directory and select properties.  For something like this, you may want to enable directory browsing, for example.
0
dlc110161Author Commented:
The network administrator tells me that he has tried your steps several times with the same results.  What appears in the Neighborhood folder is:

Name of Folder......................Comments.........................................Computer
IIS5 folder.............................http://mainfolder/subfolder.................Computer Name
IIS6 folder.............................\\ComputerName\subfolder.................Computer Name

It is also obvious that the IIS 6 folder is not recognized as a Web folder in htat the icon does not include the globe.

Any other thoughts?
Dawn
0
humeniukCommented:
The proper syntax for creating a web folder is http://server/foldername.  It appears you've got that part, but there's something missing somewhere . . .

A couple of things to remember:

IIS will default to FrontPage if you have FP Server Extensions installed.  One (potential) way around this is tho remove any Custom HTTP headers that are FP-related.  Alternatively, you can just make sure FPSE aren't installed (if you don't need them).

You have to make sure that the WebDAV extension is enabled for the server in IIS Manager.  WebDAV is not installed by default

Users must have the following NTFS permissions to the directory where the files are stored: read, read & execute, list, write, modify.

And the following permissions must be set on the virtual directory: read, directory browsing, write, indexing.

For more detailed info, see "Web Authoring with WebDAV" at www.microsoft.com/resources/documentation/iis/6/all/proddocs/en-us/pub_dav_createpubdir.mspx.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dlc110161Author Commented:
You were exactly spot-on.  Enabling WebDav fixed our problem.

Thank you for your assistance.
Dawn
0
humeniukCommented:
Glad to hear it, Dawn and thank you for the A.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.