Some help plz. A few of my applications don't work correctly any more.

I use a program called net limiter and it says that apphist.dat is corrupted.
I reinstalled the program, got the same error upon the start of the program.
I uninstalled and reinstalled the program and get the same error.
The program will not run unless that file is fixed.
Now I'm not sure what I can do?

The other application is Mozilla Firefox.  For some reason it just stopped working and now it won't even load.
Basically at some time it just crashed adn won't even run.  I did not mess around with any of the source files.
I tried a system restore to before when the problem occured and the same error.
Now what can I do?

(Your answers would be appreciated.)
LVL 1
sazukaChanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TimBusiness Systems AnalystCommented:
It could be that the net limiter program install file was corrupted during download.  Try to download it again.  Uninstall, reboot, then reinstall.
0
jvuzCommented:
Do the same with Mozilla Firefox.
0
jvuzCommented:
BTW, which version of Firefox are you using?
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

JohnnyCanuckCommented:
Uninstall net limiter.  Do a search for apphist.dat and delete it.  Reinstall net limiter.  That file may be hanging around after uninstall and causing problems when you reinstall.  Can you uninstall and reinstall firefox?  Perhaps your browser is linked to the malfunctioning net limiter somehow causing it to fail.
0
sazukaChanAuthor Commented:
I am using the current version 1.0 of firefox.
0
sazukaChanAuthor Commented:
Can any one help me or am I kind of stuck?
0
DragonmenCommented:
Do next things:
1. Unistall net limiter.
2. Delete file apphist.dat from folder C:\Documents and Settings\User\Application Data\LockTime\NetLimiter\history\ where user is your profile name.
This file is not deleted when netlimiter is uninstalled!!!
3. Install net limiter again

For the firefox try to uninstall and delete it's directory manually, download from internet and install again.

All of the above probalby happened when computer or windows crashed so some of the files ain't saved correctly (restore cannot fix this).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sazukaChanAuthor Commented:
I looked for the Application Data folder and could not find it, but firefox is working again :).
0
DragonmenCommented:
You cannot see that folder becouse it's hidden.
To show hidden folders in explorer go to:
Tools->Folder Options->View
Check "Show hidden files and folders".
Click ok and wait some time.
Now go to C:\Documents and Settings\User\Application Data\LockTime\NetLimiter\history\ and delete apphist.dat file.
0
sazukaChanAuthor Commented:
Thanks for your help all it's all working agian. :)
0
DragonmenCommented:
Thank you.
I'm glad this solution helps.
0
jvuzCommented:
Thanx,

Jvuz
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.