FTP is SOL

I recently created a new admin account on XP Pro as the original one was damaged.

When starting WS-FTP Pro, I get this:

WS_FTP Pro does not appear to have been installed correctly for the current user. WS_FTP Pro will exit.
If WS_FTP Pro was already installed by another user on this computer, try running the per-user configuration setup that was placed in your Start Menu as "Programs" -> "WS_FTP Pro" -> "Install WS_FTP Pro."

1. Googling on this error was no help.
2. No such configuration setup exists on the original admin account.
3. Re-installing the app doesn't appear to help.

So, there's a setting somewhere in the registry I assume that might fix this. Any ideas?

Thanks,
Sean
LVL 31
seanpowellAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

amirinamdarCommented:
Quoted from: http://support.ipswitch.com/kb/UI-19980701-DP01.htm
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Here are directions for removing the WS_FTP key from the registry:

Note: If you are not confident working with your Windows Registry,
PLEASE don't do this! Making a mistake while editing your Registry may
render your computer unusable!

1. Back up your Registry.

2. Go to Start->Run->Regedit

3. Locate the following Registry key:

HKEY_LOCAL_MACHINE
SOFTWARE
Ipswitch
WS_FTP

4. Select the last item in the list above and press Delete.

5. Close Regedit, click on the Windows Desktop, and press F5 to refresh your
screen.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Make sure to backup your registry before doing all this!
0
seanpowellAuthor Commented:
Missed the email on this...
I appreciate the uninstall reference, but I'm trying to figure out why the software won't work for more than one user...

Sean
0
sunray_2003Commented:
Sean,

Lets say you have 2 admin accounts
What happens if you install in admin 1.. Does it work in admin 2
uninstall the software
install in admin 2. Does it work on admin 1 ?

When you install , does it say this software will work for all users or just THIS user .. I mean it might ask a question . Does it ask it ?

Is Internet working fine logging into both accounts ?

SR
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

seanpowellAuthor Commented:
Maybe I missed something when re-installing, I'll try again.

It just seems odd that the software would only work for 1 admin account, doesn't it? All the other software seems to be okay.

Thanks - I'll be back :-)

0
sunray_2003Commented:
When you shift between 2 accounts , do you close the program in one account or just leave it open and doing a switch user to another user ?
0
seanpowellAuthor Commented:
Most of the time I'm a very happy guy.

Except right now.

I just deleted the exe file on the zip disc, although I thought I was copying it. So hit me over the head and call me a *****.

So - I need to figure out why WS_FTP only works for one user account - there must be a reg setting somewhere that tells it not to let Admin 2 use the program setup by admin 1.

But it "is" installed on admin 1. Is there anyway I can uninstall it on admin 1 and re-install it on admin 2 without the exe file?

Am I just losing it, and can someone grant me a vacation. Please.

0
sunray_2003Commented:
can you try this

logon to the admin account in which you installed this software .
copy the shortcut that it created in desktop or wherever and place it here
C:\Documents and Settings\All Users\Start Menu\Programs

login to second account and check if it will open going to programs
0
seanpowellAuthor Commented:
I'll try that.

Number One - Nicely done.
0
seanpowellAuthor Commented:
:-(

No, didn't work.

I'm going to see what Ipswitch says about this...
Sean

0
sunray_2003Commented:
Not sure Sean if that would help..

Post back please
0
sunray_2003Commented:
are you sure, you cannot download that exe file again from that website ?

http://www.ipswitch.com/_download/wsftppro.asp
0
seanpowellAuthor Commented:
Well, that's just the eval version, I had the fully paid for one...

I've posted in their forum, we'll see what happens.

Thanks :-)
Sean
0
sunray_2003Commented:
Sean

as you know it would interesting to test as i had given in my first suggestion. try to install in admin 2 and see if it would work in admin 1 and viceversa.. lets wait and see what they have to say
0
seanpowellAuthor Commented:
Well, I can't install the full version as I don't have the exe file anymore.
I could download the trial version, but then I would need to purchase it again...

Thanks,
sean
0
sunray_2003Commented:
Sean,

Here is one more suggestion.
Close WS-FTP in admin 1 account. log off admin 1
Logon to admin 2.
right-click the shortcut of WS_FTP and click "run as" and give the account information of the account in which it runs.
check if that would run that software
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
seanpowellAuthor Commented:
You're a wealth of information :-)

Works perfectly - is there anyway I can automate that so I don't have to preform the same process each time?

You're the best,
Sean
0
sunray_2003Commented:
Sean

I would think it will be a security issue if you make the password to remember in the runas as you would be giving admin password but i searched for a shareware that can do encryption
http://www.quimeras.com/Products/products.asp

let me know if that would help or i wud do some more search
0
seanpowellAuthor Commented:
No, you've done enough already :-)

It's a standalone box, so I don't mind including the password in the Run As.. command. New Q :-)

Thanks Ashwin....
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.