Weird error while trying to access databeses from Domino for Linux.

I have configured the DSN's for a SQL Server and for a DB2. I test the conections with isql (linux command) and also with Domino's dctest both sucesfully. (with dctest I get a "Sucessfully connected" message, if I use other password I get an Err of security, with isql I can connect and make queries)

The weird thing is that even tho both tests were succesfull, when I try to use the DSN's from the running Domino Server (which also works fine besides of this), it seems that it can't access the DSN's. I use the connection from Agents. I have the DECS server running. This is the error I got while trying to access one of them:

Agent message: LS:DO- ODBC could not complete the requested operation.Connect

Domino Server 6.5.2 for Linux. SuSE Linux 9.1 Enterprise.

Any ideas? :(

MMarts
LVL 2
mmarthaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

qwaleteeCommented:
Hi mmartha,

Sometimes it is a rights issue -- try running isql and dctest under the same Linux account that Domino is running under.

Also, DCTest does NOT use the same code as LS:DO.  DCTest uses the lclsx code.  So try switching from *odbc to *lclsx. The two operate much differently, so the code will be different, but at least for a connection test, you'll know the answer.  And if lclsx does work, it may pay to just do it using that model, especially since Lotus has deprecated LS:DO in favr of LC LSX.

Best regards,
qwaletee
0
mmarthaAuthor Commented:
Ok. I'll change it and test it. :)

I didn't know about DCTest using *LSLXS.

Any other info you have on will be I'll be deeply truly appreciated. :)


MMarts
0
mmarthaAuthor Commented:
I ran isql and dctest from the domino server account and had the same successful result.

Even tho it isn't my area I checked the Agent code and fonud an error that keeped the server from contacting the DSN. :D

So that was the problem.

To change from *odbc to *lclsx isn't viable according to the Domino administrator (too much code I guess)

...

So, sorry for wasting your time. I do have another question (http://www.experts-exchange.com/Web/Lotus_Domino_Admin/Q_21199248.html) so please check it out.

I don't know if I should request for this question to be closed or should I award you the points, suggest please. (qwaletee or Administrators)
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

qwaleteeCommented:
Please decribe teh solution you did find.  I'll have the topic administrator (CRAK) look into a disposition for the question.
0
mmarthaAuthor Commented:
The solution was to add a couple of lines in the code of the Agent that used the DSN. I don't know those lines cause I'm not the Notes Administrator. I run the Linux server.

I can ask for the lines if you think i should post them.
0
qwaleteeCommented:
Please do.
0
mmarthaAuthor Commented:
I've sent an email asking for the code.

I'll post it ASAP. :)

I've heard no suggestions... should I award you the points?

MMMMMMarts
0
qwaleteeCommented:
You should request a refund. To do so, go to Community Support, post a zero-point question asking for a refund, icnluding the URL of this question.
0
mmarthaAuthor Commented:
I had this code:
-- START (ommited previuos variables declaration code) --
getDsn:      
'      Set qry.Connection = con
'      Set result.Query = qry
      
      nameodbc="db2"
'      user="pcuser3"
'      pass="pcuser3"
      
'      If Not con.ConnectTo(nameodbc, user, pass) Then      
      If Not con.ConnectTo(nameodbc) Then      
            Messagebox "odbc conection problem"
            Exit Sub
      End If
      
'      Set qry.Connection = con
'      Set result.Query = qry
      con.ConnectTo("DB2")
-- END --

The last 3 lines should be:
      Set qry.Connection = con
      Set result.Query = qry
'      con.ConnectTo("DB2")

and that was it.

The code was copied from a SQL Server connection, that's why it has a lot of comments.

I'll post the refund request.

thanks q


(M^n)arts
0
ee_ai_constructCommented:
Question answered by asker or dialog valuable.
Closed, 500 points refunded.
ee_ai_construct (replacement part #xm34)
Community Support Admin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Lotus IBM

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.