?
Solved

XP workstaitons logon very slow to windows 2000 domain due to DNS problems I don't understand.

Posted on 2004-11-05
4
Medium Priority
?
210 Views
Last Modified: 2010-04-10
DNS problems with DHCP server.

I have some older windows 2000 networks running around that are being upgraded to windows XP.  These networks are all domains with DHCP on the server.  Our internet access is usually cable or DSL service on a separate router.

What is happening is this.  When the new windows XP machines logon into the domain it is very slow.  It is so slow. Takes a few minutes just to logon onto the domain.  The older windows 2000 machines are normal and log in very quickly.  I know this is a DNS problem but don’t understand how to configure DNS properly.  I have always been confused when a window 2000 asks me for the domain name and I don’t want it to think it is an actual .com domain.  I need these servers to point at the DNS servers from the ISP while at the same time the windows xp workstations properly point to the server so they can logon quickly.

I need to understand DNS on windows 2k and 2003 boxes a little better so I can deal with this problem.  Any suggestions on where to start?


Randall
0
Comment
Question by:RandallPallesen
4 Comments
 
LVL 2

Expert Comment

by:nextgen00
ID: 12507252
DNS config on your server should be:

Add Forwarders... These Forwarders should be your ISPs DNS servers.

Then in your DHCP under scope options...  Configure the DNS Server to be your Servers DNS.

That usually works for me.
Example.
Server Internal IP. 192.168.0.1
ISP DNS1: w.x.y.4
ISP DNS2: w.x.y.5
Gateway (Your Router) 192.168.0.2
Your DHCP Options:
Default Gateway: 192.168.0.2
Default DNS:    192.168.0.1

Your Servers DNS Configuration:
Forwarder1: w.x.y.4
Forwarder2: w.x.y.5

Average Clients IP config:
IP           192.168.0.101
Subnet:   255.255.255.0
Default GW: 192.168.0.2
DNS:           192.168.0.1
DHCP Server: 192.168.0.1
Wins Server:  192.168.0.1
If I'm wrong Anyone, please correct me.  But this usually works pretty well for me.
Also, this is assuming your not using your server as the router.
0
 
LVL 2

Expert Comment

by:virtuoso1
ID: 12507265
Are you running a hybrid with DNS and WINS?  

You could make an entry in the LMhosts and HOSTS files in %systemroot%\system32\drivers\etc

DNSserveripaddress     NameofDNSserver
0
 
LVL 8

Accepted Solution

by:
kain21 earned 1000 total points
ID: 12507328
rather than have your servers point at the ISP DNS servers you could point the servers at the domain controllers and setup forwarders to the DNS servers at the ISP... open the DNS console and right click on the server name... click the forwarders tab... click enable and type in the ip addresses of the ISP DNS servers... then configure the dns settings on the servers to point at the domain controller (or server running DNS for your active directory)...

for the clients on DHCP... open the DHCP console and open the Scope the DHCP clients are using... click on scope options and verify that a DNS Server setting is specified... if not... right click and select configure options... on the general tab scroll down to 006 DNS Servers... click and checkmark the option... then add the ip addresses of the internal DNS server(s)... you don't need to specify a server name... if you have a DNS Server setting already configured you can follow the same steps and verify it is giving the internal DNS server to the clients (this is imperative otherwise clients will take a long time to find the domain controller... long logon times...)....

on the clients... go to the network connection tcp/ip properties and click advanced... check the dns settings on the dns tab and verify "append primary and connection specific DNS suffixes" is selected and dns suffix for this connection is blank... checkmarks next to "register this connection's addresses in DNS" and "use this connection's DNS suffix in DNS registration" and click ok... click ok on all remaining open windows... open a command prompt and type "ipconfig /release" enter.... "ipconfig /renew" enter... "ipconfig /flushdns"... now logoff and try to logon... should logon fine...
0
 
LVL 1

Expert Comment

by:mweehcx
ID: 12512266
Hi,

First your problem with the slow login on domain using Win XP, There is a hotfix release when XP SP2 is not release please installed SP2.

Basically Just if your put the primary DNS on client machine it would be directly authinticated on that specific server.secondary would be the alternate incase primary was down.

if your not using specified ip, you can used IPCONFIG /RENEW OR /RELEASE to get the ip on the server as kain21 mentioned.

hope it helps.

wee
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Make the most of your online learning experience.
In this article I will be showing you how to subnet the easiest way possible for IPv4 (Internet Protocol version 4). This article does not cover IPv6. Keep in mind that subnetting requires lots of practice and time.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question