• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3998
  • Last Modified:

tcpsvcs.exe Causing 100% CPU Utilization

I have a P4 1.2 GHz with 384 megs of memory running Windows XP Pro, SP2.  The PC is connected to Netgear router and cable modem.  The PC's performance has been fine until a couple of days ago.  Recently all of the processes  (switching windows, printing, opening files, etc.) have been very slow.

I thought it might be some type of malware and ran mcafee virus scanner, spybot, stinger, and spyware blaster.  However, none of these programs reported a problem.

After reviewing the task manager, it indicated that tcpsvcs.exe was at close to 100% utilization.  When I manually kill this process it corrects the problem with no apparent ill effects.

My research indicates conflicting opinions as to the necessity of this service.  My question is what do I need to correct the problem?  Do I need the tcpsvcs.exe service?  Is there a way to prevent it from loading at startup?

Thanks in advance for any help.
0
johntust
Asked:
johntust
1 Solution
 
SheharyaarSaahilCommented:
Hello johntust =)

First of all make sure that what is the Path of this file.... i know tcpsvcs.exe is a valid windows file, but it shud be running from C:\Windows\System32, and if on ur system its not running from there then it can be bad file =\

So use this tool and check out this process details first >> http://www.sysinternals.com/ntw2k/freeware/procexp.shtml
0
 
Fatal_ExceptionCommented:
To stop services from loading you can open up System Config Utility:

Start > Run > msconfig (OK)  and look at the Services tab.  Ck the box "Hide Windows Services" and you will probably find that service there.  Just untick the box and reboot.  While you are there, you might want to ck the Startup Tab also..

FE
0
 
Fatal_ExceptionCommented:
hmm..  I have a feeling that this is a rogue exe, and not the actual one that runs the TCP/DHCP etc networking services.  It should never be eating up that many CPU cycles..
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
e9325827Commented:
Had the same problem on a server (after making it the new dhcp server and suffering some problems with a computer I had top delete and recreate in the domain), restarted dhcp service, no problems afterwards, CPU down to normal again.
0
 
jpdaveyCommented:
If you're able to manually kill the process it can't be the one that's started as a service for DHCP / Simple TCP. You've most likely contracted a spam virus.
0
 
rtstiehlCommented:
uncheck the microsoft TCP/IP ver 6 and the regular TCP/IP in the local connection properties. reboot the machine and then go back and add the regular TCP/IP and you will be good to go.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now