Booting Problem

Hello experts,

I have windows XP installed and I'm sure that it is a clean and perfectly working installation. The problem I am facing is that my computer while booting, after Verifying DMI pool data, it boots from the CD-ROM and then a problem comes which says "DISK BOOT FAILURE - INSERT SYSTEM DISK AND PRESS ENTER". Why does this problem come even when I have the windows installed? The jumper settings and device priority settings (primary master, primary slave) are all fine. I check them. My HDD is on Primary Master. Before I used to get the NTLDR Missing error which I fixed using the "fixmbr" command in the recovery console. Now this problem came, and I am not able to fix it. Anyway I can fix this problem? What do you people think the cause of this problem is? is it the HDD? or my motherboard? or somethign else? And yes, I do sometimes get the CMOS Cheksum defaults loaded error. I just press F1 and continue. Can it be because of this also?

Please help me out. Its urgent.

-Phud3.
LVL 1
Phud3Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Phud3Author Commented:
Btw, one more thing, when I boot from Windows XP CD, where it comes "press any key to boot from CD..." I press ESC which means it will boot from the HDD, so at that place my windows starts up but directly if I try to boot from the HDD, it gives me the error I stated above :S.
0
wesly_chenCommented:
> get the CMOS Cheksum defaults loaded error
Check your motherboard's brand and model number, then go to vendor's website to download the latest firmware(BIOS) to upgrade your BIOS.
Usually it will be a self-extraction excuteable file. Run it and it will extract to a floppy.

Since you can finish the installation, so the HD should be ok.
You can go to CMOS setting to change the boot priority to "boot from HDD first" after the installation.

Wesly
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
Well, a possibility is the Ram , so test it, or change it

http://www.memtest.org/

Are you sure you get the >>  "DISK BOOT FAILURE - INSERT SYSTEM DISK AND PRESS ENTER  << when it boots from CD? this points to a non bootable CD, or drive malfunction

Also, if you boot from the hard disk, do you get any errors?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Phud3Author Commented:
Wesly_chen: I'll try upgrading the BIOS of the motherboard. I'm not sure if any updates on the BIOS is available as the computer is P3 and the motherboard is quite old.

Nobus: I'll try changing the memory. Another thing, My boot priority is set to 1st = CD Rom, 2nd = Floppy, 3rd = HDD. Now, I do not have any CD in the CD rom and nor any diskette in the FDD. So ofcourse it will boot from the HDD. After the 'Veryfying DMI Pool Data' it says Boot from ATAPI CD Rom... Failure, DISK BOOT FAILURE - INSERT SYSTEM DISK AND PRESS ENTER. This means taht first it tried to boot from CD-rom, did'nt find anythign, went onto FDD, did'nt find anything there also and then came to HDD where it gave me that DISK BOOT FAILURE error.

But moreover, if I put a bootable Windows XP CD in the cd rom and when it boots from the cd rom first, it shows me the line "Press any key to boot from the cd..." I do not press any key and then eventually it will boot from the HDD. At that point, the windows boots up perfectly. I cannot understand this situation. Any one experienced it before? Help me out.
0
nobusCommented:
some commands to try :

if NTLDR is missing :
FIXMBR C:
FIXBOOT C:

bootcfg /disable
COPY x:\I386\NTLDR C:\
COPY x:\I386\NTDETECT.COM C:\
BOOTCFG /rebuild

i must say, i never heard of this situation : direct boot from HDD --> boot failure; after trying to boot from CD --> ok
0
WEINBERGERCommented:
Had similar problem. It turned out to be the IDE controller for the motherboard. Either that or it sounds as though your harddrive has gone faulty. Is the CD rom plugged into the same IDE port ?
If it is the IDE port you have 1 of 2 choices , get an IDE controller card or a new mobo.

0
nobusCommented:
it would not hurt running sfc from the run box :

start>control panel> - now type : sfc /scannow

have the Cd ready !
0
DawafflemanCommented:
it sounds to me like the computer is trying to boot from the cd rom drive when it gets the problem. why dont you try to go into bios/cmos and tell it not to boot from the cd-rom or FDD. then it will go straight to booting from the hard drive and it wont check the cd-rom drive for a disk. maybe the problem is in your cd rom drive and the computer thinks that something is in it when you start up the computer so just bypass it.
0
Phud3Author Commented:
Nope, still awaiting for my answer. I am not getting a proper answer or a solution to this problem. Please read above to understand my question and if you are not able to, ask me and i'll tell you again. I need a proper solution to it :S. Thankyou.
0
wesly_chenCommented:
First,
> You can go to CMOS setting to change the boot priority to "boot from HDD first" after the installation.
Did you try this one. Or you just remain your boot priority 1.CD 2.Floppy 3.HDD?

Second, did you upgrade your BIOS? Sometimes it relates to motherboard bug and fixed with BIOS upgrade.

Third, this one is new.
Please check your HDD jumper. Is your HD a single device in a IDE cable? If yes, then check the jumper on "master".
If your HD and CDROM are on the same IDE cable, then check the jumper: master on HD and slave on CD-ROM.
However, put your HD and CD-ROM on different IDE cables are highly recommended.

Wesly
0
Phud3Author Commented:
Wesly,

First comment: I have tried changing the priorities in every possible way I could, that is 1.CD 2.FDD 3.HDD, 1.FDD 2.FDD 3.CD, 1.HDD 2.CD 3.FDD, all the ways but unfortunately nothing helped.

Second comment: This motherboard does not have any BIOS upgrade I guess as this motherboard is of a Pentium 3 computer. It is not as advance as the motherboards of today.

Third comment: HDD and CD Rom are on different IDE cables. And the HDD jumper is set to Master. That means my HDD is on Primary Master, Primary Slave is empty. Secondary Master is reserved by CD Rom, Secondary Slave is empty.

Any more helping hands will be appreciated :)

-Phud3
0
nobusCommented:
what is your mobo model? and the Bios type and version?
0
wesly_chenCommented:
Hi,

   How about disable CD-ROM in CMOS or unplug the CD-ROM cable?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.