[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3085
  • Last Modified:

Windows XP skipping autochk

In an attempt to repair my partition that Windows was reporting as bad, I used Power Quest Drive Image 2002 to backup my files and then restore them onto the same drive.  I've used Drive Image 2002 before and have never had any problems.  This time however I encountered a problem that I cannot seem to figure out or get around.  The problem lies with the autochk program at boot time.  Shortly after the Windows XP logo appears, Windows XP tries to run autochk and cannot.  It reports "autochk program not found .... skipping autochk".  It then reboots and repeats the same cycle over and over again without end.  The only way to stop it is to turn the computer off.  I've tried using the Last Know Good Configuration from the boot menu but that didn't work and I've also tried using the recovery console.  I ran fixboot, fixmbr and even chkdsk /r but no change.  I can't even access safe mode.  I've basically run out of options and have posted this question with hopes that someone will help.  I've given up on calling Symantec after their answering service put me on hold for almost an hour.  This question is good for 500 points for anyone that can a solution.
0
rgalindo96
Asked:
rgalindo96
  • 3
  • 2
  • 2
  • +1
1 Solution
 
AZSanDiegoHBCommented:
Hi rgalindo96,
here are several comments from poster "bbrass10" in this thread:
http://www.techspot.com/vb/showthread/t-7746.html
>>Go to Add/Remove Programs and delete the following Windows XP HotFix: KB824105
Gotta love those hotfixes!<<
>>If it's rebooting after displaying that message, your system partition is marked as "hidden NTFS". You can download a program called ptedit from PowerQuest for free. Boot to a DOS disk, run PTEdit, and change the "partition type" from hex 0x17 to hex 0x07. If the message "autochk not found" is displayed but your computer otherwise completes the boot process normally, you need to remove Windows XP HotFix KB824105 in "add/remove programs".<<
>>I just helped someone fix their computer who was receiving the same error message, and this hotfix was the culprit<<
>>the MS HotFix that I mentioned does indeed cause the error message "autochk not found" to appear on the display, but it does not cause the computer to reboot afterward like the Hidden NTFS Partition problem. I was successfully able to emulate the Hidden NTFS issue on my computer by using PTEDIT to mark the partition type as 0x17, and if you're interested in trying it you will find the same repeatable results on any computer running Windows. You can then boot on a floppy and use PTEDIT to switch it back to type 0x07 so that your hard drive boots properly again. However, the Hotfix is a somewhat different problem. Although it displays the same error message, "autochk not found", it still continues to load Windows and therefore allows you to remove the HotFix.<<

and one final note from another poster (on an alternate way to un-hide the partition):
>>BobCrabtree
I had the same error message and reboot but, after realising that the hidden system partition was the problem, it was simple to fix by running Partition Magic 8 again and unhiding the partition<<

AZSanDiegoHB
0
 
mcmonapCommented:
Hi rgalindo96,

Also check out this older solution from Kenneniah:
http://www.experts-exchange.com/Operating_Systems/WinXP/Q_20763444.html
0
 
LeeTutorretiredCommented:
Do you have PowerQuest (Symantec) Partition Magic?  This problem sometimes comes up because the system partition is hidden.  Take a look at this web page.  There is a utility you can download to unhide the partition and correct the problem:

http://www.techspot.com/vb/showthread/t-7746.html
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
AZSanDiegoHBCommented:
LeeTutor,

Disculpe por favor, pero hay un eco?
;-]

AZSanDiegoHB
0
 
LeeTutorretiredCommented:
Oops, guess there was sort of an echo there.  I found the answer I gave by doing a search on previous XP questions, and didn't notice that you quoted the same link...  Sorry 'bout that.
0
 
rgalindo96Author Commented:
AZSanDiegoHB,

Your solution worked but now I have another problem.  It turns out my partition type was 0x44, not 0x17 like said but I still went ahead and changed it to 0x07 and rebooted my computer and that message did in fact go away and I was able to get into my desktop.  However, it was not my original desktop but a new freshly installed Windows XP desktop.  All the programs I had on there were gone.  The files and folders were still there but they were not loaded or pre-installed.  I am going to reinstall the backup image and change the partition type to something other than 0x07.  To what I don't know yet.  It's going to be a trial and error type thing.  If you have a suggestion I'd really appreciate it.  I am still going to give you the 500 points on account you did solve my problem.   Thanks for your help.
0
 
AZSanDiegoHBCommented:
a few thoughts...

from what i've read, 0x44 is not a valid type, and 0x07 is a desirable setting.

make sure that the hotfix in question is uninstalled before altering the partition type, to help with isolating the problem.

if after trial and error you can't get the balance right, you might consider wiping out the partitions and starting over with partition magic or something similar. after all, the problems started after windows reported a bad partition, then the hotfix compounded it (by all appearances), then the crazy reboot related to a hidden partition.
0
 
rgalindo96Author Commented:
AZSanDiegoHB,

It turns out I was able to finally repair my computer once I restored the backup image I had done earlier.  Once I restored it, I ran Partition Magic and marked the partition hidden and then ran ptedit and changed the partition type from 0x17 to 0x07 and it worked.  Just want to mention that I had Norton GoBack on my computer and that's why the partition was marked as 0x44 to begin with.  I've read this is typical of Norton GoBack.  Anyway, I appreciate all you help.  Thanks AZSanDiegoHB.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now