anyoung GUI login screen. can't login as root.

im a linux nubie

i just instaled debian on one of my systems. and it will not let me login as root in the GUI. the login window is labled Gnome Desktop manger (if that means anything). when i first install debian brout me to a comand line login. at witch time i start X with the startx comand to see if it was configured right. after that i rebooted the comp to install a old hard drive, when it booted back up whent to the grafical login i mention before. and would not let me login as root. i like the idea of a graficle login and would like to use it or something simaler.

  i need to get in to the GUI as root .  is there a way to change the setings on that thing to alow it. if not is there somthing i can replace it with, or at lest stop it form loding so i can lode the GUI form the startx command.
mercury8001Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lee W, MVPTechnology and Business Process AdvisorCommented:
From http://www.debian.org/doc/manuals/reference/ch-tips.en.html
==================================
8.1.4 "Let me disable X on boot!"

Chasing unstable/sid is fun, but buggy xdm, gdm, kdm, and wdm started during the boot process can bite you bad.

First get the root shell by entering the following at the boot prompt:

     boot: Linux vga=normal s

Here, Linux is the label for the kernel image you are booting; "vga=normal" will make sure lilo runs in normal VGA screen, and "s" (or "S") is the parameter passed to init to invoke single-user mode. Enter the root password at the prompt.

There are few ways to disable all the X starting daemons:

    * run update-rc.d ?dm stop 99 1 2 3 4 5 6 .

    * insert "exit 0" at the start of all /etc/init.d/?dm files.

    * rename all /etc/rc2.d/S99?dm files to /etc/rc2.d/K99?dm.

    * remove all /etc/rc2.d/S99?dm files.

    * run :>/etc/X11/default-display-manager

Here, number in rc2.d must correspond to the runlevel specified in the /etc/inittab. Also ?dm means that you need to run the command multiple times by substituting it with all of the xdm, gdm, kdm, and wdm.

Only the first one in the list is "the one true way" in Debian. The last one is easy but only works on Debian and requires you to set the display manager again later using dpkg-reconfigure. Others are generic methods to disable daemons.

You can still start X with the startx command from any console shell.
0
deurkCommented:
If you are using gdm, it is disabled by default. You must login as normal user and run (now as root) gdmconfig to change this default behaviour. Et voila: you then can boot under your GUI and log as root directly ^^
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LuxanaCommented:
Hi mercury,

Rule No.1 is never ever login to GUI as root ! You do not need access gui as root . Login as normal user then If you need root priviligies you issue command su . Also if you really need to load some gui apllication with root privilieges you can run it as root from console. I'm also only debian user and still do not understand how some others distros of linux alow you to login gui as root.

What is your reason to login to GUI as root?
0
deurkCommented:
Don't patronise users. If the guy want to log in as root, answer the question by giving him what he needs, not your own opinion on the relevance of the question... even though I agree. ^^
0
mercury8001Author Commented:
thanx for the help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.