Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

E&M route back problem

Posted on 2004-11-05
13
Medium Priority
?
570 Views
Last Modified: 2008-02-01
i've connected the two PBX thogther throught two port E&M on each side router for each pbx.
inter router link is 100% no problem.
the destination pattern i've specified is "T" which gives variable 31 no and # as terminator
signal is immediate
operation is 4 wire
type is 5
the way to dial to the other pbx is first we have to dial the trunk or E&M line access no for example "80" and then the extension

the problem i'm having is that some time when i dial to the remote pbx instead the call going to remote pbx it use to route back to local pbx through the second e&m port

i.e in short thr call is going through one port and routing back through the second port of same router instead of going to the far end router
the extension on both pbx are same i.e if one got 2014 ext then this ext will also be on the other side pbx and dial the remote ext we first have to dial the access code of the E&M.
plz help

i'll be very thankful to u
0
Comment
Question by:atifraees
  • 7
  • 5
12 Comments
 
LVL 12

Expert Comment

by:Joel_Sisko
ID: 12511881
Few more bits of information if possible:

The make/model of PBX's attached to each router, model of routers being used, connection between the two routers.

To Pararphase problem:

Calls from PBX to PBX across E&M Tie trunks work most of the time, but every now and then the call routes from port a on router 1 to port B on router 1.

Can you post the configs for the routers?

0
 

Author Comment

by:atifraees
ID: 12515854
this is the config for voice
voice-port 2/0
 cptone PK
 description KORANGI-PABX
 operation 4-wire
 type 5
 signal immediate
!
voice-port 2/1
 cptone PK
 operation 4-wire
 type 5
 signal immediate
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern .T
 port 2/0
!
dial-peer voice 2 pots
 destination-pattern .T
 port 2/1
!
dial-peer voice 3 voip
 destination-pattern .T
 session target ipv4:192.168.1.2

the reason to put T in dest pattern is for variable no dialing only b/c the pbx are further connected to other pbx so to reach them i hve put T
0
 

Author Comment

by:atifraees
ID: 12515870
one pbx is of MITEL 2xxx and other is alcatel
routers are 1760 each equiped with 2 port e&M card
the connection b/w the router is through radio modems of 2meg speed
i've checked the link its 100% reliable with no crcs or any timeout during ping
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 12

Expert Comment

by:Joel_Sisko
ID: 12516071
A few things:

The "T" in the destination pattern causes the router to pause to collect x number of digits, the . is the wildcard, so essentially what might be happening is that you are specifiying any string of digits to be recieved, then the router pauses (default vaule for T settinf is 10 secs), then the router makes the call. This timing issue might be causiing the remote pbx to appear busy, which causes the router to hairpin the call to the local pbx it came from.

Few ways to confirm this, disconnect the E&M lines from the Alcatel, then from the Mitel, dial the Alcatel over the E&M tie trunks, what is the result, I suspect you will ring back into the Mitel.

Need some addtional information:

Entire config of both routers, digit length of extenstions for Mitel and Alcatel systems

Are the Tie trunks just for connectivity between these two sites?
0
 
LVL 12

Expert Comment

by:Joel_Sisko
ID: 12516114
From a good old fashion telephony perspective, if your length for digits for either system does not exceed lets say 5 digits, I would create a destination pattern that allowed any 5 digits, but no more. Also since you have two different manufactures PBX's, I would recommend that you use wink-start signaling instead of immeadiate. Every PBX implements things a different way just a little, for example, the interdigit timing on the Mitel is different than on the Alcatel.
0
 

Author Comment

by:atifraees
ID: 12516728
the whole scenario is uploaded on my website
www.geocities.com/atifraees438/voip_problem.doc

Joel_Sisko  you said about T now instead of waiting for 10 sec the T comes with a default terminator # for example if i put 8 digit no and press # router will not wait for interdigit timout it will immedialely call

both pbx got 4 digit extension ,one 1 digit no and one two digit no for example : 2014,55,0 <--- most common used ext in this network

also one thing to mension is that both pbx got same ext on them
example 2014, 2015 etc will be available on both pbx

reason why i put T is at one end the pbx is further connected to other pbx so access those i need a varable no dest pattern


configuration:
R1:
PAPCO#sh ru
Building configuration...

Current configuration : 1504 bytes
!
! No configuration change since last restart
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PAPCO
!
logging queue-limit 100
enable secret 5 $1$r80d$NWM9xtgYwzM1f7uGGAj7j1
!
tdm clock E1 0/0 both export line
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
controller E1 0/0
 channel-group 0 unframed
!
!
interface FastEthernet0/0
 ip address 10.10.1.151 255.255.255.0
 speed auto
!
interface Serial0/0:0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial1/0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1/1
 no ip address
 shutdown
!
ip classless
ip route 10.10.1.0 255.255.255.0 192.168.1.2
ip route 192.168.100.0 255.255.255.0 192.168.1.2
ip http server
!
!
!
!
call rsvp-sync
!
voice-port 2/0
 cptone PK
 description KORANGI-PABX
 operation 4-wire
 type 5
 signal immediate
!
voice-port 2/1
 cptone PK
 operation 4-wire
 type 5
 signal immediate
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern T
 port 2/0
!
dial-peer voice 2 pots
 destination-pattern T
 port 2/1
!
dial-peer voice 3 voip
 destination-pattern T
 session target ipv4:192.168.1.2
!
banner exec ^C" You have entered the exe^C
banner login ^C!!!!!******** YOU HAVE ENTERED THE PAPCO ROUTER ********!!!!!^C
!
line con 0
 password cisco
line aux 0
line vty 0 4
 password cisco
 login
!
end


R2:
PARCO_KORANGI#sh ru
Building configuration...

Current configuration : 1688 bytes
!
! Last configuration change at 15:10:09 UTC Wed Oct 27 2004
! NVRAM config last updated at 13:30:05 UTC Thu Oct 21 2004
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PARCO_KORANGI
!
logging queue-limit 100
enable secret 5 $1$6Ilm$g67AXW1j.VOIURXNkWQI20
!
tdm clock E1 0/0 both export line
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
controller E1 0/0
 channel-group 0 unframed
!
!
interface FastEthernet0/0
 ip address 192.168.100.1 255.255.255.0
 speed auto
!
interface Serial0/0:0
 description KORANGI-VOICE-LINK
 ip address 192.168.1.2 255.255.255.0
!
interface Serial1/0
 ip address 192.168.1.4 255.255.255.0
!
interface Serial1/1
 no ip address
 shutdown
!
router rip
 network 192.168.1.0
 network 192.168.100.0
!
ip classless
ip route 10.10.1.0 255.255.255.0 192.168.1.1
ip route 192.168.100.0 255.255.255.0 192.168.1.1
ip http server
!
!
!
!
call rsvp-sync
!
voice-port 2/0
 cptone PK
 description PAPCO-PORT-QASIM
 operation 4-wire
 type 5
 signal immediate
!
voice-port 2/1
 cptone PK
 operation 4-wire
 type 5
 signal immediate
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern ....
 port 2/0
!
dial-peer voice 2 pots
 destination-pattern ....
 port 2/1
!
dial-peer voice 3 voip
 destination-pattern ....
 session target ipv4:192.168.1.1
!
dial-peer terminator *
banner login ^C!!!!!*******YOU HAVE ENTERED THE PARCO ROUTER *******!!!!!!^C
!
line con 0
 password cisco
line aux 0
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end


thats all

0
 
LVL 12

Expert Comment

by:Joel_Sisko
ID: 12517715
Yes you are correct about the # being used with the dial string. Based upon your information, you stated that both PBX's have the same exact extenstion numbers, therefore supporting your reason for a varaible extenstion. Is this correct? You also stated "reason why i put T is at one end the pbx is further connected to other pbx so access those i need a varable no dest pattern", is this correct so far?

Few questions, when you go to dial an extenstionon the Alcatel from the Mitel, you have to dial a trunk access code to gain the E&M trunks, what code is that? I have to assume that you dial a code, because if both PBX have the same extenstion numbers, and dialed X2014, the PBX would ring the local extenstion. So assuming that you dial an access code, the digits recieved by the router are meant only to reach an extenstion at the other location. Looking at it this way you would be better creating a dial peer that allows for up to 4 digits and thats it. In designing any dial plan you want to use the KISS method (Keep It Simple and Stupid). Please understand that I am not saying your users are not able to use the # to terminate the call, on average most will not, just my expirience coming to play.

So do the following:

Change E&M signaling to Wink-Start (this provides reliability, immediate does not)
Change the destination pattern if you can based upon assumed configuration above.

Also did iyou try testing the configuration by disconnecting the E&M lines at one end to see if hairpins back.

Keep me posted.
0
 
LVL 12

Expert Comment

by:Joel_Sisko
ID: 12517846
Added thought, if you cannot get around using T , then we could adjust the default time out to less than what it is now.
0
 

Author Comment

by:atifraees
ID: 12520628
i gota check these changes u have suggested
please wait i 'll u as soon as ihave done it

again about variable dest pattern is just to get through to other pbx
all the exts on mitel and alcatel r 4 digit no start with 2***
both got ext 0 for operator
got ext 55 for telco dept
thats all


from alcatel to mitel i have to dial 43 and then the desired ext
from mitel to alcatel ihad to dial 80 and then the desired ext

one thing that comes in my mind is that both the e&m line on alcatel got same access code i.e, 43 and so is on the mitel i.e, 80

i'll check it too by changing to some different nos

one that ihave checked is that when both trunks are free then this route back thing happens
when one of them is used call take place perfectly
0
 
LVL 12

Expert Comment

by:Joel_Sisko
ID: 12525492
Based upon your last post about when the E&M circuits are idle, I woul dmove towards using Wink-start, maybe for one reason or another that the E&M links on the pbx or router are going into some form of idle state that is interperted as being unavaliable by the pbx or router.

By using Wink-start you enable a handshake prior to transmitting, this might be enought to "wake" up the circuit so to speak.
0
 
LVL 12

Accepted Solution

by:
Joel_Sisko earned 750 total points
ID: 12631479
Any headway on your resolving your problem?
0
 

Author Comment

by:atifraees
ID: 12847065
sory i got late to tell u that i've configured it to connection trunk and now there is no problem

thanks to u
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my office we had 10 Cisco 7940G IP phones that were useless as they were showing PROTOCOL APPLICATION INVALID when started. I searched through Google and worked for a week continuously on those phones, and finally got them working. This is a di…
Skype is a P2P (Peer to Peer) instant messaging and VOIP (Voice over IP) service – as well as a whole lot more.
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…
Suggested Courses

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question