?
Solved

Hard-drive constantly writing

Posted on 2004-11-06
8
Medium Priority
?
1,132 Views
Last Modified: 2008-02-07
My hard disk is constantly writing data to disk at intervals of about 1.5 seconds. I cant figure out why its doing this.
Steps I have taken thus far:

1. Boot into safe mode. disk still writes data
2. Run Diskmon to confirm disk is writing. This was confirmed, Dismon shows writing activity every 1.5 seconds or so.
3. Run Filemon to determine what process is access\wiriting to what file. Filemon does not detect any activity. It stays blank unless I perform an action.
4. Perform a virus check in safe mode (the latest definition is installed)
5. Run ProcessExplorer to determine if any processes seem to be involved. I dont see any process who's activity seem to corrolate with the HD writing activity.
6. Confirmed that drive does not write when not in windows, ie, pause during boot, or boot into dos.

any ideas would be awesome! I'm just about ready to nuke my install.

Current system:
Via chipset (KT400)
Windows XP Pro
2 Hitachis 80gb ATA100 each in RAID 0 configuration
0
Comment
Question by:330pilot
8 Comments
 
LVL 3

Expert Comment

by:WEINBERGER
ID: 12512330
Press Ctrl Alt and delete key at the same time. Select task manager if it does not come up automatically.
Select process. Look at the CPU column and see if there are any process that is using a large amount of cpou resources. This would then most likely be the software responsibile for the disk writing.
Notes under idle operations the System Idle process will be around 97-99. This is normal. However if there is another process using lot try determine what it is.

PS: is your machine slower than normal. If constantly writing I suspect it would be.,
0
 
LVL 3

Expert Comment

by:Ultimate_NescaFe
ID: 12512520
Definitely DEFRAGMENT your HDD, as there is a large chance of fragmentation causing your problems.
0
 
LVL 93

Expert Comment

by:nobus
ID: 12512737
and run all of this :


     Spybot :        http://www.download.com/3000-8022-10122137.html
     adaware :      http://www.lavasoftusa.com/
     STINGER  :   http://vil.nai.com/vil/stinger/   
http://housecall.trendmicro.com/                                           online scan for trojans
http://www.ravantivirus.com/scan/
http://www.spychecker.com/program/coolwebshredder.html            CWshredder
http://www.spychecker.com/program/hijackthis.html                           download
http://www.hijackthis.de/index.php?langselect=english                            check the log
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
LVL 14

Expert Comment

by:JohnnyCanuck
ID: 12513088
Turn off indexing.

Control Panel->Administrative Tools->Services->Disable Indexing Services.
0
 
LVL 88

Expert Comment

by:rindi
ID: 12513159
How big is your RAM? Windows XP needs at least 256 MB to work smoothly. If it is less, it'll constantly swap out to disk, causing your disk activity. Look at your eventviewer (Administrative Tools). There you should see any problems your PC has. If it does have problems, those will be logged and cause writing to disk, so try to eliminate those problems or try to keep them from getting logged (You can change Log Settings via Policy Editor).
0
 

Author Comment

by:330pilot
ID: 12513351
RAM = 1024mb PC3200
Computer is fast enough: AMD XP 2200+
Indexing = Turned it off a while ago, did not resolve (still off)
No process is utilizing any CPU

Though, I completely forgot about defrag. The volume has a total of 16% fragmentation, let me try this and get back to you.
0
 

Accepted Solution

by:
wittyfred earned 500 total points
ID: 12514116
Try deleting the page file and creating a new one:

Control Panel > System > Advanced > Advanced Tab > Change (under Virtual Memory) > No Paging File > Set > reboot computer

after computer has rebooted:

Control Panel > System > Advanced > Advanced Tab > Change (under Virtual Memory) >System managed size > Set > reboot computer
0
 
LVL 88

Expert Comment

by:rindi
ID: 12516814
With 1 Giga Ram you can consider turning off your paging file completely. Try that and, if you don't often get a message that your running out of memory you can leave it that way. Also, if you do need the paging file, make a separate partition specifically for it and set it to be of a certain size (initial size and maximum size have the same value).
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
New style of hardware planning for Microsoft Exchange server.
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Suggested Courses
Course of the Month15 days, 5 hours left to enroll

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question