cisco 837, port forwarding and emule

Hi there, can someone explain to me how to set up my cisco router to allowing incoming traffic on ports for my emule file sharing client on LAN ip 192.168.0.3. The key advice I need is that this needs to be for a dynamic IP address, not a static. My current config is list below:


no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname xxxxxx
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxxxxxxxxxxxxx
!
no aaa new-model
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.0.1
ip dhcp excluded-address 192.168.0.3
!
ip dhcp pool CLIENT
   import all
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   lease 0 2
!
!
ip name-server xxxxxxxxxxx
ip name-server xxxxxxxxxxx
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
 hold-queue 100 out
!
interface ATM0
 no ip address
 atm vc-per-vp xx
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc xxxx
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet2
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet4
 no ip address
 duplex auto
 speed auto
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer remote-name xxxxxxx
 dialer-group 1
 ppp authentication pap chap callin
 ppp chap hostname xxxxxxxxxxxxx
 ppp chap password xxxxxxxxxxxxx
 ppp ipcp dns request
 ppp ipcp wins request
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list 102 interface Dialer1 overload
!
!
access-list 23 permit 192.168.0.0 0.0.0.255
access-list 102 permit ip 192.168.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
 password xxxxxxxx
 login
 no modem enable
 transport preferred all
 transport output all
line aux 0
 password xxxxxxx
 login
 transport preferred all
 transport output all
line vty 0 4
 exec-timeout 120 0
 password xxxxxx
 login
 length 0
 transport preferred all
 transport input all
 transport output all
!
scheduler max-task-time 5000
end
barryantwiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JFrederick29Commented:
First, you need to determine which ports you need to open.  Once you know which ports need to be forwarded, use the following syntax for each port:

ip nat inside source static tcp|udp <inside IP address> <inside port> <outside interface of IP address> <outside port>

For example, to forward TCP port 10000 to 192.168.0.3, you would use the following command:

ip nat inside source static tcp 192.168.0.3 10000 interface dialer1 10000

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.