'routed' problem....

hi,

i am designing a Intranet where things are always on the move. this is the setup:

 (DMZ, 10.209.0.0/16) -+-+                                +-+--(10.201.250.200/8:router2:10.200.250.1/16)+-+(DLink switch)
                                      | 10.209.250.1            |                                                                                     |
                             (Linux router1) +-+-+-+(10.201.250.201:Cisco switch)              (DNS caching server:10.200.1.11/16)
                                      |xxx.yyy.zzz.98                      |
                                      |                                          |+-+-+-+-+-+
                                      |                                                            |
                 (Cisco router: 1721, to Internet)                                (PC: 10.103.11.1)

Basically the only queer thing here is that the subnet mask for the internal LAN is set at /8 so that I am able to assign addresses like 10.103.yyy.zzz in the intranet and when i setup departmental router, I will seamlessly migrate. So as I hv show here, ideally the Internal LAN NIC of the Linux router (main) should be connected to other routers only, but as of now, we can expect PC to be directly plugged into the main switch.

My problem is: I am running the 'routed' domain on both the Linux router1 and router2 because I didnt want to manually go and add static routes on every router. However, although the setup initially works and the routes are discovered, after a while I get messages such as:

routed[pid]: deleting route to interface eth2 (timed out)

eth2 is connected to the Internal lan.

I am here to clarify.

Over to you.
LVL 2
kidomanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wesly_chenCommented:
Hi,

    routed use RIP (Routing Information Protocol) to "dynamically" add/remove route in the routing table.
Sometimes the route expires due to the destination missing so it will be deleted.
For example, one PC with DHCP IP change the IP in the LAN side, then the route to the original is no longer valid and the routed
will examine and detect those invaild routes and reomve them periodically.
So it should be ok to see this message unless you have a routing problem.

Wesly
0
kidomanAuthor Commented:
Hi,

I am perplexed by the problem I am facing....

The routed daemon is randomly deleting routes to destinations which are still visible. I mean, RIP listens to broadcast message from different routers. So unless some router explicitly mentions that the route is still valid, then how shall it be deleted.

Please clarify,

Karan
0
MikaelErikssonCommented:
I'm not sure why the routes are removed from your routing table but maybe the use of ospf will help.
I downloaded the quagga rpm from http://www.quagga.net/

With ospf the routers "talk" to each other in the interval you choose and reporting nearby routers and routing tables.
Works great for me!
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

kidomanAuthor Commented:
Can u tell me how u managed to get quagga up and running.... because before I moved to Routed i tried quagga but found the documentation severly lacking.....
0
MikaelErikssonCommented:
I downloaded and installed the latest rpm to get the zebra and ospfd daemons.
The config files ospfd.conf and zebra.conf should be placed in /etc/quagga

* Start Zebra and ospfd at boot.
       chkconfig --level 2345 zebra on
       chkconfig --level 2345 ospfd on
 
* Edit /usr/local/etc/zebra.conf
     hostname server1
     password zebra
     enable password zebra
     log file /var/log/zebra/zebra.log
 
* Edit /usr/local/etc/ospfd.conf
     hostname server1
     password zebra
     enable password zebra
     router ospf
     network 0.0.0.0/0 area 192.168.1.0
 
* create /var/log/zebra/zebra.log
     Set permissions to the file
         
* Start zebra and ospf daemons
 
* Connect to zebra using a telnet client (port 2601)
        Password: *****
        server1> enable
        Password: *****
        server1# conf t
        server1(config)# interface eth1
        server1(config)# ip address 192.168.1.10/24
        server1(config)# quit
        server1(config)# wr
        Configuration saved to /usr/local/etc/zebra.conf
        server1(config-if)# quit
 
* Connect to ospf using a telnet client (port 2604)
        Password: *****
        server1> enable
        Password: *****
        server1# conf t
        server1(config)# interface eth1
        server1(config-if)# ip ospf hello-interval 10
        server1(config-if)# ip ospf cost 1
        server1(config-if)# ip ospf priority 1
        server1(config-if)# ip ospf retransmit-interval 5
        server1(config-if)# ip ospf dead-interval 40
        server1(config-if)# wr
        Configuration saved to /usr/local/etc/ospfd.conf
        server1(config-if)# quit
 
 
To check hello packets:
tcpdump -i eth1 ip[9] == 89
 
You should see hello packets sent out every 10 sec.

I hope this helps!

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kidomanAuthor Commented:
I am a little confused..... you mention that the configuration files should be placed in /etC/quagga but are referencing files in /usr/local/etc....? Whadda going on.

Karan
0
MikaelErikssonCommented:
I'm sorry.
The files should be placed in "/etc/quagga", if you are using default config from quagga.
I did a cut and paste from a server where i manually installed zebra and ospfd, before i discovered quagga.

You can change the location of the config files but then you need to edit the scripts for ospfd and zebra services.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.