Linux Network trouble.   Need help

Posted on 2004-11-06
Last Modified: 2010-03-18

I installed Redhat 9.0 on a system in my home.  The computer is connected to a linksys router but currently cannot ping the router or any local computer or anything out on the internet.  It acts as though it's locked out.  I have checked all cable connections and they are live and work properly.  I do have the firewall turned off on the linux box.

The box is running Linux 9 (Redhat) with Gnome GUI.

I was looking for any assistance if possible.

Below are results for some  tests I run

Here is the route -en
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface   U         0 0          0 eth0     U         0 0          0 eth0       U         0 0          0 lo         UG        0 0          0 eth0

Here is the lsmod
Module                  Size  Used by    Not tainted
nls_iso8859-1           3516   1  (autoclean)
nls_cp437               5116   1  (autoclean)
sd_mod                 13516   0  (autoclean)
vfat                   13004   1  (autoclean)
fat                    38808   0  (autoclean) [vfat]
parport_pc             19076   1  (autoclean)
lp                      8996   0  (autoclean)
parport                37056   1  (autoclean) [parport_pc lp]
iptable_filter          2412   0  (autoclean) (unused)
ip_tables              15096   1  [iptable_filter]
autofs                 13268   0  (autoclean) (unused)
3c59x                  30704   1
sr_mod                 18136   0  (autoclean)
ide-scsi               12208   0
ide-cd                 35708   0
cdrom                  33728   0  [sr_mod ide-cd]
usb-storage            69332   0
scsi_mod              107160   4  [sd_mod sr_mod ide-scsi usb-storage]
keybdev                 2944   0  (unused)
mousedev                5492   1
hid                    22148   0  (unused)
input                   5856   0  [keybdev mousedev hid]
usb-uhci               26348   0  (unused)
usbcore                78784   1  [usb-storage hid usb-uhci]
ext3                   70784   2
jbd                    51892   2  [ext3]

And ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:A0:24:E0:4B:6C  
          inet addr:  Bcast:  Mask:
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:284 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:240 (240.0 b)  TX bytes:17157 (16.7 Kb)
          Interrupt:10 Base address:0xe400

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8232 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8232 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:564175 (550.9 Kb)  TX bytes:564175 (550.9 Kb)

iptables -en returns

Nothing but blank Forward/Outgoing etc.

Again I cannot get out of the linux box to my local network or the Internet.

This linux box is behind a linksys router/switch.  IP of router.  (


Question by:Rog
    LVL 38

    Expert Comment


       Can you do
    # grep -i eth0 /var/log/messages
    to see any error messages and post the output here?

    LVL 8

    Author Comment

    No Errors are showing up.... I see where eth0 comes up successful.

    It can ping localhost and it's own ip but nothing else.

    LVL 38

    Accepted Solution


       How about any error message in /var/log/dmesg?
    Do you see "eth0: Transmit error, TX status ...." in /var/log/messages?
    Could you post the output of
    # grep -i eth0 /var/log/messages

    LVL 17

    Expert Comment

    Try "route add default gw"
    LVL 38

    Expert Comment

    >Here is the route -en
    >Kernel IP routing table
    >Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
    >   U         0 0          0 eth0
    >     U         0 0          0 eth0
    >       U         0 0          0 lo
    >         UG        0 0          0 eth0    <=== default gateway

    Default gateway is already there.
    But you can delete the redantant route:
    # route del -net netmask


    LVL 8

    Author Comment

    I did remove the entry.

    Nothing changed.

    It seems that when I set the network device to DHCP and activate it, it hangs like it isn't getting information from the linksys router.  Other widnows systems connected to the router are working properly and getting ip informaiton.  I am beginning to think it's something with the way linksys router is talking to a Linux box?????

    LVL 5

    Expert Comment


    It might be something as simple as a defective NIC. You could also try to replace the UTP cable.
    LVL 16

    Expert Comment

    have you tryed redhats network config?

    Using DHCP
    Using DHCP is the easiest and best way of setting up networking.  To use DHCP there must be a DHCP server on your local network.  NMU has such a server.
    To set up dhcp, you must have the ethenet card working.   After that, just edit the /etc/sysconfig/network-scripts/ifcfg-eth0 to include the proto line as shown below.
    Setting up the Ethernet Card Address
    To set up the ethernet card you will need to know your netmask.  Your netmask is used to tell if a given IP address is on the given network.  You netmask is dependent on the class of your network.  A Class C network has a netmask of, a Class B network has a netmask of  Custom subnets have different netmasks.

    You can then configure your card by hand with a command like
    ifconfig eth0 netmask up

    You can make these settings permenant by editing /etc/sysconfig/network-scripts/ifcfg-eth0
    Checking Ethernet Card Status
    You can check the ethernet card at this point to make sure it's working by restarting the network and then trying to ping a machine GIVEN ITS IP NUMBER and ASSUMING ITS ON THE LOCAL NET.  Other functionality is not yet set up.  Try a command like

       /etc/rc.d/init.d/network restart

    If everything is fine
    LVL 17

    Expert Comment

    Have you tried giving the linux box a static ip?
    LVL 38

    Assisted Solution


       I've 3Com 10/100 (3C90x) NIC card in my RedHat box and show up in "lsmod" as
    3c59x                  30704   1
    as yours.

       I've the same problem with that all network configuration are right (static IP, clean routing table, NIC driver loaded and
    recognized by OS). But just can not ping my DSL router (default gateway in the same network). My linux box is dual
    boot with Win98se, which has no problem to surf internet.

       I found "eth0: Transmit error, TX status ...." in /var/log/messages and dmesg, but I couldn't figure it out the cause.
    First, I suspect my netgear gigabit 8-port switch which the Linux 3Com driver didn't do the good job to negotiate transfer rate.
    Changed the switch still failed.

       Finally, I pulled out the modem and the network is up.....   (tear...)

       Anyway, this may not suit your case, but you might want to switch NIC card to test.

       Never give up, which is my principle.


    LVL 8

    Author Comment

    I did take out the modem card.  Now everything seems to be going well.  Thanks for the tip though as this is the exact situation I had

    LVL 38

    Expert Comment

    Gald to hear that everything go smoothly now.

    I think the IRQ assignment in Linux doesn't do the good job
    or the reserved IRQ range for Linux and Windows are different. So works for Windows doesn't work for Linux.



    Featured Post

    Highfive + Dolby Voice = No More Audio Complaints!

    Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

    Join & Write a Comment

    I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
    Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

    729 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now