unable to login to database

hi,

trying to login to oracle db [sqlplus userA/userA@tcxDB] is giving following error:

ORA-00604: error occurred at recursive SQL level 1
ORA-01219: database not open: queries allowed on fixed tables/views only

user1 is having dba rights and the oracle is 9.0.2. but not sysdba, also i don't know the sysdba username/password.

Experts please help !!!!!

Thx
T...X
tcraxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arjanhCommented:
Looks like you need to open the database using svrmgrl (assuming it is indeed running):

svrmgrl> connect internal
svrmgrl> alter database open
0
StevenTaylorCommented:
I don't think svrmgrl is available in Oracle 9.

Alternatively, as long as you're logged into the OS with a user having dba permissions, you should be able to get access using:

sqlplus "/ as sysdba"

You than have the same options available to you as with svrmgrl and can start/stop the database:

startup

shutdown <immediate or whatever>
0
boriskalavskyCommented:
On UNIX you need to be a member of dba group (OS group) and on Windows you will need to have ORA_DBA role (OS role) granted to you user. Having this you will be able to "alter database open;" after "connect / as sysdba;" in sqlplus.

sqlplus /nolog
conn / as sysdba
alter database open;
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

tcraxAuthor Commented:
@arjanh: svrmgrl is not available in oracle 9

@StevenTaylor/@boriskalavsky: i have dba permissoon but i am not able to connect as susdba as i'm getting "insufficient privileges".

any other workaround !!!
0
muskware77Commented:
why don't you connect as SYSTEM? Then set the passwordfor sys and then connect internal and do the rest?
0
StevenTaylorCommented:
Try uncommenting the parameter "SQLNET.AUTHENTICATION_SERVICES" in the $ORACLE_HOME/network/admin/sqlnet.ora file.

SQLNET.AUTHENTICATION_SERVICES= (NTS)
0
boriskalavskyCommented:
What OS do you have?
0
slightwv (䄆 Netminder) Commented:
As everyone else has already stated:  the DB is not open.

As for connecting to open the DB:  What is the result by following boriskalavsky's suggestion

As for the: ORA-01219: database not open: queries allowed on fixed tables/views only

I'm betting that there is a login.sql or glogin.sql that is attempting to perform a query.
0
boriskalavskyCommented:
Database DBA role and OS dba group is not the same thing. Do you have a OS group dba?
0
boriskalavskyCommented:
Check $ORACLE_HOME.
Check $ORACLE_SID.
Check if $TWO_TASK is set.
Try to rename sqlnet.ora to sqlnet.ora_save, check if you can connect as sysdba if did not help rename it back.
You can connect to SYS and grant sysdba to other user and then connect as sysdba as that user.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tcraxAuthor Commented:
@boriskalavsky ... renaming sqlnet.ora worked, now I'm able to connect as sysdba. But when I gave:

SQL> startup

I got following error:

ORA-27123: unable to attach to shared memory segment
HPUX-ia64 Error: 22: Invalid argument
Additional information: 1
Additional information: 9764870

Also the server is HP-Itanium.
0
boriskalavskyCommented:
You can try to go to $ORACLE_HOME/bin

cd  $ORACLE_HOME/bin
ls -l oracle

Permitions should be: rwsrwsr--
0
StevenTaylorCommented:
If the permissions are wrong, set it as follows:

chmod 6755 $ORACLE_HOME/bin/oracle

Also, if this isn't the problem, check you've set all the kernel parameters to at least the minimum specified in the Oracle I-Guide.

Specifically, check shmmax (I think it needs to be at least 1GB).
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.