Home Networking Not working - Ping successful, firewalls properly configured

Here's the situation, I am trying to get three computers to network with each other, and was successful temporarily, however I seem unable to now to connect to or from one of the computers.
Here's the Setup:
Working PCs:
PC 1   -  Win 98
PC 2   -  Win XP - SP1

Not working PC: -
PC 3   -  Win XP SP2

I am able to ping between all computers fine.  Putting the IP address of PC 1 or 2 into the browser of PC 3 allows me to access PC 1 or 2 in a somewhat limited manner.  Trying to put the IP address of PC 3 in the browser of PC 1 or PC 2 results in the comp saying it cannot find the computer.
All computers were confiugred using the Win XP Home Networking Configuration Wizard, their IP addresses are:
PC 1 -  192.168.123.101
PC 2 -  192.168.123.102
PC 3  - 192.168.123.100
all were assigned by the US Robotics router.
I am running Macafee on PC1 and Kerio Personal Firewall on PC 3, however both are configured to the home network.  Disabling them does not help either.
In network neighborhood if I click on 'view workgroup computers' on PC 2 I see PC1 and PC 2
If I click on 'view workgroup computers' on PC 3 I recieve an error saying that 'home network is unavailable...blablabla'.  It worked for a while when I had SP1 installed, then stopped working.  I installed XP and SP 2 on a different HD in the PC (I have a 200 and a 160) and it worked for mabye a month and then I noticed it stopped working.  Long story short it looks like its the XP home networking setup which is a problem (I have manually messed around to no avail with the adapters, onboard LAN driver...etc).  Has anyone encountered this problem, and does anyone know how to help?  Any suggestions appreciated.
I'd love to make it a 250 point question, but unfortionately I only have 125 at the moment  I will increase it to 250 or 500 whenever I get more.  I apologize for that, and thanks in advance for your help.
LVL 3
RyanChAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

improveyourpcCommented:
RyanCh,

The problem PC has SP2 loaded on it, SP2 comes with a built in windows firewall that you may have to disable if you are using Kerio Personal Firewall.

Here is a link that walks you through disabling the windows firewall:

http://www.infosec.uga.edu/xpsp2/disablefirewall-popup.html
0
RyanChAuthor Commented:
I disabled the windows firewall long ago :-)
This problem happened with SP1 as well before if that helps.  I have the latest drivers for my motherboard (it is onboard LAN) as well.  
0
jjk16Commented:
i usually uninstall all firewalls(when troubleshooting), the windows firewall with xp sp2 is good, just check the exception for file and print sharing. Some firewalls dont like to be disabled and keep blocking, uninstall them to form a known good, might even try it in safe mode with networking

once you do that, get used to event viewer
start --> run,   eventvwr

click on system look for the MxSMB etc (they're yellow or red)

start-->run, \\192.168.123.101
start-->run, \\192.168.123.102
start-->run, \\192.168.123.100

ALL should come up, even yourself, repeat that on all three computers

post the results
0
Firewall Management 201 with Professor Wool

In this whiteboard video, Professor Wool highlights the challenges, benefits and trade-offs of utilizing zero-touch automation for security policy change management. Watch and Learn!

RyanChAuthor Commented:
On PC3 there is nothing in the event viewer from anything other than PC3, and in the MrxSMB events it says
The redirector failed to determine the connection type.

So from PC 3 the start --> run    I can connect to PC 2, but neither PC 1 or PC 2 can connect to PC 3.

I feel that I have improperly respnded to your comment jkk16, at the moment PC1 and PC2 are in a room where some stuff just fell so it is going to get cleaned up before I check the event viewer on them.  I will respond further once I do. Thanks for your help.

0
RyanChAuthor Commented:
I looked on PC 2 (PC1 was off for the moment) and the MrxSMB had the same thing "The redirector failed to determine the connection type".  I probably also should mention that all computers are connected to a US Robotics router, and all can access the internet.  
0
jjk16Commented:
it still seems like a firewall issue...  it seems like pc3 is the only one that seems to be blocked.

im guessing that and 1 and 2 can connect to each other, but not 3,

did you UNINSTALL the firewall?
0
rindiCommented:
Edit your \systemroot\system32\drivers\etc\hosts file on all PCs and add the ip addresses and names of all of them there (on the win98 PC it is in a different location).
0
RyanChAuthor Commented:
I uninstalled, tested, and re-installed the firewall.  No luck any way.I will try what you suggested rindi, but won't that simply allow me to type the PC name in the address bar and access it (but not solve the problem).....in other words, isn't that simply changing the start-->run, \\192.168.123.101 type of command to just having to type the PC name?
0
jjk16Commented:
9x is in the c:\windows directory

i do not think hosts works for 9x as they do not use dns for name resolution(could be wrong)

lmhosts would be the safer bet,   but yeah your just exchanging an IP for a UNC name...

there is a program net diag..

http://www.microsoft.com/windows2000/techinfo/reskit/tools/existing/netdiag-o.asp

let it check your connection..
0
jjk16Commented:
please post the results...
0
RyanChAuthor Commented:
Ok, looks like i've hit a problem here jkk16.  When I try running netdiag (through the cmd window of course) after I install it I get the following error:
The procedure entry point for DnsGetPrimaryDomainName_UTF8 could not be located in the dynamic link library DNSAPI.dll.
(this is on PC3)
0
jjk16Commented:
Note if using WinXP/Win2k3 one should use the Netdiag.exe supplied on the install cd WinXP(X:\Support\Tools\Setup.exe) / Win2k3 (X:\Support\Tools\suptools.msi), or else one will get the following error:
netdiag.exe - Entry Point Not Found :

i linked you to the one for win2k, my apologies

http://www.microsoft.com/downloads/details.aspx?FamilyID=49ae8576-9bb9-4126-9761-ba8011fabf38&displaylang=en

although now they have something about genuine windows...
hope your legit
0
RyanChAuthor Commented:
Thanks for the info on that.
Netdiag worked fine off the CD (don't like microsoft snooping), and here's the results.  Please note that I didn't have PC1 or PC2 on when I ran it.  

Computer name:xxxxxxx
DNS Host Name:xxxxxxx
system and processor info looked good
Hotfixes installed: (i have windows updated completely, i go to the update site every week or two, so i thought there would be more hotfixes listed.....mabye it summarizes them with SP2...)
KB824707
Q147222

Netcard queries test................passed
[Warning] The net card '1394 adapter' may not be working because it has not recieved any packets.
(thats my main NIC, which is the NForce onboard NIC)

Per interface resuilts:
Adapter:  LAN
Netcard queries test.........:passed
Host name....................xxxxxx
IP address...................192.168.123.100
subnet........................255.255.255.0
default gateway ............192.168.123.254
dns server.....................192.168.123.254  (both the default gateway and dns server are set to my router, i havn't had any DNS problems so it appears that its recieving DNS from my ISP fine)

Autoconfiguration results............Passed
Default gateway test................Passed
NetBT name test...................Passed
[WARNING] At least one of the <00> 'workstation service', <03> 'Messenger service', <20> 'WINS' names is missing.
No remote names have been found

WINS service test..............Skipped
There are no WINS servers configured for this interface

Global results:
Domain membership test.................Passed
DNS domain name is not specified
DNS forest name is not specified

NetBT transports test..................passed
List of NetBt transports currently configured
Net_BT_Tcpip_{33hex char}
1 NetBt transport currently configured.

Autonet address test....................Passed
IP loopback ping test...................Passsed
Default Gateway test...................Passed
NetBT name test.........................Passed
[WARNING] You don't have a single interface with the  <00> 'workstation service', <03> 'Messenger service', <20> 'WINS' names defined.

Winsock test....................Passed
DNS test.............................Passed
Redir and Browser test.........Passed
List of NetBT transports currently bround to the Redir
NetBT_Tcpip_{same 33hex char}
The redir is bound to 1 NetBt transport.

List of NetBt transports currently bound to the browser
NetBT_Tcpip_{again same 33 hex char}
The browser is bound to 1 NetBt transport.

DC discovery test....................skipped
DC list test...........................skipped
Trust relationship test...........skipped
Kerberos test........................skipped
LDAP test.............................skipped
Bindings test........................passed
WAN configuration test..................skipped
No active remote access connections.

Modem diagnostics test..............passed
IP security test................passed
Service status is:  started
Service startup is:  Automatic
IPSec service is available, but no policy is assigned or active
Note:  run 'ipseccmd /?' for more detailed information

The command completed successfully.

0
jjk16Commented:
ive seen your config , looks like everything is normal, nothing out of the ordirnary.

KB834707 is the hot fix, guessing a typo, missing another hotfix but it doesnt look like it would cause your networking not to work.

only have couple suggestions left...

sfc /scannow

netsh int ip reset

pathping RouterIP, pc1, pc2
(if packet loss you got issues...)

Run crossover cable to pc 1 or 2 connected to pc 3
give your self static ips, have pc3 connect to pc 1 or 2,
have pc 1 or 2 connect to pc 3

format and start fresh...

 if your networking is not working you have some software that is preventing it.   Thanks for posting the diag, at the very least you got some new tools to play with.... please post your results.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RyanChAuthor Commented:
Ok, I will run through a couple of those when I get home, not sure if I have a crossover lying around anywhere, may have to make one up.  I'd pefer to avoid formatting if possible (It worked for a while after I installed XP on a fresh HD around august).  
At windows update there are a few non-critical updates (journal something or other, windows media player something or other....), none of them are really any important OS related updates.
Question about pathping RouterIP, pc1, pc2.  Isn't that basically going to be an internal traceroute where I specifify the hops?
Oh, I really should mention, the way I have my network setup here:
There are 4 wall plugs in rooms upstairs, all which run down to the basement, then out to the garage (well within the distance limit of Cat5).  In the garage I have my router, DSL modem, and an 8 port switch.  The switch is really what connects most of the ports throughout the house, including PC1 and PC2.  So basically all of the computers are running off of the switch, but recieve DHCP from my router.  
Anyway, I will run through those this afternoon.  Thank you very much for all your help jjk16
0
RyanChAuthor Commented:
I ran sfc /scannow, it took a while, but nothing appears to have been fixed.  Pathping works fine, but I still cannot conncect to the home network (even if I'm the only one on, i should still be able to see myself).  I think i'm going to call it quits and just use it the way i've got it now.  I'd like to thank everyone who helped me here, especially jkk16.  Sorry the question wasn't worth more points, it really should have been, but i don't have that many at the moment.
I appreciate your help, and if i find any fix in the future i'll be sure to let you all know.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.