OS Fails to load after mobo/CPU change

My old motherboard was acting up, so I decided to replace it. I got an Asus NForce2 A7N8X-E DELUXE and an AMD Athlon XP 3000+. After installing everything, I powered it on. I'm dual-booting Windows XP and SuSE Linux 9.1. It makes it past POST and gets to GRUB, but when I select either OS, neither will load. SuSE freezes at the boot screen, and Windows will just continue to restart, even after trying safe mode.

Everything appears to be installed correctly, however, being that I'm not A+ certified, I wouldn't rule anything out. Any ideas as to what could cause this? Thanks in advance.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Asta CuTechnical consultant & graphic designCommented:
Did you check Asus for a potential update in terms of Driver or BIOS for your MB?  See this often in dual boot with the linux bootloader residues....
karniv0reAuthor Commented:
I can't do it now, but I will try this later and post my results.
Enough power?, especially 12 volts ?

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Are you saying that you had some old motherboard/cpu combo in the system (like maybe an old intel setup) and then moved over to the amd setup?

If that is so, i would try doing a reinstall of Windows XP (try a repair) over your existing setup.

Quite often, moving from one completely different chipset to a totally unrelated chipset (intel to amd for example) will have unforseen consquences and one of them is no ablity to boot.

I have changed motherboards several time on Windows XP machines and every time I have had to format and reload. Repair installation does not work either. XP does not accept motherboard changes , well at least the OEM versions. Have not tried with retail version.
karniv0reAuthor Commented:
stockhes, not sure what you mean by enough power. I'm running a 486 Watt power supply, and I followed the manual and AFIAK, I hooked up everything that needs to be hooked up, correctly.

bobo_tech, the old mobo/CPU combo was an MSI board with an AMD XP 1600. So it wasn't a real drastic change.

WEINBERGER, it is an OEM version of XP, and it would make sense, except that SuSE won't load either. It starts to load the kernel, and it gets stuck and won't move. It doesn't panic, it just freezes.

I will also mention that I tried Knoppix, and it loaded but didn't run right. Also tried Damn Small Linux, which didn't load at all, and FreesBIE (A liveCD FreeBSD distro), which did load and work ok for the most part.
Well have you tried to do a repair install over your existing windows at least?

Also there is a tool that might help you (its a bit late for it know though) called Sysprep.  Its what we use at the university where i work to setup images that can work across various chipsets and such.

Google or goto www.microsoft.com and search for sysprep.
karniv0reAuthor Commented:
Sorry, guys. It was a dumb question after all. Not dumb enough, though, to be solved with the information I gave. I took it over to a friends house. He's a little smarter than I am, but we still couldn't get it.

At first he wondered if it was the memory. I've got two PC2100 DDRs and I just switched from the XP 1600 to the XP 3000+ which was an upgrade from a 266MHz FSB to a 333MHz FSB. He thought the RAM might be making it incompatible, but after trying PC 2700, it didn't do any good. After loading SuSE in failsafe, which showed the kernel messages, we narrowed it down to the HDD.

This motherboard is SATA capable, and we figured that since I'm not using SATA, then that must be the problem. Sure enough it was. After taking it back home I set the SATA jumper to disable (it's enabled by default) and I'm staring at my SuSE desktop. I haven't tried XP, but since I only use that for games and other Windows-only activity, I'm not too atatched to it.

Thanks anyway for all the suggestions guys.
Asta CuTechnical consultant & graphic designCommented:
":0) Asta

No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave the following recommendation for this question in the Cleanup topic area:
PAQ - Refund

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

EE Cleanup Volunteer
PAQed with points refunded (125)

Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.