My cd drives are no longer visible.

Hi there,

My cd drives are no longer visible.

WinXP
E:\ - CD-RW
F:\ - DVD-R

A common answer is to delete the upper and lower filters in the registry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318} but they were never there in the first place to delete.

Like others I have the cd drives there after boot, then after about a few minutes they disappear, and the obligitoery exclamation mark appears!!!

I don't remember doing any un-installs, other than recently closing system restore, doing a full system virus scan after a scare, followed by a Norton Windoctor. The patches on Norton are up to date. This problem may have occurred before this, as I haven't needed to use the drives in some time.

I've loaded the question at 500 points, as it is urgent!!! and I would like to get to the bottom of this without having to carry out a full WinXP install again!!!

Your help and expertise are appreciated.

Many thanks,


LoveToSpod
LoveToSpodAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mrwebdevCommented:
Try Adding a New - Administartive User, keep your existing one too, switch over to the new User and see if you have the same problem!

Also:
This is a known issue that can occur when you remove Easy CD Creator version 5.01 or earlier or DirectCD version 3.01c or earlier. This issue may also occur with Easy CD Creator version 5.01 and with DirectCD 3.01d or later.
0
garak1357Commented:
It sounds like you know what you're doing in Windows as evident by your knowledge of the registry.  In this case I would actually take a look at it as if it were a hardware problem.  I would check and see if the IDE cable is loose.  If that is not the case, replace the IDE cable and see what happens.  Sometimes the simple answer is the explaination.  Also, make sure that the IDE channel is enabled in the BIOS.  I've turned it off by accident before myself and took me hours to figure out what I did.  I hope one of these turns out to be your answer.  Good luck.
0
envoguecomputersCommented:
Have you tried updating/reinstalling the motherboard drivers? You can also look in the BIOS to make sure that the IDE channel is enabled and that PNP OS is set to yes.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

NetworkArchitekCommented:
Hi LoveToSpod,
I would remove any and all DirectCD type software you may have installed and completely disable Windows XP's little version of directCD, this can be done in the properties of the device in Device Manager. I would also, in Device Manager, remove both CDROM drives then restart and have Windows automatically install them. The main thing is to destroy DirectCD, you do not need packet-writing software. As suggested you could try swapping cables if this does not work. If all else fails, then pickup a cheap PCI IDE controller and run the drives off that. I think you have a software issue though.

Cheers!
0
nobusCommented:
try these :

0
nobusCommented:
try these : (if you suspect virus present)

http://housecall.trendmicro.com/                                           online scan for trojans
http://www.ravantivirus.com/scan/
http://www.spychecker.com/program/coolwebshredder.html            CWshredder
http://www.spychecker.com/program/hijackthis.html                           download
http://www.hijackthis.de/index.php?langselect=english                            check the log
0
LoveToSpodAuthor Commented:
Thanks all for your replies so far. I can report the following:]

mrwebdev - I tried creating a new Administrator user, but the drives weren't there still. I don't believe I had any CD burning software that I un-installed.

garak1357 - I have replaced the IDE cable for a new one, and checked the jumpers on the back of the drives. They are on the secondary IDE channel, and in the correct place. The replacement brought no change. In BIOS I have the channels selected as auto-detect. I use F3, and they show up correctly as CD and DVD in the correct place. I hit F10 and save the changes.

envoguecomputers - Haven't tried updating the motherboard drivers YET, and will look at that particular BIOS setting.

NetworkArchitek - The drives aren't visible in explorer/my computer or Device manager. I have tried to disconnect, and run windows, then re-connect and run windows again to see if that fixes it. Sometimes the drives will be there on new boot, but will disappear after a few minutes. I will try and destroy DirectCD before they disappear. I would rather re-install XP that run the drives from PCI-IDE.

To save me having to re-install XP, is there anything else I can do? If this is a well-known problem (which it seems to be), is there a patch for it out there somewhere??

Thanks for your help!!

LoveToSpod.
0
gerodimCommented:
Sometimes winXP mix up the drivers for your two drives and then make both of them invisible because they're not working anymore.
Try this. Boot in safe mode and uninstall both drives from the device manager. Then shutdown your pc and remove one of them
completely(remove the IDE cable). Boot up again normally using only one of the drives and see what happens. If the drive works normally
i'd syggest plugging the other one in the other IDE cable so as not to mix them up again.... Tell me what happened...
0
Cyber-DudeCommented:
What burning software did you have? uninstalling burning software might not be enough due to the fact that these software usually force their own hardware's drivers within the OS and you may need to remove them manually...

Cyber
0
nobusCommented:
0
mjmatCommented:
From what I am seeing above, it sounds like a short in the secondary IDE socket. If possible, get a PCI Controller card and try inserting it into an available slot and connect your 2 drives to the card. If it recognizes them and holds them, You will know that it might be time to replace mobo. The controller card cost will be minimum. I may be incorrect, but this sounds more like a hardware problem than a software issue.
Good Luck
0
mjmatCommented:
Also, a question: Are both drives connected by the same Y power cable. If so, try connecting them to another power supply feed.
0
yukeleCommented:
Hi,

I'm saying the obvious here...

I had this problem recently on my system and this is what fixed it for me (you probably tried it already)

I opened the "add hardware wizard" and after a search which found nothing, selected "Yes, I have already connected the hardware". My drive was on the list of installed hardware, I selected it and i haven't had a problem since.
0
danielwpcCommented:
I have the same experience with customer machine with Easy CD Creator uninstalled. Sorry for cannot provide you some links, but it is easy to find the solution in the web.

Two other things you can try are system resotre (not stable) or repair the XP.

Honestly, sometime it take less time to reinstall everythings than to fix a problem.
0
willcompCommented:
When troubleshooting, it is always helpful to first reduce down to bare essentials and sequence back up.

First try suggestion by gerodim with these added comments.  Connect each drive individually as master on secondary IDE channel.  Start with CD ROM.  See if either is recognized and stable.  Could be a faulty drive.

If neither drive works properly, Uninstall Easy CD Creator to completely remove its drivers.

I am surprised that you did not have upper and lower limit settings in Registry.  They are for CD-RW drives and should be in place unless previously removed.

Dalton
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
can you test the drives on another system?
0
FreddieDCommented:
I had this problem with my cd writer a couple of weeks ago and it turned out that my cd-writer had reached it's end of days,

Also try to use a new or working IDE cable,they do tend to give some problems.
0
f-kingIT support technicianCommented:
The best would be to boot from your winxp cd and do a repair install before you start thinking that the hardware has died
0
LoveToSpodAuthor Commented:
Thanks all for your help,

It was difficult trying to accept any one of the assistances above as an answer. The situation has left me as follows:

I have ended up disconnecting the CD/RW, and connecting the Primary of IDE-1 to the DVD-R - After changing the shunt on the device to MA (Master). I now have a CD of sorts!! BUT, this begs a very interesting question:

Willcomp above wrote: "I am surprised that you did not have upper and lower limit settings in Registry.  They are for CD-RW drives and should be in place unless previously removed."

My problem seemed to be like FreddieD above.

Maybe the CD/RW is faulty, or maybe it's because I never actually installed the drivers/software for the device. This may explain why I have no upper and lower limit settings in the registry.

My quest now will be to try the device on another PC, as per nobus above.

Thanks all for your help, in the depth of my heart I reckon XP has had a bit of a doo-dah, and can't fix itself.

I will add to this comment when I find out what the deal is. Hopefully this page may be of use to others in the future!!

MANY THANKS ALL,

LoveToSpod

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.