Setting up a cisco router

Hey all I'm back, well this time I'm trying to finish the configuration of the CISCO router 2621. For the most part I'm talking through interfaces ethernet0/0, Serial0/0 out to my ISP, now I'm trying to connect a second device on ethernet0/1; actions taken already configured the interface 0/1 with ip address, subnet, speed, mode.
While checking my interface it states eth0/0 is up, line protocol is down
Ok what am i doing wrong???
ramosenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cnewgaardCommented:
If you can post a config of the router.  Will make it easier to see what's going on.
0
ramosenAuthor Commented:
whats thw best way to capture the config file
0
cnewgaardCommented:
If you use a terminal connection such as hyperterminal you can click on Transfer and then Capture text and it will put it into a text file for you.  Through a command prompt (like telnetting into the router) you can click on the c:\ in the upper left hand corner next to where it says telnet then go to Edit and Mark.  It will bring up a blinking cursor block.  Then you can drag your mouse to highlight the config.  Then you hit the enter key to copy the config then paste it into a text file.   The best way to do this is to login and do a sh conf command then hit the space bar until the whole config is shown.  Then do the mark and edit and copy to the text file or directly into your post here.
0
Top Threats of Q1 & How to Defend Against Them

WEBINAR: Join WatchGuard CTO and our Threat Research Team on Aug. 2nd to hear the findings from our Q1 Internet Security Report! Learn more about the top threats detected in the first quarter and how you can defend your business against them!

sanjoybasuCommented:
line protocol is down means its not able to sense the network . Its not a big issue.
If you haveo NO device (server or switch or PC ) connected to that Ethernet port you will get protocol down. If the device is connected it must be due to bad cable.
In my experiance whenever a devise is discoonected from a ethernet port we get protocol down.
0
ramosenAuthor Commented:
Here it is;


Cisco2621#sh conf
Using 703 out of 29688 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco2621
!
enable password xxxxxxxxxxxxxxxx
!
!
!
!
!
memory-size iomem 10
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface FastEthernet0/0
description connected to Cisco PIX 501
ip address 207.xxxxxxx.1 255.255.255.0
duplex auto
speed auto

interface Serial0/0
ip address 207.xxxxxxxxx38 255.255.255.252

interface FastEthernet0/1
ip address 207.xxxxxxx.1 255.255.255.0
duplex auto
speed auto

interface Serial0/1
no ip address
shutdown

interface Serial0/2
no ip address
shutdown

ip classless
ip http server
 
line con 0
line aux 0
line vty 0 4
login


Serial0/0 is up, line protocol is up
Hardware is PQUICC with Fractional T1 CSU/DSU
Internet address is 207.xxxxxxx.38/30
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
Keepalive set (10 sec)
Last input 00:00:06, output 00:00:08, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations  0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
31729 packets input, 2086634 bytes, 0 no buffer
Received 21132 broadcasts, 0 runts, 0 giants, 0 throttles
7 input errors, 3 CRC, 3 frame, 0 overrun, 0 ignored, 1 abort
21154 packets output, 1334973 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions
DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

FastEthernet0/1 is up, line protocol is down
Hardware is AmdFE, address is 0007.8531.5f21 (bia 0007.8531.5f21)
Internet address is 207.xxxxxxx.1/24
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Auto-duplex, Auto Speed, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:02, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog
0 input packets with dribble condition detected
18130 packets output, 1087800 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Serial0/1 is administratively down, line protocol is down
Hardware is PowerQUICC Serial
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
Keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations  0/0/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=down  DSR=down  DTR=down  RTS=down  CTS=down

Serial0/2 is administratively down, line protocol is down
Hardware is PowerQUICC Serial
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
Keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations  0/0/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=down  DSR=down  DTR=down  RTS=down  CTS=down
0
RyanChCommented:
Make sure that you've got good cables on there.  That can be a royal pain in the butt if you have one small problem.  I've had this happen to be before (the line protocol down), don't remember exactly what I did to fix it (sorry), but bad cables will definately give you this problem.  
I'm not familiar with the PIX stuff too much, but just some information:
http://searchsecurity.techtarget.com/originalContent/0,289142,sid14_gci1022648,00.html
"Hackers place Cisco Pix firewall source code up for sale
A group called The Source Code Club says it's selling the blueprint for an older version of the popular Cisco Systems Pix firewall for $24,000"
You probably want to make sure to stay informed of this, at least with cisco as / if they release updates.
Also, you mentioned that you were talking through your Serial 0/0, and in the rare event you didn't notice it was down I just thought i'd point it out.

Best of luck with your configuration!
(sending text files to configure routers also comes in handy, thats another topic.)
0
lrmooreCommented:
Agree with above, if you have line up/protocol down on an Ethernet port, it is generally a physical connection problem.
In your case, it could be a L3 IP subnet overlap:
 
interface Serial0/0
ip address 207.xxxxxxxxx38 255.255.255.252 <== is this a subnet of this|?
                                                                                                        |
interface FastEthernet0/1                                                                    |
ip address 207.xxxxxxx.1 255.255.255.0   <-----------------------------------
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ramosenAuthor Commented:
Yes that was the plan, what do you mean by L3 Ip overlap?
0
alsonluoCommented:
the same ip address in both interface FastEthernet.
pls try another ip address
0
lrmooreCommented:
upon closer examinatin, it looks like all three interfaces could be overlapped...

interface FastEthernet0/0
description connected to Cisco PIX 501
ip address 207.xxxxxxx.1 255.255.255.0 <== is this a different subnet?
                                                                                               |
interface Serial0/0                                                                     |
ip address 207.xxxxxxxxx38 255.255.255.252                               |
                                                                                               |
interface FastEthernet0/1                                                           |
ip address 207.xxxxxxx.1 255.255.255.0   <== than this?------------

If these are, in fact, all three different subnets, can you verify that?

FYI, I don't see your default route statement. I would expect to see:
   ip route 0.0.0.0 0.0.0.0 207.xx.xx.37

0
ramosenAuthor Commented:
interface FastEthernet0/0
description connected to Cisco PIX 501
ip address 207.xxxxxxx.1 255.255.255.0 <== is this a different subnet?
                                                                                               |
interface Serial0/0                                                                     |
ip address 207.xxxxxxxxx38 255.255.255.252                               |
                                                                                               |
interface FastEthernet0/1                                                           |
ip address 207.xxxxxxx.1 255.255.255.0   <== than this?------------

All three are different

When will I put these
FYI, I don't see your default route statement. I would expect to see:
   ip route 0.0.0.0 0.0.0.0 207.xx.xx.37

Also my is line up with the recommendation of replacing the my cables good call you guys are great   thanks RyanCH.

So whats my next step?
0
lrmooreCommented:
Next step is to set your default gateway:

   router(config)#ip route 0.0.0.0 0.0.0.0 207.xx.xx.37

0
ramosenAuthor Commented:
Why 0.0.0.0 0.0.0.0 207.xx.xx.37 and not 38?
this is not going to interfere with my pix config?

0
lrmooreCommented:
Because your serial IP is .38
Your default route should be the next hop router. given the subnet mask on ser0/0, the only possible gateway IP is .37
0
winkingtigerCommented:
The first up and second down is always a Layer 2 problem in the OSI model.
0
abu_deepCommented:
have u try to use ( no shutshutdown ) after u get on fastFastEthernet0/1 it's interface subcommand to enable the interface which by defult is disabled...
0
abu_deepCommented:
sorry ...I typed it wrong here it is  ( no shutdown )

0
RyanChCommented:
he did use the no shutdown command, the interface is up, its just that the line protocol is down.
207.xxxxxxx.1
207.xxxxxxxxx38
207.xxxxxxx.1
I don't think the cisco IOS will allow you to set the first and third to the same IP so I think we can assume they're in a different subnet (i.e. the first might be .10.1 and the third might be .11.1)
The real question is if the second one is .11 or .10 (in my example).  Unless you're using VLSM this will cause an overlap which could be part of the problem.  
I believe that is what irmoore was trying to get at.

On your FAE interface i noticed:
Last input never
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts

Looks like a cable issue.


---The first up and second down is always a Layer 2 problem in the OSI model
It is still possible that it is a cable problem, and while the data link is often the problem, one is best off verifying the hardware first.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.