An HP mess

1.I'm on a 333 W98SE with an HP2200D. I just uninstalled program called System Suite. Afterwards printer stopped working. I was able to print from an old DOS 16-bit WP program, which controlled the hardware, but none of my windows programs would print. I got the usual error msg: Error writing to LPT1. Next I uninstalled the HP software and driver and reinstalled. After that even the DOS 16 bit program didn't work. Now on bootup I also get the messege -- too many parameters see HP help etc. (Nothing in there about too many parameters.) Clearly the it's not sending to printer port. Tried unintalling and reinstalling again. Tried the PCL6 Driver fromt he HP web site. Now I got mess. Any ideas?

2. If I really want to start over, don't I have to remove A)The software B) the drivers C) registry entries.

3) Also tried different settings for spooling, including printing directly, which froze computer up.
normanmlAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SheharyaarSaahilCommented:
Hello normanml =)

Have u read here yet ??

HP LaserJet Series Printers - Error Writing to LPT1, Device Is Not Connected or Is in Use by Another Device Message When Using an Alternate Printer Driver
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?locale=en_US&taskId=110&prodSeriesId=28861&prodTypeId=18972&objectID=bpl08778
0
normanmlAuthor Commented:
I don't think that messege applies to my case. There is no device director on the taskbar or tray. I have a configuration manager which I can choose from the start menu, but when I choose it I get a messege that tells me the device is not connected. And I'm not using an alternate driver.
0
SheharyaarSaahilCommented:
tell me one thing.... is this the only printer which is not working, or u cannot use any of the other printer ??
i just want to confirm if the problem lies within windows or with this printer configuration :-?
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

nobusCommented:
Does the printer show correct under printers? Does it work on another system?
If yes, right click the device, and check it's settings, as to which  port it prints.
If everything looks ok, i recommend uninstalling and reinstalling the printer and driver software
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
normanmlAuthor Commented:
I've tried everything, including the above. I've lost LPT1. It shows up fine in the device list, but for some reason the printer won't recognize it. Mybe I should submit this question under W98. I installed a USMB driver and the printer works fine, but I need the LPT1 to print from my 16-bit app.
0
nobusCommented:
did you check the settings? (see post above)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.