Cisco vlan trunking with other non-cisco switch

I have a 6509 and a 3548 connected via vlan trunking, but now I am trying to connect a Dlink switch to the 3548 with vlan trunking. Dlink told me that their switch support vlan tagging. I had try unsuccessfully to make a vlan trunking for the dlink and 3548 switch. I only manage to get layer 1 up and running. The following is my config for the 3548 switch

Interface fastethernet0/48
switchport trunk encapsulation dot1q
switchport mode trunk

Dlink config
ports 1 vlan 200, tagged, 802.1q

the 3548 switch trunk status is
Name: Fa0/48
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,20,50,60,101,201-203,301,302,304-310,401-429,500-504
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none


Please advise how to get it working
ghganAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

grbladesCommented:
Hi ghgan,
> Dlink config
> ports 1 vlan 200, tagged, 802.1q
Does this mean you have set the native VLAN on the D-Link to 200?
0
ghganAuthor Commented:
the native VLAN on the D-link is set to Vlan 1
0
grbladesCommented:
VLAN 200 is not active on the Cisco. Can you post the entire Cisco configuration?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

mikebernhardtCommented:
It doesn't appear that the switch port is configured to allow vlan 200. Do the following:

In enable mode:
vlan database
 vlan 200
exit
config t
interface f0/48
 switchport trunk allowed vlan add 200
0
alexcfCommented:
From what you've shown above you need to enable dot1q :)

You need to do the following:

interface port
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no cdp enable
!

That should solve the problem :)
0
alexcfCommented:
Infact, apologies, I've just re-read the post...

If I understand correctly, you're going 6509 -> 3500 -> Dlink?

Have you created vlan 200 on the 6509? It needs to get the vlan 200 tag from somewhere, so it needs to be added there. Create an interface.

int vlan 200
ip address 192.168.0.1 255.255.255.0
no cdp enable
no shutdown
!

Try that, if not, to test that the dlink is working, plug it directly into the 6509 and create a trunk port. Is the dlink switch layer2 or 3?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.