Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 787
  • Last Modified:

Exchange 2003 Smart Host (SMTP Connector)

Hello,
We use SBS2003 with Exchange 2003 and use an SMTP Connector with a smart host because we are are on a dynamic IP address. The smart host is a static IP and we're refrened it by name but some of our messages are being marked as SPAM because it is picking up that the messages were orginally sent from a dynamic IP address. SPAM Assasin flags it up as being a dynamic IP on teh SORBS list etc...

Have I configured something wrong in the connector or will the orginating IP always appear in the message header??

Thanks

Andrew
0
Flexology
Asked:
Flexology
  • 6
  • 6
  • 4
  • +2
1 Solution
 
rlindermeierCommented:
Hi Andrew,

the orginating IP always appear in the message header. I know this problem because i´m already using Dynamic IP too. The best way is to send out your messages to your ISP-SMTP-Relayserver. Please contact your ISP an ask him to which SMTP-Relay you can send your outgoing SMTP-Traffic and you don´t have such problems in future ...

Robert
0
 
ikm7176Commented:
Follow the link below, you need to use your ISP's smarthost to send your mails

http://www.amset.info/exchange/smtp-connector.asp

http://www.amset.info/exchange/dynamicip.asp
0
 
FlexologyAuthor Commented:
Robert,
I thought this was the point of a SMTP connector. We have a proper smtp server on a static IP so all we need to do is to use that to send our mail. I'm a bit confused as to what you're saying.... Our ISP has a SMTP server which we can use also.

Thanks

Andrew
0
Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

 
rlindermeierCommented:
Why does your SBS have an Dynamic IP, i think you are using an Smarthost with an static IP? If your SBS use an private IP the SPAM Assasin doesn´t mark it als SPAM.

Config your Virtual SMTP-Server to use only the internal, private IP-Adress if you are using your SBS as Webproxy ..

Robert
0
 
FlexologyAuthor Commented:
I'll explain my set-up.

We are connected via broadband (dynamic IP) to the Internet. We run our own exchange server behind our firewall. We share a webserver/mail server that handles all our smtp, pop3 & www which is on a static IP.

All i want is for Exchange to use our SMTP server on the static IP to send all our e-mail, so we opt'd for a smart host set-up but mail-headers still list our dynamic IP.

Here's a section from the mail header

Received: from 82-xxx-163-xxx.cable.ubr02.maid.xxxx.co.uk (HELO moe) (82.xxx.163.xxx)
  by mcp.34sp.com with SMTP; 8 Nov 2004 14:32:20 -0000

82.xxx.163.xxx is our dynamic IP
mcp.34sp.com is our smtp server


Thanks

Andrew
0
 
susanzeiglerCommented:
Try setting the masquerade domain to mcp.34sp.com

Here's the step by step from Microsoft. It is the same procedure in exchange 2000 and in 2003:)
http://support.microsoft.com/default.aspx?scid=kb;en-us;314331&sd=tech

That usually does the trick since it replaces the first mail-from header with the smarthost's address.
0
 
rhettleeCommented:
Like  rlindermeier said your IP will always appear on the header since the email originally came from your server.. the only difference is when you are using smarthost, the remote server you are send an email will accept it from your smarthost server. Since the email is relayed first to your smarthost server befire delivery.

When you try to email for example yahoo.com when you look in the header:
doest it say that the yahoo mail server  recieved the mail from your smarthost or directly from your dynamic IP?Anyway just check if your smarhost is really working... have you configured your SMTP connector to route all mails to your smarthost?



 
0
 
rlindermeierCommented:
OK, i´ve tested it once more ....

Your always can see the intial sending server´s ip in the Header of the e-mail. The only chance is - how i wrote it earlier - is to use an private IP at the sending server so that SPAM Assasin see not an Dyn-IP .... Try it out.

It´s normally always the best way to send by an ISP-Smarthost ......

Robert
0
 
FlexologyAuthor Commented:
My server has a private IP, as does the firewall but it's the router Ip that is getting appended to the mail header.
0
 
rlindermeierCommented:
use your ISP-Smarthost, there is nothing other that i could say ...
0
 
susanzeiglerCommented:
This is where the masquerade domain comes in--it replaces the machine in the first line of the mail from header with  the masquerade.
0
 
FlexologyAuthor Commented:
Masquerade domain is setup with our .co.uk address rather than the .local of the SBS Server
0
 
susanzeiglerCommented:
yes, and that is probably why the router IP is showing--the masquerade domain does not replace the "from address" in the message, it replaces the first host in the "mail from" header. If you change it to the smart host address, it should resolve the issue.
0
 
susanzeiglerCommented:
Actually, if you clear the masquerade domain it should work as well--although the first "mail from" header will show the private IP of your mail server. If you do not want that to show, then make it the smart host, if it is no issue to show the private IP, then remove it. Eitherway, it is the masquerade domain you have set up now that is causing your issues.
0
 
susanzeiglerCommented:
I assume that since you accepted an answer, you have been able to resolve the issue for which I am glad. I am a little surprised at the grade, however. I initially included a link to a step-by-step procedure to add a masquarade name and provided you with what that masquarade name should be (that answer should have resolved the issue). After a number of other suggestions were posted it was finally discovered that you had a masquerade domain already in place--which was probably causing the entire issue in the first place--and therefore noted that removing it should also solve your problem.

If you feel the grade is fair, that is certainly your perogative, however I I'd like to request an explanation as to why you feel it appropriate so that I may better help others in the future:)
0
 
FlexologyAuthor Commented:
The messages are still getting bounced but our masquerade is showing up our local address so you answer worked for all intent and purpose but didn't entirely resolve our actual problem but I think it's more to do with the spam filter.


sorry. I don't mind up'ing the grade if you tell me how.
0
 
susanzeiglerCommented:
I had to figure out how to do it. Basically, you leave a zero-point question in Community Support asking the Moderators to change the grade.

http://www.experts-exchange.com/Community_Support/

here's an example of a request:
http://www.experts-exchange.com/Community_Support/Q_20761911.html?query=change+grade&clearTAFilter=true

You could also request the question deleted and your points refunded since it really wasn't completely resolved.


Did you try using the smart host in the masquerade? That ought to keep the spam filters from seeing your dynamically-assigned address at all.
0
 
FlexologyAuthor Commented:
Yes our settings are:

Max Hop Count: 30
Masquerade Domain: smtp.flexology.co.uk
Fully Qualified Domain Name: smtp.flexology.co.uk
Smart Host: smtp.flexology.co.uk

It's not set to reverse lookup DNS and has no external DNS servers in place.

thanks


0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

  • 6
  • 6
  • 4
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now