Multi Boot Problem- win98, win-xp and Fedora 2

Hi experts

I am very new to linux... i hav a pc in my home and it is already dual boot.. win 98 and Win-XP..
now i got fedora 2 and i installed it in the system..after the installation the GRUB boot loader comes and lists two options Fedora and Windows...if i select windows instead of coming the earlier options, that is Win98 and Win-XP the following message is coming and the system hangs

rootnoverify (hd1,1)
makeactive
chainloader +1

so now i am not able to work in windows...

how this is happend so ?..

how i can correct this ?.. or if i install everything from scratch what shud i do to work with all the OS..?

pls cooment on this urgently

gafoor
LVL 5
gafoor78Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wesly_chenCommented:
Hi,

   Login Linux and change /etc/grub.conf as following:
--/etc/grub.conf ----
title Windows at hdb2, Windows
root (hd1,1)    <====
rootnoverify     <====
makeactive
chainloader +1
-----

Wesly
0
Ferg_y2kCommented:
Hi gafor,

this is a very common problem in fedora, happened to me a few days ago.

To solve follow these instructions

first become root user

su -

then type

sfdisk -d /dev/hda | sfdisk --no-reread -H255 /dev/hda

Read the output it may say this is not recommended and no changes have been made if so use the force option by typing this

sfdisk -d /dev/hda | sfdisk --no-reread -H255 /dev/hda --force


Restart your computer and then select windows and it will boot perfectly :)

Have Fun

Dave
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
okidachiCommented:
rootnoverify (hd1,1) ==> It looks like to have 2 separate drives for Windows and Linux. Perhaps, the problem is that your Windows drive is secondary drive. There is one thing very important here, the Windows OS cannot boot on the secondary drive, so to make it woks, login Linux and change the file /etc/grub.conf as follow:

map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,1)
makeactive
chainloader +1
boot  

The map command will exchange your drive so that the Windows OS will think it is on the primary drive and everything is done now I suppose :) ... but make sure that you name the partition correctly (hd1, 0) --> first parition of second drive, (hd1, 1) -> second partition of second drive.

Good luck,
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.