Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 24660
  • Last Modified:

530 user <username> cannot log in, home directory inaccessible. Login failed.

Hi!

I'm trying to set up some ftp account while my bro who administrates the server normally is gone (he forgot his cellphone...)

Gonna explain what I did / what I get:

Made a new website called hosted.nirwanakru.be which is a subdomain of www.nirwanakru.be, assigned the same ip, entered all the things in the dns etc.
The website has location F:\websites\nirwanakru.be\LocalUsers\hosted\

I created a new ftp site called hosted.nirwanakru.be assigned the port 666 to it and set the homedirectory to F:\websites\nirwanakru.be\LocalUsers\hosted\
Created a new user (lets call it userHosted) and gave F:\websites\nirwanakru.be\LocalUsers\hosted\users\userHosted\ as home directory
Created a virtual directory under the ftp site and called it userHosted, pointing to  F:\websites\nirwanakru.be\LocalUsers\hosted\users\userHosted\
Gave read/write permissions to this user through explorer (permissions)

Now when I try to logon on hosted.nirwanakru.be:666 with that user I get the error:
530 user userHosted cannot log in, home directory inaccessible. Login failed.

Anyone could help me on this? Did I miss something? (I'm not that driven in Windows 2003 server)

My bro is coming back way too late so any help would be HIGHLY appreciated!
0
TwEeD
Asked:
TwEeD
  • 6
  • 5
1 Solution
 
TwEeDAuthor Commented:
To summarize what I want to do:

hosted.nirwanakru.be -> accessible only by admin and will be for website
hosted.nirwanakru.be/users/<username>/ -> accessible only by  username  (isolated)
0
 
WeHeCommented:
did you give the User permissions for F:\websites\nirwanakru.be\LocalUsers\hosted too?
0
 
TwEeDAuthor Commented:
yes I did thatz why I completely don't get it
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
WeHeCommented:
did you setup the FTP site with "Isolate Users" ?
0
 
TwEeDAuthor Commented:
I'm not sure anymore, where can I check this?
0
 
WeHeCommented:
you can only choose it, when setting up the ftp.

To create a new FTP site that isolates users
In IIS Manager, expand the local computer, right-click the FTP Sites folder, point to New, and click FTP Site.
Provide the required information in the FTP Site Description and IP Address and Port Settings dialog boxes, and click Next.
In the FTP User Isolation dialog box, click Isolate users, and click Next.
Complete the remaining steps of the wizard.
Right-click the new FTP site you created, and click Properties.
Click the Security Accounts tab. If the Allow anonymous connections check box is selected, in the User name and Password boxes, type a user name and password to use to to authenticate anonymous users.
If anonymous access is allowed, create the subdirectories LocalUser and LocalUser\Public under the FTP site home directory.
If users of the local computer log in with their individual account user names (rather than as anonymous users), create the subdirectories LocalUser and LocalUser\username under the FTP site root directory for each user allowed to connect to this FTP site.
If users of different domains log on with their explicit domain\username credentials, create a subdirectory for each domain (by using the name of the domain) under the FTP site root directory. Under each domain directory, create a directory for each user. For example, to support access by user Sales\user1, create the Sales and Sales\user1 directories.
0
 
TwEeDAuthor Commented:
deleted the sited

recreated it with isolate users
set permissions for the user
created in IIS under the ftp a virtual directory called users
created under that virtual directory a directory called usesHosted
checked permissions

same error :(
0
 
WeHeCommented:
check if any of the following errors are present:
The Allow only anonymous connections security setting has been turned on in the Microsoft Management Console (MMC).
The username does not have the Log on locally permission in User Manager.
The username does not have the Access this computer from the network permission in User Manager.
The Domain Name was not specified together with the username (in the form of DOMAIN\username).
0
 
TwEeDAuthor Commented:
The Allow only anonymous connections security setting has been turned on in the Microsoft Management Console (MMC).
>> anonymous connections in a whole are not turned on, I checked my other ftp sites and nowhere was this set so figured I didn't have to

The username does not have the Log on locally permission in User Manager.
The username does not have the Access this computer from the network permission in User Manager.
>> Can't seem to find this, you mean in Adminstrative tools> Computer management > users > <username> do you?


The Domain Name was not specified together with the username (in the form of DOMAIN\username).
>> is correctly set
0
 
WeHeCommented:
some failure of mine:
>The username does not have the Access this computer from the network permission in User Manager.
This right is set in a domain policy or in Local Security Policy.
Administrative Tools -> Local Security Policy -> User right assignment -> "Log on localy"
0
 
TwEeDAuthor Commented:
Ok found it

The user is a member of users, and users is in those 2 policies

0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now