Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2395
  • Last Modified:

ASP.NET Error - Parser Error Message: Access is denied: 'DreamweaverCtrls'.

Server Error in '/' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Access is denied: 'DreamweaverCtrls'.

Source Error:


Line 256:                <add assembly="System.EnterpriseServices, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
Line 257:                <add assembly="System.Web.Mobile, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
Line 258:                <add assembly="*"/>
Line 259:            </assemblies>
Line 260:
 

Source File: c:\winnt\microsoft.net\framework\v1.1.4322\Config\machine.config    Line: 258

Assembly Load Trace: The following information can be helpful to determine why the assembly 'DreamweaverCtrls' could not be loaded.


=== Pre-bind state information ===
LOG: DisplayName = DreamweaverCtrls
 (Partial)
LOG: Appbase = file:///E:/sites/mh0405.stisd.net/wwwroot
LOG: Initial PrivatePath = bin
Calling assembly : (Unknown).
===

LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
LOG: Post-policy reference: DreamweaverCtrls
LOG: Attempting download of new URL file:///C:/WINNT/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/fbde633c/19eea101/DreamweaverCtrls.DLL.
LOG: Attempting download of new URL file:///C:/WINNT/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/fbde633c/19eea101/DreamweaverCtrls/DreamweaverCtrls.DLL.
LOG: Attempting download of new URL file:///E:/sites/mh0405.stisd.net/wwwroot/bin/DreamweaverCtrls.DLL.

 


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET Version:1.1.4322.2032
0
smetterd
Asked:
smetterd
  • 2
1 Solution
 
jpontaniCommented:
Does the ASPNET account have read permissions on the directory with the DLL file in it?
0
 
mmarinovCommented:
Hi smetterd,

try to clear your asp.net temp folder

c:\winnt\microsoft.net\framework\v.1.1.4322\Temporary ASP.NET Files
just delete the complete content - it is just a temp files

Regards!
B..M
mmarinov
0
 
smetterdAuthor Commented:
Someone had installed FP extensions onthe site, which had removed asp.net's permissions to the dll

jpontani, you hit it right on the head. good work.
0
 
jpontaniCommented:
I know that problem oh so well :).  I've had it happen to me many times, glad to hear you got it working.

Joe
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now