• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 342
  • Last Modified:

PIX Configuration

This is the question

I have a 3 public ip addresses  the first ip address has a static map to the internal interface of the pix, the other two have static mappings.  I am using access list to provice port redirection.  I want to redirect port 80 (www) to an inside address, however because the their are static mapping for the three public address i have, it seems i can not do this.
0
akita29
Asked:
akita29
  • 5
  • 3
  • 2
  • +1
2 Solutions
 
grbladesCommented:
Hi akita29,
Thats correct. If you have static mappings you are effectivly saying all ports outside for that IP are to go to the specified internal IP address. You cannot redirect a particular other port to another machine.

If you post your current configuration we can suggest ways around it for you.
0
 
akita29Author Commented:
PIX Version 6.3(3)                  
interface ethernet0 auto                        
interface ethernet1 auto                        
nameif ethernet0 outside security0                                  
nameif ethernet1 inside security100                                  
enable password
passwd
hostname
fixup protocol dns maximum-length 512                                    
fixup protocol ftp 21                    
fixup protocol h323 h225 1720                            
fixup protocol h323 ras 1718-1719                                
fixup protocol http 80                      
fixup protocol pptp 1723                        
fixup protocol rsh 514                      
fixup protocol rtsp 554                      
fixup protocol sip 50                  
fixup protocol sip udp 5060                          
fixup protocol skinny 2000                          
no fixup protocol smtp 25                        
fixup protocol sqlnet 1521                          
fixup protocol tftp 69                      
names    
access-list 1 permit icmp any any                                
access-list 1 permit gre any any                                
access-list 1 permit tcp any host 120.33.200.67 eq pop3                                                    
access-list 1 permit tcp any host 120.33.200.67 eq smtp                                                    
access-list 1 permit tcp any host 120.33.200.67 eq imap4                                                      
access-list 1 permit tcp any host 120.33.200.67 eq 8010                                                    
access-list 1 permit tcp any host 120.33.200.67 eq 8100                                                    
access-list 1 permit tcp any host 12.30.35.6                                          
access-list 1 permit tcp any host 120.33.200.68 eq pptp                                                    
access-list 1 permit tcp any host 120.33.200.67 eq 9010                                                    
access-list 1 permit tcp any host 120.33.200.66 eq 1666                                                    
access-list 1 permit tcp any host 120.33.200.68 eq 1700                                                    
access-list 1 permit tcp any host 120.33.200.68 range 27000 27009                                                              
access-list 1 permit udp any host 120.33.200.68 range 27000 27009                                                              
access-list 1 permit tcp any host 120.33.200.68 eq 2027                                                    
access-list 1 permit tcp any host 120.33.200.68 eq 2031                                                    
access-list 10 permit ip 10.0.7.0 255.255.255.0 10.1.7.0 255.255                                                              
pager lines 24              
logging on          
mtu outside 1500                
mtu inside 1500              
ip address outside 120.33.200.66 255.255.255.240                                              
ip address inside 10.0.7.1 255.255.255.0                                        
ip audit info action alarm                          
ip audit attack action alarm                            
ip local pool remote-users 10.1.7.50-10.1.7.200                                              
pdm history enable                  
arp timeout 14400                
global (outside) 1 interface                            
nat (inside) 0 access-list 10                            
nat (inside) 1 0.0.0.0 0.0.0.0 0 0                                  
static (inside,outside) tcp interface 1666 10.0.7.6 1666 netmask 255.255.255.255                                                                                
 0 0    
static (inside,outside) 120.33.200.67 10.0.7.3 netmask                                                  
static (inside,outside) 120.33.200.68 10.0.7.2 netmask 255.255.255.255 0 0                                                                        
access-group 1 in interface outside                                  
route outside 0.0.0.0 0.0.0.0 12.30.35.65 1                                          
timeout xlate 3:00:00                    
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00                                                                            
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00                                                              
timeout uauth 0:05:00 absolute                              
aaa-server TACACS+ protocol tacacs+                                  
aaa-server RADIUS protocol radius                                
aaa-server LOCAL protocol local                              
no snmp-server location                      
no snmp-server contact                      
snmp-server community                    
no snmp-server enable traps                          
floodguard enable                
sysopt connection permit-ipsec                              
crypto ipsec transform-set myset esp-des esp-md5-hmac                                                    
crypto dynamic-map dynmap 10 set transform-set myset                                                    
crypto map ipsec-maps 10 ipsec-isakmp dynamic dynmap                            
crypto map ipsec-maps interface outside
isakmp enable outside
isakmp identity address
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn3000 address-pool remote-users
vpngroup vpn3000 dns-server 10.0.7.2 10.0.7.4
vpngroup vpn3000 wins-server 10.0.7.2 10.0.7.4
vpngroup vpn3000 default-domain transmedics.com
vpngroup vpn3000 split-tunnel 10
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet 10.0.7.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:
0
 
martapCommented:


static (inside,outside) tcp interface 80 X.X.X.X 80 netmask 255.255.255.255 0 0
                                                          ^^^^^ - internal ip address you want port 80 to be redirected to.

The internal host would then be available on 120.33.200.66 :80

0
Rewarding opportunities for women in IT

Across the nation, technology jobs are vacant because there aren’t enough qualified professionals to fill them. With a degree from WGU, you can get the credentials it takes to become an in-demand IT professional. Plus, WGU’s IT programs include industry certifications.

 
akita29Author Commented:
Try it, however can not hit the web page.. i will take a look again..
0
 
martapCommented:

try to do a "clear xlate".
0
 
akita29Author Commented:
Did the clear xlate, no luck.  any other suggestions.  question on the netmask i enterd 255.255.255.255 0 0  however should it be 255.255.255.0 0 0 for a class c
0
 
akita29Author Commented:
btw i did not write it to memory, because if there an error i just need to restart the pix.  this should not be an issue?
0
 
grbladesCommented:
> static (inside,outside) tcp interface 1666 10.0.7.6 1666 netmask 255.255.255.255 0 0
You are redirecting port 1666 to an internal machine here so you can add additional ports to the list.

I am not sure if you can redirect port 80 on the external interface. I have seen problmens with this before. I would try something like :-

static (inside,outside) tcp interface 81 10.0.7.x 80 netmask 255.255.255.255 0 0
Then try to view the website from outside the network (NOT inside) on http://120.33.200.66:81.
If that works change the '81' in the line above to '80' and try again.

It wont matter that you haven't saved the config.
0
 
lrmooreCommented:
clear xlate
static (inside,outside) tcp interface 80 10.0.7.6 80 netmask 255.255.255.255
access-list 1 permit tcp any interface outside eq 80
access-group 1 in interface outside  <== always re-apply the acl

0
 
martapCommented:

damn, I missed the access-list part...

lrmoore is right, you also need to add the access-lists to allow port 80 in.
0
 
akita29Author Commented:
Thanks guys or girls.  Lrmoore you have helped in that past another good job.  martap thank you also, you started the ball rolling, both of you ROCK...
0

Featured Post

Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

  • 5
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now