Lost LPT1

1.I'm on a 333 W98SE with an HP2200D. I just uninstalled program called System Suite. Afterwards printer stopped working: Got the usual *error writing to LPT1* messege.  

2. The printer works. I also installed a USB driver and have the machine connected with both cables, USB and Parrallel. When I select the USB driver, it prints fine. When I switch to the parralell driver, error. Again, this first happened when ONLY the parralell was connected. Just wanted to test printer so I connected USB too.

3. I think that in the uninstalling of System Suite, I lost some file that was affecting LPT1. The port is good. I can see it under device manager. It's fine.

4. Question: a local tech who came over advised that I take my W98 SE-update disk and install it over my current WIB setup, thinking perhaps it would restore the file that might be preventing my printer drivers from seeing LPT1.

5. This is clearly an LPT1 issue. What can I do to restore it. I tried *remove* under device manager, rebooted, it re-installed just fine. But I still get the same error messeges when I try to get the printer to print to it.



Clearly the system can't sent sending to printer port. Tried unintalling and reinstalling again, three times. Tried updated drivers from the HP web site. No dice. It was recognize the
normanmlAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

normanmlAuthor Commented:
Please forget that last sentence. Forgot to delete it. Messege is in 1-5.
0
blue_zeeCommented:

Have you tried reinstalling the printer software?

Or even uninstalling everything printer related from Add/Remove programs, reboot and reinstall HP's software.

Zee
0
normanmlAuthor Commented:
Yes. Twice. Uninstalled all printer software and drivers. Still can't get it to print to LPT1.
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

blue_zeeCommented:

One last shot at this, to double check:

Uninstall printer software and drivers.

Reboot.

Now, again, reboot in SAFE MODE.

Go to Device Manager and uninstall/delete ALL entries under Ports (COM & LPT).

Reboot again, letting Windows reinstall the Ports.

Now, reinstall the printer software and drivers.

Check if the problem persists.

If it does, in Device Manager go to LPT1 > Properties > Resources.

Untick "Use automatic settings" and select "Basic configuration 0001", click Apply and OK.

Reboot and check again.

Good luck.

Zee

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ribs1776Commented:
Reboot in safe mode and remove all ports.  Also download the latest chipset for your 333 Mhz from intel ( If it is an Intel chipset).  Istall the latest chip set. and reboot.  If you need help to determine the chipset Intel has a chipset id program on there website.

good luck

ribs1776
0
normanmlAuthor Commented:
Zee,
It's didn't work but it was a good idea and it led me to this...

I took my W98SE disk -- the disk that update the W98 to SE -- and reinstalled the Opsys over the current setup. (I had uninstalled all printer drivers and software.) Unhooked the printer. Rebooted. Then shut down. Then reconnted the printer. Booted. Finally got one dialog from the add printer wizard. Tried to use the folder on HP disk in the instructions; no go. Wouldn't copy the driver. So I went to another folder, fould a PCL6 driver, tried that. It loaded. And I finally got the LPT1 back.

The reinstall somehow disabled some of my PS fonts. In eudora, for example, I can't get the program to see them anymore. And one of my WP -- NotaBene, gives me the following error:

NBEDITOR caused a general protection fault
in module HPBF3210.DRV at 001e:000072a0.
Registers:
EAX=4daf35e4 CS=4eaf EIP=000072a0 EFLGS=00000297
EBX=0001143c SS=592f ESP=0000c52e EBP=0000c54e
ECX=00000553 DS=4e27 ESI=00004e27 FS=0000
EDX=00004daf ES=4daf EDI=0000c5b8 GS=0000
Bytes at CS:EIP:
26 ff 1f 83 c4 08 89 56 f2 89 46 f0 66 83 7e f0
Stack dump:
4daf35e4 4daf05f8 4e27c5b8 c5404daf 0728592f 4daf35e4 00000000 4e270000 2587c581 364e4f5f 05f84daf c5744daf c5b8592f 00014e27 0728adff 01784daf.

Unlike MSWord, NB loads all fonts at startup. Anyway. I'm going to uninstall the program and reinstall and we'll see what's what in the morning.    

Some other small fallout from the reinstall but I can live with it. Anything I should look for with the reinstall. Everything seems okay, though a bit slow.
0
blue_zeeCommented:

Thanks.

See if this helps:

Missing TrueType Fonts in Fonts Folder or Programs
http://support.microsoft.com/default.aspx?scid=kb;en-us;133732

Zee
0
normanmlAuthor Commented:
Good article. Actually the fonts that went south are PS fonts. I have adobe type manager. It's on and the fonts are listed, they just won't show up in Eudora. But perhaps if I simply follow the instructions above to reinstall TT fonts, and reinstall all the fonts, it will work. Again, thanks.

0
blue_zeeCommented:

You're welcome. Hope it works.

Zee
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.