File download box when opening files accross network????

Hello everyone, I have 2 servers here.  
SERVER1 is a file server and SERVER2 is a terminal server that users connect to remotly.  While a user is logged into server2 via terminal services, they have  a mapped drive M:\  When they try to run program M:\EXECUTE.EXE they get a prompt to OPEN or SAVE the file as if they were downloading it from a web page.  If they hit open the program opens fine and runs.  I need to get rid of this open dialog box!  Anyone got any ideas?

Things Ive tried:

Mapping the drive like so; (target)
\\server1\foldername
\\192.168.1.5\foldername
janderson2kAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kain21Commented:
try adding the ip address of the server to the list of intranet sites in explorer security settings
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kain21Commented:
you'll need to add it this way \\(server ip address)... internet explorer will change it to the file format...
0
janderson2kAuthor Commented:
KAIN21, if you look at what I wrote I tried that...
0
janderson2kAuthor Commented:
Whops KAIN, I didnt understand you, sorry.
0
kain21Commented:
no problem... if you look in the bottom right hand corner of the explorer window when you open the file share on the other computer it will tell you what zone the computer believes it is in... more than likely it is saying it is in the internet zone and some security setting that is applied to this zone is causing the behavior... if you add the ip address and servername to the intranet zone then explorer will apply more leanient policies... open internet option under the tools menu in internet explorer... click the security tab, highlight local intranet, click sites, click advanced and add \\(server ip address) and \\(server name) ...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.