Unrecognised USB key - blue screen


I have a USB key (i-stick 2.0) that I've been using for quite a while.  I have XP at home and recently upgraded to SP2.  Prior to SP2 I had no problems, but now when I insert my USB key one of two things happen:
1) I get a message saying that the USB device is not recognised
2) I get a blue screen with a BAD_POOL_HEADER (0x00000019).

But, if I have the key inserted while I re-boot the computer I have no trouble at all.

I have XP SP1 at work and it works fine over there.

Can anyone help?
amoosaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

namitcCommented:
Have you tried disabling the Windows Firewall? Try different USB ports on the same computer? Downloading the updated drivers first and installing them before putting the USB device in?
0
amoosaAuthor Commented:

- I have tried different USB ports on the same computer
- I have not downloaded updated device drivers because the manufacturer says no driver is needed it simply uses Windows USB driver. (and prior to SP2 I did not use any driver and it worked fine)
- I have not tried disabling windows firewall...I'm not sure how to do that but I'll research it when I get home and I"ll give it a shot.

Thanks for your suggestions.
0
rindiCommented:
If possible visit the site of your USB device look if there are any patches related to SP2. Download and install these.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

amoosaAuthor Commented:
Already checked the manufacturers site.  I even sent them an email asking if they knew about the problem...I'm blaming SP2,but it could just be coincidental.  I'm tempted to uninstall SP2 and see what happens.
0
cpc2004Commented:
Does your I-Stick 2.0 mean that it is USB2.0?There have a lot of problem of XP SP2 relating to USB 2.0.  What is model number and manufacturer of your I-Stick?

Would you check the system event log and look for record 1001. The parameter list of bugcheck 0x00000019 are the most diagnostic information. Please repost and I will do the research on Google.

Do you install any new device besides upgrading to SP2? I'm afraid that the culprit may be a new device driver and not XP SP2.

Hope it can help you
Albert
0
Cyber-DudeCommented:
Go to the BIOS and set all resources to be managed by the OS (PnP OS=Yes).

MS are more strickted to hardware not compliant with the HCL database in SP2 thus this device may cause problems...

What Mobo you have?

Cyber
0
amoosaAuthor Commented:
I really appreciate everyone's suggestions:

cpc2004:  I'll check the system event log tonight and I'll write down the 0x19 parameters and post them here.

Cyber-Dude: The BIOS looks OK, but I'll check again tonight...I don't think there's a PnP option, but I'll check...and this may sound like a dumb question, but I'm assuming Mobo means motherboard (right?)  How do I check that???  I have a Dell Dimension 8300.

thanks.
0
cpc2004Commented:
It would be extremely helful if I know the device configuration of your Windows.

Run command msinfo32 and navigate to Hardware Resources > IRQs. Click anywhere in the right panel and then press CTRL-A and then CTRL-C. You have copied that data to the clipboard. Paste that data and repost.
0
amoosaAuthor Commented:
I REALLY appreciate the offer to take a look at my hardware resources.  But I think the problem is solved.

After hours of scouring the internet I came across a similar board to this one where someone had posted a similar question.  The problem is a device driver called ustor (ustork.sys).  This device driver is not compatible with SP2.  I'm not exactly sure how to uninstall the driver properly so I simply removed it from system32/drivers.

After removing that file the USB key works now...If anyone wants to tell me how to properly uninstall a driver I'd appreciate it, but for now I'm quite happy.

Thanks again...Not sure about points.
0
Cyber-DudeCommented:
hehehe
A simple manner to remove a driver is by searching any exsistance through the registry and simply remove it.

To view all the drivers are currently in use within your OS; just commit the following command via command prompt:
Type: 'driverquery' and press 'Enter'. To learn more use the '/?' switch...

If you want to verify compatibility just type: 'driverquery /V' and press 'Enter' (I would suggest to spill all data to a text file so that it would be much easier fo you to analyse data; i.e. driverquery /V > data.txt).

Hope that will help you for next time;

Cyber
 
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cyber-DudeCommented:
Sorry; use the '/SI' switch...

Good luck

Cyber
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.