CHKDSK DOES NOT RUN on Win2k

Running Win2k with all updates current. Every time I boot or re-boot I get the "you need to run chkdsk..." / it counts down to zero and then it asks and answers it's own question of "do I want to run chkdsk? YES/NO by answering itself with "No".  It also qualifies this answer with the statement that my drive appears to be a "non-windows 2000 disk".  I'm supposing the boot sector is corrupt, but how do I correct it?
Thanks,
Ujak
UjakAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KaliKoderCommented:
Hello Ujak,

Can you tell us what kind of File system does your OS has ? (Is it FAT32 or NTFS?) You can also tell this by looking at the chkdsk screen that you get on startup, it would tell you right there wheather the File System is NTFS of FAT.

When it asks you do you want to run chkdsk, have you tried pressing "Y" and then hit enter to answer yes ? If you have not, can you please try this ? Once it lets you, can you boot into Safe Mode ? (Press F8 during startup process, and then choose safe mode from the menu)

Thanks and Good Luck!
0
UjakAuthor Commented:
1. File sys is Fat32.
2. When it asks me if I want to run chkdsk, it doesn't give me the opportunity to answer. The "Yes/No field is populated automatically with a "NO"
3. I can boot into Safe Mode and I can boot normally but I can't do a defrag until I do a chkdsk and it won't let me do a chkdsk, either from the bootup screen or from the MSDos Prompt from Accessories or from a "Safe Mode w/ MS DOS Prompt"

ujak
0
KaliKoderCommented:
Hello Ujak,

Can you try the following:

- Boot into safe mode
- Open up a command prompt and type "chkdsk /f" (without quotes) and hit enter
- This would bring a warning to you saying, "Check disk cant be performed on this drive, cuz this drive is mounted, would you like this to be scheduled at next system startup. Press Y to say yes
- Reboot your computer normally, at system startup a chkdsk would be forced on your computer, once done it would either reboot your computer
- Now you can log on to windows Normally and try your defrag.

Good Luck!
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

KaliKoderCommented:
Also Ujak,

Since file system is FAT, it makes it bit easier. If my above comment does not work, then you should do this. You should download a WIndows 98 boot disk (from http://bootdisk.com/bootdisk.htm) and start your computer from this boot disk. This bootdisk would have the scandisk on it, scan your disk with the scandisk on the floppy, but make sure you say "dont fix errors" if it comes up with errors
0
UjakAuthor Commented:
Why "don't fix errors"?
0
UjakAuthor Commented:
Your last answer doesn't seem to be completed...

1. I tried the previous answer of starting in safe mode and setting up chkdsk to run the next time the pc boots, but it still will not permit a chkdsk to run when rebooting or shutting down and re-starting.
2. I ran scandisk from the floppy and it said that the "Media Byte" was missing.

What do I do now?

 
0
Rob StoneCommented:
0
Rob StoneCommented:
Also check this to remove the chkdsk option
http://www.regxplor.com/tweak_current.html

Run a virus check and critical update as well.

Also might be worth running SFC /SCANNOW
0
UjakAuthor Commented:
Thanks for answering.

Not exactly. What's happening is that the CHKDSK tries to run on startup but won't because it says the drive appears to be a non-windows 2k drive. When it asks "do you want to run chkdsk on this drive, YES/NO?" .. it answers itself with a "NO" and then tells me it is a non-windows 2k drive.

Ujak
0
Rob StoneCommented:
Try removing it from the bootup using the second link.

Also, is their a reason why your not using NTFS?

Did you try CHKDSK /F /R? I know you tried without the /R.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
UjakAuthor Commented:
Virus will not run. It says "The file or directory ..... Dynamic.ini is corrupt and unreadable. Please run the Chkdsk." which I cannot do.
0
UjakAuthor Commented:
I'll try your suggestions and let you know. No specific reason for not using NTFS but I am going to go back to it. I'll get back to you, probably later today.
Thank you.
Ujak
0
UjakAuthor Commented:
I ended up running Scandisk and repairing the drive. Everything except for one minor glitch is running smoothly. Thank you for your help. I am going to split the points:  150 to Kalikoder and 350 to Stoner79 plus the 20 for the Link to Question for Stoner79.
0
Rob StoneCommented:
cheers
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.