XP Pro (PATA) / XP MCE (SATA) dualboot problem.

After searching the net for solutions to no use, I stumbled into EE and wish to try my luck here. Only got 125 points, so I'm sorry if the problem is worth more...

1. Installed Win2k on SATA disk, worked perfectly.
2. Added PATA disk, Installed WinXP Pro (norwegian). Dualboot worked perfectly. Used for several months.
3. Removed Win2k, Installed WinXP MCE (SP2, english) on SATA disk. Whenever choosing MCE in the bootscreen, it halts (No loading screen)
4. Removed PATA disk, XP MCE boots (after adding ntlder and such)
5. Tried diffrent HD boot priority, boot.ini edited on both disks. RAID controller activated in BIOS and tried to put SATA disk as slave to IDE0, then the PATA disk disappears. SATA disk as slave on IDE1, then the CD-Rom disappears.
6. Tried to install XP Pro on SATA disk, behaves the same way. (Win2k not tried again)
7. Tried to install XP Pro/XP MCE with only SATA disk connected, behaves the same way.
8. Tried to install GRUB to MBR (PATA disk?). Seems like if GRUB pointed to system partition on SATA disk, it started ntldr on PATA disk. If pointed to system partition on PATA disk, then it started the correct ntldr. (Had a friend 'helping' me out with this one) Anyways, this wasnt helping as booting the system on SATA disk halts on black screen...

Noticed something strange on the PATA disk, Partition Magic 8.0 reports it as bad. No partition info and no free space reported. Windows disk manager still reports them there. The system works, all partitions accesseble..
I cant remember when this has occoured, but I once had a failure with Norton Ghost (NG made a 16 MB partition and tried to boot that repeatedly)
I think I needed to edit boot.ini or recover the MBR to get XP Pro boot again.

Any idea how to solve this? I still wish to keep XP Pro

-----
IC7 MAX3 (BIOS build date 04/27/2004)
IBM-DTLA-307045 (45 GB PATA) set as IDE0 Master
 F: 20 GB, system XP Pro (norwegian)
 G: 16 MB, GRUB files (Made by Norton Ghost, reformatted to install GRUB)
 H: 25 GB, crap files
PLEXTOR CD-R PX-W1210A set as IDE1 Master
 I:
WDC WD1200JD-00FYB0 (120 GB SATA)
 C: 8 GB, system XP MCE (english)
 D: 112 GB, crap files
KontoristaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cosol27Commented:
Step 7 is for me the important clue, you should be able to do that for sure.
Are you using the latest SATA driver disk (for XP, and your m'board) during the install (pressing F6 to install it)?

I would reset SATA configuration in the BIOS, and have another go at installing XP.

Cheers and good luck
CS
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KontoristaAuthor Commented:
Hi, and thanks for your contribution :D
I am using the SATA connection as IDE-3 Master (I see I've earlier called the 2 others as IDE0 and IDE1, lets from now on call them IDE-1 and IDE-2). But its a 3rd IDE channel, and I guess it then use a 3rd IDE controller.
System works perfectly fine until connecting PATA disk.. Could this mean that ARC path naming gets confusing after adding PATA disk? Then this should be possible to fix in boot.ini
?

I dont have a floppydrive or spare CD's, so I cant check if it works to install it in RAID mode just yet..
0
Gaud-woCommented:
Maybe you can create an additional FAT32 partition containing the SATA drivers, and point to it during install?

This is a wild guess though, I don't know if any other partitions are accessible during install, or if the drivers -have- to be on a floppy.

Perhaps the SATA drivers are on the mainboard installation CD?
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

rindiCommented:
As far as I know this may have something to do with the fact that SATA drives are looked upon as SCSI Devices by most OSs. I don't just now have a any installed system that uses both, SCSI and IDE. Maybe someone does have such a configuration and can help? The drive assignments will probably also move around depending on the interface you boot from.
0
KontoristaAuthor Commented:
Well, had in mind to install in RAID mode for a long time, but I needed first to get hands on a floppy drive before checking it.
Was not able to point at other location for SATA drivers other than floppy!

The solution was this:

I needed to to set the SATA disk to use RAID controller instead of an IDE controller. This ment I needed to use a floppy to install RAID control drivers by hitting F6 in the XP installation.  (Congrats cosol27, I guess you earned the points and get them when I close this thread)


By some odd reason an OS doesnt like to get installed on the SATA disk if its set to IDE mode. WinXP MCE wont boot, GRUB points to PATA disk even if set to point at the SATA disk, anyone know why?

It did work fine If there is no IDE disk on IDE-1 controller (maybe no HD should be on IDE-2 either).
WinXP on PATA disk always booted when asked to.

It seems to me that even if SATA disk (IDE mode) is set as first boot disk, containing MBR and NTLDR then it doesnt know where its placed in the ARC path structure or something. (at least with my mobo/BIOS)
Boot.ini points to where it presume the OS to be, but witch is wrong. So does GRUB, set to point to first partition on SATA disk, but starts ntldr on first partition on PATA disk. I would guess IDE-3 kind of got 2 adresses, one where it is (as IDE controller?) and one where it reports to be at (as RAID controller?)..

The ARC path was the same regardless of if it was installed in IDE or RAID mode:
[boot loader]
timeout=3
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="WinXP MCE" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="WinXP Pro" /fastdetect
C:\CMDCONS\BOOTSECT.DAT="Recovery Console" /cmdcons

What would the path be if it was in IDE mode on IDE-3? something like this?
multi(0)disk(0)rdisk(2)partition(1)\WINDOWS="WinXP MCE"

Well, drive letters in XP MCE are ****ed up, system set as D...  Anyone successfully done a drive letter change on system?
But hey,at least it boots with the PATA disk connected :D
0
cosol27Commented:
Glad you got it working, SATA can be problematic, Windows just doesn't handle it properly yet!

There's an on going question here at EE concerning changing the boot/system drive letter, see here;
http://www.experts-exchange.com/Operating_Systems/Q_21197912.html

Cheers
CS
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.