Linksys router at home/vpn to work

I have a linksys router (wrt54g) and it uses 192.168.1.x for my home network...I VPN into my work and then use remote desktop to connect to 192.168.1.150 on the work network...problem is...I can't do this when I'm on the router...I have to unplug from router and plug directly into my cable modem and get an ip from comcast before I can use RDP to connect to my work ip (192.168.1.150)...is there a way around this so I don't have to keep unplugging and plugging cables?  Let me know if this isn't enough info!

B
LVL 1
aero-ownerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cnewgaardCommented:
Try changing your ip's from the router on your home side.  The problem is that the Linksys at home is using the same network as your work does.  When this happens the RDP client is trying to connect locally instead of over the VPN causing your connection to fail.  That's going to be your easiest shot considering it's probably not feasible to change the IP's on your work network.
0
aero-ownerAuthor Commented:
well...in my linksys all it gives me the option of is what the starting address is for DHCP 192.168.1 is hardcoded....
0
cnewgaardCommented:
If you change your LAN IP address on the Linksys and apply it (and write it down as you will probably need to set your PC up to access it for configuration) it should change the DHCP options to the new network number.  
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

aero-ownerAuthor Commented:
Really? I'll give that a try...
0
aero-ownerAuthor Commented:
wow...I'm a tool...never thought of that...just figured it was hardcoded for that subnet....thanx a lot!
0
gokalpsCommented:
Aero-owner,
Can you explain a little about what you did to make this work? I am having the same exact problem. I changed the IP address of the router to 192.168.10.1 but did not change the subnet mask. then disabled the DHCP server.
As a result of that, nothing worked and lost my internet connection. Had to reset to defaults.

Thanks in advance,
Gokalp
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.