XP can't detect USB printers

USB ports work properly and auto detect any USB device that is plugged in except USB printers. When a USB printer is plugged in I get the following error message:

"Cannot Install this Hardware
There was a problem installing this hardware:
USB Printing Support
An error occurred during the installation of the device.
The data is invalid"

Printer drivers are installed for Epson Stylus C60 and Canon i9100, but when looking in printer configuration / Ports, there is no USB options listed. Neither can they be found when selecting "Add" to add another port.

AMD Athlon 1700+, 512MB RAM, Windows XP Home
rballAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TommyTupaCommented:
Start here.  
Goto: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ENUM\PCI
Right click PCI and choose permissions.
Set Administrators, System to Full Control.  Then click advanced and make sure it says System - Full Control.


0
rballAuthor Commented:
I checked out the permissions in the registry as you suggested. Interestingly, I found that there was no Administrator set, just System and User. I set both to Full Control to see if it helped. Unfortunately there was no change. Still doesn't detect USB printers and USB Printing Support fails to install.

Thanks,

RC
0
jvuzCommented:
Can you install the printer on another pc and see what happens.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

nobusCommented:
did you install the software first, and plug then the printer in?
0
nobusCommented:
If the problem persists, you can try running sfc /scannow from the run box (start>run) to repair damaged system files,or
you can delete the usb devices in the device manager, and reboot.
0
rballAuthor Commented:
jvuz & nobus - Yes, both printers work on other pc's and yes, I did run sfc /scannow. I should note that one of the printers, the Epson C60, has both USB and parallel ports. It will operate correctly in parallel mode, but not USB.

The problem is quite strange because I can plug any other USB device into any USB port and it is recognized, but not a printer. I believe the problem is with "USB Printing Support" which is supposed to be installed when a USB printer is detected. When I plug in a USB printer, I get the USB printing error mentioned earlier.
0
TommyTupaCommented:
-Wondering if you have Service Pack 1 because thats when drivers for USB2.0 came around.
-Also, I would check out Lexmark support.  They have great printer support there.  For instance, here are two documents which may be of use:
http://support.lexmark.com/cgi-perl/knowledgebase.cgi?ccs=229:1:0:340:0:0&framed=&docid=710&relevance=1
http://support.lexmark.com/cgi-perl/knowledgebase.cgi?ccs=229:1:0:340:0:0&framed=&docid=ENUS12715&relevance=1
0
nobusCommented:
did you uninstall the usb devices?
0
rballAuthor Commented:
Tommy - Service Pak 2 currently installed. I'll check out the URL's you suggested. Thanks.
0
rballAuthor Commented:
Nobus - Yep. I've uninstalled and reinstalled both the printer drivers as well as USB. Thanks.
0
rballAuthor Commented:
The problem is now fixed. Was eventually solved by doing an in-place reinstall of XP and then reinstalling SP2

Thanks to all who offered suggestions.

RC
0
Nyah247Commented:
Have you checked the BIOS USB device settings?  Some devices have difficulty connecting when Legacy or High Speed USB is disabled.  Try toggling the settings and see if this helps.  Just be sure to note what changes you make so you can undo them if needed.  Usually you can get into the BIOS settings by pressing F1, F2, Esc, or something of that nature during the POST check...  It just depends on your board.

Also you may want to check your board/computer's manufacturer for driver and BIOS updates.  
0
hdhondtCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave a recommendation in the Cleanup topic area that this question is:
PAQ/Refund
Any objections should be posted here in the next 4 days. After that time, the question will be closed.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

hdhondt
EE Cleanup Volunteer
0
moduloCommented:
PAQed with points refunded (250)

modulo
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.