CVS on solaris : no such repository



I am trying to setup cvs-1.11.17 server on solaris 9 sparc. I did as follows:

1. Created a cvs group, assigned and given all permission to
/opt/repository/CVS

2. $ cvs –d /opt/repository/CVS init

3. $ CVSROOT=/opt/repository/CVS
   $ export CVSROOT

4. $ cvs import -m "Imported sources" test test start
now I could check out and check in on the same machine.

5.  added in inetd.conf
cvspserver stream tcp nowait root /opt/sfw/bin/cvs cvs -f --allow root=/opt/repository/CVS pserver

6. added in services
cvspserver      2401/tcp                        # CVS port for remote

restarted inetd and services

now I want to access the cvs from different server as follows:

:pserver:admin@serversideonline.com:/opt/repository/CVS

but getting “connection refused: no such repository”

on local machine I even tried as follows:

$ CVSROOT=:pserver:admin@myserver:/opt/repository /CVS
$ export CVSROOT
$ cvs login
Logging in to :pserver:admin@ myserver:2401/opt/repository /CVS
CVS password:
/opt/repository /CVS: no such repository

Could anyone tell me what is wrong here?
mrhafizAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

yuzhCommented:
Try:

cvs -d :pserver:admin@myserver:/opt/repository/CVS login

PS: should have no space between:/opt/repository and /CVS

for more details see :
http://lists.gnu.org/archive/html/info-cvs/2002-08/msg00111.html
0
mrhafizAuthor Commented:
Thanks for the response. That was a typo. I tried with

cvs -d :pserver:admin@myserver:/opt/repository/CVS login

but it still returns:

$ cvs -d :pserver:admin@myserver:/opt/repository/CVS login
Logging in to :pserver:admin@myserver:2401/opt/repository/CVS
CVS password:
/opt/repository/CVS: no such repository

in /opt/repository/CVS, i have

CVSROOT  testproj

0
stefan73Commented:
Hi mrhafiz,
You're probably better off by connecting to your CVS server with SSH. It's the better choice, since it needs no additional ports open, services or inetd changes.

Cheers!

Stefan
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

TintinCommented:
I'll second the ssh option.

You just need to set

CVS_RSH=ssh

CVSROOT=:ext:admin@myserver:/opt/repository/CVS

0
ahoffmannCommented:
did you check your files in CVSROOT/ and CVSROOT/CVS/
in particular  CVSROOT/modules
0
yuzhCommented:
Have you restart "inetd"  deamon after you edit inetd.conf and /etc/services files?

eg:
   ps -ef | grep intetd | grep -v grep
   kill -HUP process_id
   restart the inted deamon
   

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.