• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5523
  • Last Modified:

ARCserve 9.01 in NetWare 6.5 error E0007 Server is low on memory

I've a BrightStor ARcserve for Neware 9.01 patched running on a Netware 6.5 SP 2,
the server as 1 GB RAM.
When the backup job start I got the Error message
"E0007 Server is low on memory. Cannot start jobs until memory is restored"

I've reinstalled ARCserve with all the patches, unloaded unused modules, but nothing,
always same error message.

Any idea how to resolve it ?
0
fpifferini
Asked:
fpifferini
  • 8
  • 7
  • 7
  • +2
19 Solutions
 
PsiCopCommented:
If you loaded a DOS before you loaded NetWare on this machine, then make sure a HIMEM.SYS statement is not in C:\CONFIG.SYS. If you loaded the machine straight from the NetWare CDs, this is not an issue.

I don't think you'll need it in NetWare v6.5, but it can't hurt to include a RESERVED BUFFERS BELOW 16 MEG=200 statement in C:\NWSERVER\STARTUP.NCF, if that is not already there.

How much disk space is on this server? How is the RAM consumption after ARCserve is loaded but *before* it starts processing a job? How much RAM is available as cache?

Are there any NDS replicas on this server?
0
 
ShineOnCommented:
Next set of questions -

Was the server a fresh install of 6.5 or an upgrade - in other words, does it have legacy volumes or is it all NSS?  

If it's all NSS, have you tuned for NSS performance?

What NSS attributes are turned on, on the volumes?  Backup?  Compression?  Snapshot?  Migration?  Shredding?  ??

Is this a multiprocessor server?

Have you tuned your ASCONFIG.INI or is it still default?

Have you applied the latest post-SP2 eDirectory IR patch??
0
 
fpifferiniAuthor Commented:
Answers:
1. HIMEM.SYS not in C:\CONFIG:SYS
2. RESERVED BUFFERS BELOW 16 MEG=300
3. Allocated memory in pool      291 MB
   Cache buffer memory          471 MB
   Cache movable memory              0 MB
   Cache non-movable memory       1 MB
   Code and Data memory          66 MB
   Misc. memory                 243 MB
   Total server work memory    1073 MB
   
   (this before job start)
   
4. Server was fresh installed
5. All volumes are NSS
6. NSS attribute ON: Backup, Salvage Files, Directory Quotas, User Space Restriction
7. Is not a multiprocessor server, is a Xeon 2.4 GHz (HP ML370G3)
8. Default ASCONFIG.INI
9. Post-SP2 eDir patch: not sure if it's installed

Now I've made some change in the BTI.CFG file:
[MicroKernel]
MaxFiles=250
MaxCursors=200
Cachesize=65536 (ignore the 20% warning)
MaxClients=120
BackgroundThreads=25

[Btrieve Communications Manager]
MaxWorkerThreads=25
MaxRecSize=65116
MaxClients=120
MaxReceivePacketSize=1500

I will check asap if it's work...
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
PsiCopCommented:
1) and 2) Good.

3) Hmmm...43% RAM as Cache. A little low, but should be tolerable for NetWare v6.5. I'd suggest planning to add a bit more RAM - 1.5 GB total should do nicely.

4) OK.

5) and 6) Is the ARCserve user restricted as to disk space consumption, or is it exempted? Should be the latter.

7) and 8) OK.

9) Its only relevant if this server holds an NDS replica.

Keep us advised.
0
 
ShineOnCommented:
Are you running the ProLiant ACPI manager that makes the G3 Xeon look like 2 processors?  I think it's CPQACMGR.NLM?
0
 
DSPooleCommented:
1. Load Netware’s Console Monitor ("LOAD MONITOR") from the server console screen and select Resource Utilization. This should tell you the Total Server Memory and the Cache Buffers available. Novell recommends that the available cache buffers be at least 30%. If it is below 30%, add more memory to the server. If it is above 30%, go to Step 2.

2. From the ARCserve Scheduler Console, select Configure ARCserve Server. The Minimum Cache Buffers Required to Start Jobs must be less than the Available Cache Buffers from Step 1. The default setting is 10%. If this setting is fine, go to Step 3.

3. Modify the file server‘s STARTUP.NCF file and add the following statement (note the syntax):

SET RESERVED BUFFERS BELOW 16 MEG = 300; (200 for 3.11 server)

This statement should go in as the first line of the STARTUP.NCF on the file server. It at least should be before any LAN or DSK drivers load. Then the server must be restarted for this change to take effect. Also ensure that the driver for the SCSI controller is up-to-date.

0
 
PsiCopCommented:
Oooo....good one. Yeah, we had that problem on some IBM x-series servers, where the ACPI support module that the NetWare install selected made the system appear to have 2x CPUs. The fix was to run MPS14.PSM instead (just change the entry in STARTUP.NCF).
0
 
ShineOnCommented:
Are you getting any error messages when the PFC is running?  (besides the 20% warning...)

You might want to consider turning off the "backup" setting in NSS, since ARCserve 9.x doesn't use this feature.  If you upgrade to ARCserve 11.1, I think it does use that feature, but until then, it could be working against you.  Just a thought...
0
 
ShineOnCommented:
How do you have your cache balance setting set for NSS?  Since you don't have any Traditional volumes, it should not be set to the default.  I have mine set to 80%, but that's just because I'm conservative, but you should have it set to at least 80%.

To check, type "NSS STATUS" at the server console.
0
 
ShineOnCommented:
Speakin' of SCSI controller - are you using the CANWPA tape drivers instead of NWASPI?  Did you make sure to remove the ASPI driver loads from STARTUP.NCF?
0
 
DSPooleCommented:
that and make sure NWTAPE.CDM is not loading...
0
 
fpifferiniAuthor Commented:
1. I use admin user for backup, he isn't involved in the user space restriction.
2. The server as a Read-Write partition on it
3. I don't have any other message when PFC is running.
4. Cache balance set for NSS is 85%
5. I'm using CANWPA tape drive
6. I've see that NWTAPE.CDM is loaded, but usually this cause an error message on starting ARCServe,
    when is seraching Tape Drive, is not my case.
7. After BTI.CFG optimization, the backup of yesterday was successfull without error message !!!
    But I will monitor the backup in the next days....
0
 
ShineOnCommented:
Make sure the eDirectory IR is installed.  the eDirectory with SP2 had memory leak issues, IIRC.
0
 
fpifferiniAuthor Commented:
What exactly the filename of the eDirectory IR patch ?
I'ven't find it on Novell website
0
 
DSPooleCommented:
shut down ARCserve
unload NWTAPE
rename NWTAPE.CDM to NWTAPE.XXX in the C:\NWSERVER\DRIVERS\ folder
   (this will prevent NWTAPE.CDM from loading automatically when your SCSI drivers load)
reload ARCserve

you do NOT want NWTAPE.CDM running.

0
 
ShineOnCommented:
0
 
PsiCopCommented:
While the admin user is not affected by user space restrictions, the account can still be affected by DIRECTORY space restrictions, if you employ those. But hopefully you've found the issue.
0
 
DSPooleCommented:
Cachesize=65536 in the BTI.CFG is the absolute minimum you can use.
0
 
fpifferiniAuthor Commented:
Back again,
finally we hade time to update the server with eDirectory 8.7.3.3
unfurtunatelly this can't resolve the problem of
E0007 Server is low on memory. Cannot start jobs until memory is restored.

Any other suggestion ?
0
 
PsiCopCommented:
Did you increase the RAM any, or is it still at 1 GB?
0
 
fpifferiniAuthor Commented:
I had the problem with 512 MB, I've increased to 1 GB thinking that was sufficient,
but same error.
I will check if I can add more RAM
0
 
PsiCopCommented:
Hrm. Interesting. You're at 1 GB but RAM as Cache is only 43%. Gads, what was it when you only had 512 MB?

I'm not convinced that adding RAM will help, but I'd like to eliminate the "simple" things, yanno?
0
 
fpifferiniAuthor Commented:
I don't remember what was the Cache with 512 MB...my first idea was to increase the RAM....
I've see in the Novell forums that another person as the same problem...Someone as siggested TID 10091980,
I would like monitoring answer to this person....
0
 
PsiCopCommented:
Its possible some tuning would help the issue. Certainly worth a try.
0
 
pgm554Commented:
Try adding this statement to the asconfig.ini:

CSNLM6=SYS:\ARCSERVE.6\NLM\CANWPABD USEABOVE16 CLEAR

Otherwise the issue could be the way Arcserve looks for cache memory.On TNFS volumes cache buffer actually means something, whle on NSS the old cache buffer stat is somewhat useless forom monitor.
0
 
fpifferiniAuthor Commented:
After the suggested fix steps in the TID 10091980 the problem seams to be resolved.
Now my ARCserve run fine without the message
"E0007 Server is low on memory. Cannot start jobs until memory is restored" !
Thank you to all
0
 
PsiCopCommented:
Glad its working
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 8
  • 7
  • 7
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now