[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 201
  • Last Modified:

sendmail with nameserver configuration

After i changed hosting company, the sendmail in script does not work.
It send email to admin but not to registered user. It use to work in previous hosting company.
Here is the setting i have now.

*.kaufff.com. MX 10 kaufff.com
*.kaufff.com. A   63.247.87.231
kaufff.com. MX 10 mail.kaufff.com
kaufff.com. MX 10 kaufff.com
kaufff.com. A   63.247.87.231
mail.kauff.com. A   63.247.87.231
pop3.kaufff.com. CNAME   kaufff.com
smtp.kaufff.com. CNAME   kaufff.com

in nameserver is not allow to enter 0 for MX. So i gave value 10.
0
tilmes
Asked:
tilmes
1 Solution
 
periwinkleCommented:
The MX records are NOT why your script is having problems, but there are definitely some errors here.  You need to have varying MX values for the various mail servers.  In fact, the multiple MX records are highly redundant, as they all point to the same IP address:

kaufff.com. MX 10 mail.kaufff.com
kaufff.com. MX 10 kaufff.com

I'd remove the secondary MX record - you don't need it.  If you must keep it, you should raise one of the priority values, or else sendmail will be confused over which to use.

For your script, are you certain that you have the correct path to sendmail?  Can you contact your web hosting company to find out what the error is in the maillog for that outgoing email?

0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now