Strange NFS automounter problem

Hi...

Currently, I have a NFS server running on Solaris 9, which share out user's home directory.
All my clients are using Sun Ultra 5/10 workstation. All these workstation is running on SunOS 5.5.1.
Below is the auto_master and auto_home for all my client's workstation.

# Master map for automounter
#
+auto_master
/net            -hosts          -nosuid
/auto_home      auto_home
/xfn            -xfn
/home1          /etc/auto_home


# Home directory map for automounter
#
+auto_home
*       myserver:/home1/&


All my clients was able to automount all the directory in home1, but some client workstation encounter some strange problem when they mount to the directory in home1.

This is the problem I'm encounting now. Let say my /home1/user1 directory contains the following files/directory in it.

drwxr-xr-x  34 usr   staff       1024 Oct 14 09:13 old
drwxr-xr-x  55 usr   staff       2048 Oct 11 08:47 used
-rw-r--r--   1 usr   staff       1613 Nov  2 08:nov01_19_37
-rw-r--r--   1 usr   staff      13372 Nov  2 08:nov01_19_46
drwxr-xr-x   4 usr   staff        512 Oct  3  2003 TRAIN
drwxr-xr-x  25 usr   staff        512 Oct 29  2002 archieved
drwxr-xr-x  15 usr   staff        512 Apr 18  2003 debug


On the problematic client workstation, when I 'cd' to /home1/user1 and do a 'ls', I only get the following output.

drwxr-xr-x  15 usr   staff        512 Apr 18  2003 debug
drwxr-xr-x  34 usr   staff       1024 Jan 12  2004 old
drwxr-xr-x  50 usr   staff       1024 Nov  9 13:39 used

When I update certain files in /home1/user1 directory on the problematic client workstation, the update is not reflected on the server home directory.

This is a very strange problem as I'm able to automount to the shared folder, but I'm not able to view all the files/folder in it. Somemore, the updates done on the problem workstation onto the shared automount directory is not reflected on the server.

Someone pls help.
Thanks.
LVL 3
ShadowWarrior111Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rugdogCommented:
when you say "some cliente workstation", do you mean just one or many?
i would do the following:
- check for clues in /var/adm/messages on server and client
- try to mount the NFS manually onto another mount point in the client and check if that way works
- try to ls /net/server/home1/user1  and check if  that works
- try to mount another machine NFS onto the client to see if it behaves the same

That of course won't fix the problem but will probably give more clues for researching further

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ahoffmannCommented:
check /var/adm/messages and/or /var/log/syslog
then check on both server and client:
  rpcinfo | egrep 'mount|nfs'

the second column in the result tells you which NFS version is used
both, client and server should have the same (1, 2, 3 usually)
0
ShadowWarrior111Author Commented:
Currently, I have around 5 client workstation facing this problem. Below is the answer to some of the question.

1. There's nothing unusual found on the messages for both the server and client.

2. When I do manual NFS mount of the home directory, I'm able to see all the files, but the automounted home directory still display certain directory only.

3. I'm able to do `ls /net/server/home1/user1`

As I'm not able to reboot these problematic workstations for the time being, I'm not able to determine whether this problem can be solved once rebooted. I'm also not able to unmount the current home directory as it is being used.

Is there any solution out there to fix this strange problem?

Thanks...
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

rugdogCommented:
so, in point #3 you are able to do the ls /netc/server/home1/user1, do you see al its files?

I would try to restart the automountd and nfs.client.

check out for patches regarding automount and nfs for sunos 5.5.1 at sunsolve:

http://sunsolve.sun.com/search/startadvsearch.do?pageId=bycollection

the ones I found for automount:

104654-05
104055-03
103928-02

for nfs there's a bunch.

Also, try this:

cd to /home1/user1/
and do a
truss ls -la

see if by any chance the files that are hidden are attempted to be read.


0
ahoffmannCommented:
I'd reboot the server, on the client it's sufficient to stop and start all mount/nfs services (including portmapper)

Also: I'm still waiting for the results of rpcinfo ...
0
ShadowWarrior111Author Commented:
Hi rugdog/ahoffmann,

Thank you both for your help. 1st of all, I'm not able to reboot the workstation as the workstation is being used to run some application. Somemore, when I try to stop/start the nfs daemon, it will say that home drive is busy..
Anyhow, the problem is solved once I reboot the workstation.

I'm really thankful for both your help. How do I split the points between you two?

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.