Local intranet server not responding to client page requests

Posted on 2004-11-09
Last Modified: 2008-01-09
I'm using SBS 2003 (server/standard) and it has enough problems as it is...but in particular I seem to have a DNS/IIS issue so I've come here first...

from a clienet workstation, the TCP/IP settings are as follows:




192.168.*.* Primary DNS and also SBS/DNS server/ADS
192.168.*.* Secondary DNS/2K3 Standard/ADS

in this configuration the DNS name of the intanet page cannot be loaded i.e. HTTP://FPNET (local intranet) - 404 page not found

if i rotate the DNS to show secondary first, primary second etc.

HTTP://FPNET  ==  voila, page there are currently no DNS issues other than revese lookup on 2K3 Std server not fully configured.

All answers welcome
Question by:SHIELD1
    LVL 9

    Accepted Solution


    Let's determine if it's your DNS server(s) or what.  Let's go to a DOS prompt from your workstation, and type  the following commands in order:
    server 192.168.*.* (where it's the IP address of the primary DNS)
    (write down the result IP address)

    server 192.168.*.* (secondary DNS IP address)
    (write down the result again).

    Now let's compare the results.  Did the first server return the IP address?  Is it the right IP address?  Did the second server return the IP address (I'm assuming yes)?  Is it the right IP address (also assuming yes)?

    If the IP addresses were returned by both servers, but they were different from eachother, I'll have to assume that your DNS servers were setup in a non-Active Directory and are not replicating with one another.  If one is returning the IP address but not the other, then it's the second server's DNS configuration is out of whack.

    Let's get some answers from you first so we can determine the rest.

    LVL 6

    Author Comment

    Splendid, thanks for your interest in my problem!...ok, NSLOOKUP, addmittedly I've never used that to resolve internal IP addresses!

    But in answer to your queries, both servers bring back the right IP address for FPNET, regardless of which server is listed as  the 1st or 2nd DNS server.

    **** I need to point out here that there is a manual entry for FPNET in DNS, FPNET-------ALIAS(CNAME)-------------SVR1 but this has had little effect :( ****

    Anyway, becuase of this I decided to check the intranet again from the client PC - - and FPNET came up straight away...the question is, is now a cached DNS record? or in internet explorer?

    """"I'll have to assume that your DNS servers were setup in a non-Active Directory and are not replicating with one another"""" I like the way you think :) but no, ADS was fully configured and replicating with no replication erros...however I have had to manually setup and configure DNS on SERVER 2...and as I said at time of POSTING
    was also copying reverse lookup from SERVER 1 (SBS) to server 2.

    so far no joy....
    LVL 9

    Assisted Solution

    That's interesting.  But if you asked me, I'd say the first time it tried to lookup FPNET the DNS server did not have the record, but when you tried it again, it had already replicated.  Is that likely to have happened?

    The reason I am thinking that way is because the DNS1 was responsive when you tried it before your initial post.  If it wasn't responsive at all (DNS is down) it would have tried the second DNS server on the list.  But because it wasn't able to resolve it, it means it was not recorded in its DNS table.

    LVL 6

    Author Comment

    Hey JM, thanks for sticking in there with me i appreciate your help (two minds r better than 1 !!!) to be honest I'm left scratching my head...the easy way out is to just rotate the DNS on the client workstations!? In other words let the let DNS2 be preferred?  Because that works...but then am I being lazy and complacent?

    If u don't mind can i leave the topic open for another day or so?  I've upped the points because now this more of a discussion than problem and i'm curious to see how it develops.

    Thanks again
    LVL 6

    Author Comment

    I've decided to close this question for two reasons, I have failed to generate any new information on it and secondly,
    what would seem to be by fluke, I may have solved the problem:

    It would appear that none of my servers were set up as master browser, in addition, although I was automatically propagating LMHOSTS records to my workstations,
    none of my servers were using LMHOSTS.

    After setting 1 server as browser master in the registry:

    setting =FALSE to =TRUE

    this information may be of use to some one :)

    Featured Post

    Highfive + Dolby Voice = No More Audio Complaints!

    Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

    Join & Write a Comment

    Debug Tools to analyse IIS process: This article focus on taking memory dumps from IIS to determine which code is taking more time and to analyse which calls hangs/causes more CPU usage. To take dumps,download the following. Install1: To st…
    If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

    729 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now