Local intranet server not responding to client page requests

I'm using SBS 2003 (server/standard) and it has enough problems as it is...but in particular I seem to have a DNS/IIS issue so I've come here first...

from a clienet workstation, the TCP/IP settings are as follows:




192.168.*.* Primary DNS and also SBS/DNS server/ADS
192.168.*.* Secondary DNS/2K3 Standard/ADS

in this configuration the DNS name of the intanet page cannot be loaded i.e. HTTP://FPNET (local intranet) - 404 page not found

if i rotate the DNS to show secondary first, primary second etc.

HTTP://FPNET  ==  voila, page loads...now there are currently no DNS issues other than revese lookup on 2K3 Std server not fully configured.

All answers welcome
Firmin FrederickSenior IT ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


Let's determine if it's your DNS server(s) or what.  Let's go to a DOS prompt from your workstation, and type  the following commands in order:
server 192.168.*.* (where it's the IP address of the primary DNS)
(write down the result IP address)

server 192.168.*.* (secondary DNS IP address)
(write down the result again).

Now let's compare the results.  Did the first server return the IP address?  Is it the right IP address?  Did the second server return the IP address (I'm assuming yes)?  Is it the right IP address (also assuming yes)?

If the IP addresses were returned by both servers, but they were different from eachother, I'll have to assume that your DNS servers were setup in a non-Active Directory and are not replicating with one another.  If one is returning the IP address but not the other, then it's the second server's DNS configuration is out of whack.

Let's get some answers from you first so we can determine the rest.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Firmin FrederickSenior IT ConsultantAuthor Commented:
Splendid, thanks for your interest in my problem!...ok, NSLOOKUP, addmittedly I've never used that to resolve internal IP addresses!

But in answer to your queries, both servers bring back the right IP address for FPNET, regardless of which server is listed as  the 1st or 2nd DNS server.

**** I need to point out here that there is a manual entry for FPNET in DNS, FPNET-------ALIAS(CNAME)-------------SVR1 but this has had little effect :( ****

Anyway, becuase of this I decided to check the intranet again from the client PC - - and FPNET came up straight away...the question is, is now a cached DNS record? or in internet explorer?

""""I'll have to assume that your DNS servers were setup in a non-Active Directory and are not replicating with one another"""" I like the way you think :) but no, ADS was fully configured and replicating with no replication erros...however I have had to manually setup and configure DNS on SERVER 2...and as I said at time of POSTING
was also copying reverse lookup from SERVER 1 (SBS) to server 2.

so far no joy....
That's interesting.  But if you asked me, I'd say the first time it tried to lookup FPNET the DNS server did not have the record, but when you tried it again, it had already replicated.  Is that likely to have happened?

The reason I am thinking that way is because the DNS1 was responsive when you tried it before your initial post.  If it wasn't responsive at all (DNS is down) it would have tried the second DNS server on the list.  But because it wasn't able to resolve it, it means it was not recorded in its DNS table.

Firmin FrederickSenior IT ConsultantAuthor Commented:
Hey JM, thanks for sticking in there with me i appreciate your help (two minds r better than 1 !!!) to be honest I'm left scratching my head...the easy way out is to just rotate the DNS on the client workstations!? In other words let the let DNS2 be preferred?  Because that works...but then am I being lazy and complacent?

If u don't mind can i leave the topic open for another day or so?  I've upped the points because now this more of a discussion than problem and i'm curious to see how it develops.

Thanks again
Firmin FrederickSenior IT ConsultantAuthor Commented:
I've decided to close this question for two reasons, I have failed to generate any new information on it and secondly,
what would seem to be by fluke, I may have solved the problem:

It would appear that none of my servers were set up as master browser, in addition, although I was automatically propagating LMHOSTS records to my workstations,
none of my servers were using LMHOSTS.

After setting 1 server as browser master in the registry:

setting =FALSE to =TRUE

this information may be of use to some one :)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.