Why a -1017 error is encountered on the Exchange server while recovering Priv.edb

We had been facing a problem on our Exchange server for last ten days. When a user tried to send a message the process used to terminate with an error "The operation failed". We ran an integrity check with ESEUTIL /G /ISPRIV /X /V and it revealed that we have errors in the database. An envent ID 195 was being recorded in the eventlog "MSExchangeIS ((606)) Internal trace: lv.cxx@400.

The result of the integrity check showed that we have JET Error -1206 on table "Msg" with bad leaf page links. Table "DeliveredTo" had the same problem as table "Msg". Other errors included were as described below:

Table "1-8FA11" 1131 index entries inconsistent
Table "1-2EC03" 32 index entries inconsistent
Table "1-2EC03" 412 index entries inconsistent
Table "1-2EC03" 25 index entries incosistent
Table "1-24" bad page pointer to leaf page and subtree check failed with err -1206

On seraching the microsoft knowledge base we came accross an KB#181824. This artical described the similar problems and we started the receoved according to the guidelines set forht in the artical. The ese.dll was copied to the system32 directory and ESEUTIL /p started on priv.edb.

Almost at the end of the process eseutil was terminated with error -1017 and even id 138 was recorded in the eventlog for maybe 100 times. Description of this event id is ((123)) The database engine lost one or more bad columns of data in one record.

We are not able to proceed further as the ESEUTIL /D terminates with same error -1017. Any suggestion, how we should proceed further?
LVL 1
atiqcAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

marc_nivensCommented:
Your database is unrepairable.  If it still mounts you can use Exmerge to get the mail out.  Otherwise you're looking at a 3rd party solution such as ontrack (www.ontrack.com).
0
atiqcAuthor Commented:
Marc, your comments are appreciated but I would like to know which particular product of ontrack will be applicable to me as ontrack has a lot of recovery products available. Will be grateful for your feedback.
0
marc_nivensCommented:
I think its called ontrack power controls.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.