Receiving a dialog on my form that I cannot explain?

     I've created a Date field on my form by doing the following:  Form>Control Toolbox, the Control Toolbox will appear.  I right click in the Control Toolbox and choose Custom Controls, then I scroll down and select Microsoft Date and Time Picker, then click OK.  It will then populate the Date and Time Picker icon in my Control Toolbox.  I then drag this onto my form.  During this time I'm in the Edit Compose screen.  When I try and  bind this Date and Time Picker field onto the Edit Read Page, I will get the following dialog prompt:

"To help prevent malicious code from running, one or more objects in this form were not loaded.
For more information, contact your administrator."  

      I then have the option to click OK, which I do.  The data that I had in my drop-downs in my other fields on this form disappears then.  What is causing this and is there a setting somewhere I can set to keep it from doing this?  Your expedited responses are greatly appreciated.

Thanks,

itsmevic
itsmevicAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mikal613Commented:
you have sp2?
0
MatrixFreakCommented:
Have you tried running a virus check and then reinstalling Visual Studio?  It sounds like a virus or Visual BASIC is messing up on you.  I've used the Date and Time Picker and have never had a problem before so, maybe reinstalling will help.
0
Carl TawnSystems and Integration DeveloperCommented:
Sounds like you're using VBA.  Are you using Office 2003 ?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

itsmevicAuthor Commented:
Mikal613, actually yes I do have SP2 installed.  

Carl_Tawn, yes I am running Office 2003.

MatrixFreak - I havn't tried running the Virus check and reinstalling.   I wanted to mention that I'm not running Visual Studio, I'm running Outlook 2003.

0
Carl TawnSystems and Integration DeveloperCommented:
This sounds like the classic Office 2003 "Paranoia mode" security settings.  You usually get it with ActiveX controls, but i'm not sure that theres actually a fix for it yet.
0
Erick37Commented:
See this:

"Description of the Outlook 2003 hotfix package: March 2, 2004"
http://support.microsoft.com/default.aspx?scid=kb;en-us;835210

Issues that are fixed by the hotfix package:
When you open an occurrence of a recurring appointment that contains an ActiveX calendar control, you may receive the following error message:
To help prevent malicious code from running, one or more objects in this form were not loaded. For more information, contact your administrator.
0
itsmevicAuthor Commented:
Maybe I downloaded the wrong hotfix or something from the link that was provided.  I installed the hotfix, rebooted system as instructed went back into my form, put the active  x control back into my form on the compose side, then copied it over to the edit side to bind it to the form, I then went back to the compose side and was again prompted with the same error message:

"To help prevent malicious code from running, one or more objects in this form were not loaded.
For more information, contact your administrator."  
0
itsmevicAuthor Commented:
Any help with showing me how to add an Active X control to my outlook form with Calendar without getting these error messages would be greatly appreciated.  The link provided:  http://support.microsoft.com/default.aspx?scid=kb;en-us;835210 is exactly what I'm needing to fix this however that URL does not provide the hotlink to download the Office 2003 Hotfix that supposidely corrects this issue.  Is there a setting in Outlook anywhere, I've disabled my macro security have enabled everything in with Active X controls, nothing is working.
0
Erick37Commented:
This link may provide a solution:

http://www.outlookcode.com/d/secforms.htm
"
The ideal solution for this issue is to avoid one-off forms completely. If you must use a one-off and you are using Outlook 2003, you can use a registry entry or policy to control the behavior. (This option is not availble in Outlook 2002 SP3). To use a registry entry, add a DWORD value named AllowActiveXOneOffForms to the HKCU\Software\Microsoft\Office\11.0\Outlook\Security value and set it to one of these values:\

0   Load only the frm20.dll controls, the Outlook View Control, Outlook Recipient Control, and the docsite (message body) control
1   Allow only controls marked as "safe for initialization" to load
2   Allow all ActiveX controls to load  
"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
itsmevicAuthor Commented:
Erick37 you are tha man....your last solution with the reg hack was right on target buddy, IT WORKED!  

Thanks a million!  ~ itsmevic
0
Erick37Commented:
Glad it worked!
Thanks for the "A"
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic Classic

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.