Favorites Redirect Custom AD Policy

I search long and far for this one. I am looking for a way to redirect client's favorites folder to a network share by way of AD policy. So far I found a way to creat a custom policy and a tool to do it (Policy Template Editor).

Everything seems to be ok, but when I add the custom policy, the icon shows up in red (instead of blue) and doesn't not work. Also, if I set Administrative templates to View "Policies only", the folder with the policy shows up, but the policy does not.

Here is the FavoritesRedirect.adm that I created:


   CLASS USER
      CATEGORY "!!FavoritesRedirect"
         KEYNAME "Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders"
         POLICY "!!FavoritesRedirect"
            KEYNAME "Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders"
            EXPLAIN "Redirect Clients Folders to a Network Location (\\server\share\%username%\favorites)"
            VALUENAME "Favorites"
            VALUEON "\\solfs001\users\%username%\favorites"
         END POLICY ; !!FavoritesRedirect
      END CATEGORY ; !!FavoritesRedirect
 
[STRINGS]
FavoritesRedirect ="Redirect Clients Favorites"
pwslglAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

oBdACommented:
It's normal that it's displayed in red. This setting is not a group policy, it's what Microsoft calls "Preferred Setting" or "Branding". The key is outside the ...\Policies\... keys in the registry, so this will behave like an NT4 System Policy: It will NOT simply "go away" if you delete the GPO or set the policy to "Not Configured", it will remain at the last setting it was (as if you manually edited the registry).
Assuming that editing this key works correctly, this template should work for you:

CLASS USER
CATEGORY "!!FavoritesRedirect"
  POLICY "!!FavoritesRedirect"
    KEYNAME "Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders"
    PART "Redirect Clients Folders." TEXT END PART
    PART "New Path:" TEXT END PART
    PART " " EDITTEXT REQUIRED EXPANDABLETEXT
      VALUENAME "Favorites"
      DEFAULT "\\solfs001\users\%username%\favorites"
    END PART
  END POLICY ; !!FavoritesRedirect
END CATEGORY ; !!FavoritesRedirect

[STRINGS]
FavoritesRedirect ="Redirect Clients Favorites"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
beatifiedCommented:
I am trying to do the same thing (redirect the favorites folder) and used the method above but have no luck enableing the redirection. A folder shows up called Redirect Clients Favorites but I can not do anything with it. I have also noticed that folder redirection needs to be enabled to have this show at all.

Any help would be appriciated,
Thanks.
0
beatifiedCommented:
Sorry found the answer to my own question.

gpedit.msc
Right click "Admistrative Templates"
Highlight "View"
Click "Filtering..."
Deselect "Only show policy settings that can be fully managed."
Click "OK"
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.