Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 262
  • Last Modified:

XP home sp1 can ping all network devices but cant access the shares

I have a small network a router and 4 XP computers 2 pro sp1, 1 home sp2, 1 home sp1(hsp1). All have static assigned ip addresses. 192.168.254.? The 2 pro machines can see all the shares except the hsp1's the hsp2 can see all the shares except the hsp1's the hsp1 cant see any shares. From the hsp1 machine I can ping all the others. but when I try to open a share I get the message that the newtork resource is not accessable and to make shure i have permissions and path not found. When I boot the hsp1 machine in safe mode with networking all the shares are accessable and I can see them from the other machines.
0
fstarling
Asked:
fstarling
2 Solutions
 
SKULLS_HawkCommented:
So booting Home SP1 ( the machine with the problem) in safe mode allows it to work?

What have you got running in normal mode that doesn't start in safe mode.  Is there a firewall on this machine?

If it works fine in Safe mode, then something that is starting up normally isn't there to stop it.

In normal mode, do the following.

Click Start => Run and type msconfig.

Click on the startup tab, and see what is listed.  You can start by disabling one at a time, or disable all and then try them
one by one.  This is probably easiest.  First try though, disable all startups, restart the machine and see if it works.

If that doesn't help, compare the netorking setup between safe and normal mode.
0
 
ikm7176Commented:
Make sure that the browser service is started on hsp1

follow the link below
http://www.jsiinc.com/SUBK/tip5300/rh5336.htm
0
 
stevenlewisCommented:
did  you run the networking wizard?
or
on the XP machine

Start | Programs | Administrative Tools | Local Security Policy

Security Settings

Sharing Mode- Change this to "Classic Mode - Local users Authenticate as Themselves" (as opposed to "Guest only" the default model)

this fix will be applied after a restart

See:

http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/winxppro/proddocs/506.asp?frame=true

0
 
fstarlingAuthor Commented:
The browser service on Hsp1 was and is set to automatic and was already started. I did not turn off all the startup items yet, wanted to try the easier suggestions first. Looked for the start|programs|administrative tools|local security policy, but it isn't a choice. Is that a XP Pro tool? Anyway I went to control panel and opened administrative tools. I went to find local security policies and opened component services. went to component services|computers|my computer, I right clicked and went to properties. I unchecked the box "Enable Distributed COM on this computer" (thius turns DCOM off) and clicked apply. Closed all windows and checked my network. Now I could log onto the other shares on my network. I went to another computer on the network and checked, I can see the shares on Hsp1. I do not know why this made a difference, I had already checked the registry and DCOM was not enabled anyway. But it was in this component services module.  So now it works, but I am new to this exchange and not sure how to award these points. None of you got it but your answers were great. Cant say why I didnt turn all startups off in the first place, and never would have looked in component services if not for stevenlewis. Any suggestions?Thansk for your help.
0
 
stevenlewisCommented:
don't know why DCOM would interfere with the network, but glad you got it
you have a few choices
1. go to CS and request PAQ with refund
http://www.experts-exchange.com/Community_Support/
2. go to CS and request a reduction in points and then award the experts for their help
3. split the points between experts
the choice is yours
Steve
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now