[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 337
  • Last Modified:

Fedora Core 2 DNS setup

I have deployed FC2 server with apache,squid,dns,samba,and postfix but i am having problems with name resolution from my windows clients.  
0
revelyn
Asked:
revelyn
  • 11
  • 11
1 Solution
 
revelynAuthor Commented:
internet connection via dsl with integrated dhcp, firewall, and dns routing.  I have configured DMOZ mode and have an external ip for eht1 etho 192.168.0.1 255.255.255.0
0
 
wesly_chenCommented:
Hi,

> internet connection via dsl with integrated dhcp, firewall, and dns routing
You mean you have DSL router/firewall to do those function?
DMOZ? Is it DMZ?

What's the DNS servers' IPs which are provided by your DSL provider?
Are your setting DNS servers' IPs on Windows clients the same as your DSL? ( run "ipconfig /all" to show DNS on Windows )

Wesly
0
 
revelynAuthor Commented:
-dns for dsl are 196.28.61.145 & 196.28.61.161
-internally the ip address of the dls router is 172.16.0.1 with 255.255.0.0 sub
-the ip's of the windows nodes are set to the internal adapter of the fedora server 192.168.0.1
-dhcp yet needs to be deployed on the server ut i have set it manually for testing purposes to the 192.168.0.1 dns
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
wesly_chenCommented:
Do you have an internal DNS server? ( Such as Windows Active Directory server)
Unless you set up DNS server on your fedora server, or those Windows clients can not get the name resolution since
you point to 192.168.0.1.

Before you setup DNS on Fedora server, please point to other DNS server (Windows AD).

Wesly
0
 
revelynAuthor Commented:
I heve set u dns in the fedora box name resolution is fine on the server but the clients name resolution is not working
0
 
wesly_chenCommented:
1.
> set up dns in the fedora box name resolution is fine on the server
Please do the the following check:
# nslookup
> server 127.0.0.1
www.yahoo.com
Result ? If this not working, then your DNS is not setting right.

2. What is the content of /etc/resolv.conf?
Do you have
---
nameserver  127.0.0.1
or
nameserver 192.168.0.1
----
If not, then you are not query your DNS on your Linux box.

Regards,

Weslu
0
 
revelynAuthor Commented:
1. Yes this is working OK
2.  the entries mentioned  are not in the /etc/resolv.conf  I just added them

I will try testing this with the nodes and will update via the forum


Regards,

Ray Evelyn
0
 
revelynAuthor Commented:
which would be the corresponding entries for dhcpd.conf in order to replicate to windows nodes
0
 
wesly_chenCommented:
> which would be the corresponding entries for dhcpd.conf in order to replicate to windows nodes
I'm not following you. Can you explain more?

By the way, doesn't iptables run on your Fedora box? If yes, then what's the rules (iptables -L)?
It may block the DNS query from outside of the linux box.

Wesly
0
 
revelynAuthor Commented:
Let me refrase about dhcp I would like to automatically asign ip's from the linux box to windows with the corresponding  ip address of the server for  adecuate name resolution( 192.168.0.1) I suspect with name resolution from the clients for example outlook and ping for the command prompt will work.

Internet browsing is fine on the nodes  I have squid working as an internet cahing device on port 3128

iptables -L

Chain INPUT (policy ACCEPT)
target     prot opt source               destination
 
Chain FORWARD (policy ACCEPT)
target     prot opt source               destination
 
Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

0
 
wesly_chenCommented:
--- dhcpd.conf ---
subnet 192.168.0.0 netmask 255.255.255.0 {
     range 192.168.0.50 192.168.0.254;    <=== Modify as you like
         option subnet-mask 255.255.255.0;
         option broadcast-address 192.168.0.255;
         option routers 192.168.0.1;
         option domain-name-servers 192.168.0.1;
         option domain-name "domain.com";    <==== change to your domain
         option ip-forwarding on;
         option netbios-node-type 8;
     }
---------------------
Wesly
0
 
revelynAuthor Commented:
dhcp is running with the sample file sent thanks but, still no resolution from the nodes to external mail servers  with outlook, tried to connect via putty to another linux server  i have an another location but connection times out. nslookup from windows client yields non existant domain cant find server name  default server unknown
0
 
revelynAuthor Commented:
Microsoft Windows 2000 [Version 5.00.2195]
(C) Copyright 1985-2000 Microsoft Corp.

C:\>ipconfig /all

Windows 2000 IP Configuration

        Host Name . . . . . . . . . . . . : assist
        Primary DNS Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : vozydata.net

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . : vozydata.net
        Description . . . . . . . . . . . : DAVICOM 9102/A PCI Fast Ethernet Ada
pter
        Physical Address. . . . . . . . . : 00-80-AD-01-60-A1
        DHCP Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.0.254
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.0.1
        DHCP Server . . . . . . . . . . . : 192.168.0.1
        DNS Servers . . . . . . . . . . . : 192.168.0.1
        Lease Obtained. . . . . . . . . . : Thursday, November 11, 2004 12:13:58
 AM
        Lease Expires . . . . . . . . . . : Thursday, November 11, 2004 12:13:58
 PM

C:\>
0
 
wesly_chenCommented:
Hi,

   The issue is that you need to start routed on your Linux box.
So your Linux box acts like a router.

Wesly
0
 
revelynAuthor Commented:
how?
0
 
wesly_chenCommented:
As root
# echo "1" > /proc/sys/net/ipv4/ip_forward
Then
# /etc/init.d/routed start

# chkconfig --level 2345 routed on
For start routed at boot up.

Wesly
0
 
revelynAuthor Commented:
Hi Wesly:

  It works great now.  I can VNC,rdesktop to remote, e-mail, run ssh to my remote server and have one last question when I e-mail outlook gives me an error message saying relaying denied?

Thanks,

Ray  
0
 
revelynAuthor Commented:
550 5.7.1 Invalid email address or relaying denied I am running postfix

0
 
wesly_chenCommented:
Put "vozydata.net" and all your domain names in
/etc/mail/relay_domains
and restart the sendmail.

Wesly
0
 
wesly_chenCommented:
I'm not very familiar with postfix.
However, you can look for config file for postfix and check the following entries:
-----
mynetworks_style = subnet
mynetworks = 192.168.0.0/24
-----

Wesly
0
 
wesly_chenCommented:
main.cf for postfix

Wesly
0
 
wesly_chenCommented:
Hi,

  Is your issue resolved? For postfix, it's separate issue from your topic, you can post to
http://www.experts-exchange.com/Networking/Email_Groupware/

  There are a lot of expert can assist you.

Good luck,

Wesly
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

  • 11
  • 11
Tackle projects and never again get stuck behind a technical roadblock.
Join Now