• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1837
  • Last Modified:

3Com NBX-100 Multicast Between Sites

Hi,

We have been running a 3Com NBX-100 system for some time now with the following configuration:

*E1/T1 PRI Card for trunks
*MOH
*IP On The Fly

Recently we brought a remote office (located acrossed the street) online with the main office via a PTP T1, not bridged.  

Office 1  <<--Cisco 3600, 192.168.1.0-->> (PTP T1) <<--Cisco 2600,192.168.2.0-->>

So two separate net's exist, the NCP resides on the 192.168.1.0 network.  We have managed to bring phones online at both sites, dialing out works, transfer of calls works, music on hold works.  We run into a problem when attempting to conference calls, as well as with time/date synchronization at the handsets.

it appears that this is due to a multicast issue.  My basic question would be what is the proper configuration for multicasting between these two sites, using the routers and connection we currently have?   Bridging the two networks really isn't an option so we are hoping to be able to pass the MC packets through the T1 ckt.

Let me know if I can offer further information.

Thanks!
0
rfowleroma
Asked:
rfowleroma
  • 11
  • 9
1 Solution
 
Joel_SiskoCommented:
Few things,

Please post your router configs, do you have any firewalls that are in the path, also are you using managed switches (type and model if you can).

Are you paying for the T1 between the two sites? If they are across the street from each other, is it possible to set a wirless bridge between the two?

What version of the NBX software are you using? Also I would recommend that you fully enable IP on the NBX if you are planning on adding remotes offices and users. In the past I have seen that using IP on the Fly to cause other issues in a multisite configuration.

 
0
 
Joel_SiskoCommented:
Additional information as per my first post, to enable for multicast enter Global Configuration mode and enter:

Router> (enter password for privledged mode)

then

Router#config (enter global mode)

then

Router(config)# multicast-routing (enter gloabl sub mode)

then

Router(config-mcast-ipv4)# interface all enable

0
 
Joel_SiskoCommented:
Also, in regards to the time issue, using the command:

ip-helper address x.x.x.x

should take care of the time issue on phones (as long as port 37 is being used to do this)
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
rfowleromaAuthor Commented:
We appear to have multi-casting enabled within both routers.   Config layout is as follows:

NBX is running 4_2_6 , we have 4_2_7 on the way from our vendor.

Site 1 - NCP is located here - network: 192.168.1.0   Router: Cisco 3640 w/ WIC1

Site 2 - remote office - network:  192.168.2.0   Router; Cisco 2605 w/ WIC1

T1 is paid for by us and a PTP to our remote office acrossed the street.  We do not bridge.   There is a firewall/NAT box in place at site 1 to handle internet traffic routing onto another t1, however all traffic between site2 and site1 in regards to the NCP and phones never touches that NAT box.

Wireless bridge would not be possible due to LOS issues from either point as well as city code regulations.  

Also where would ip-helper be executed from?  IOS? or the NBX?

The telephones are located on both subnets.  Phones on the .2 subnet are assigned static DHCP reserved .2 addresses, and then physically mapped within Netset to their respective IPs.   All functions of the phone system work perfectly, including MOH.  The only issues we have are with the paging functions, conferencing, and time synch.

Routing table from Site 1: (192.168.1.251=nat box for internet routing)
Gateway of last resort is 192.168.1.251 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial0/0
C    192.168.1.0/24 is directly connected, Ethernet0/0
S    192.168.2.0/24 [1/0] via 10.10.10.2
S*   0.0.0.0/0 [1/0] via 192.168.1.251

Routing table from Site 2:
Gateway of last resort is 10.10.10.1 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial0/0
S    192.168.1.0/24 [1/0] via 10.10.10.1
C    192.168.2.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 10.10.10.1

Thanks for your help!!
0
 
rfowleromaAuthor Commented:
Also router config from Site2 ..
! Last configuration change at 10:51:16 UTC Thu Nov 11 2004
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname omagw01
enable secret 5 $1$QHF.$RmCDXz3SocKsrAc6ZW8E21
ip subnet-zero
ip name-server 192.168.1.252
ip audit notify log
ip audit po max-events 100
call rsvp-sync
!
gw-accounting h323 vsa
gw-accounting voip
interface FastEthernet0/0
 description connected to EthernetLAN
 ip address 192.168.2.253 255.255.255.0
 speed auto
 full-duplex
 no mop enabled
interface Serial0/0
 description connected to CorporateNetwork
 ip address 10.10.10.2 255.255.255.252
 ip router isis
 service-module t1 remote-alarm-enable
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
router isis
router rip
 version 2
 passive-interface Serial0/0
 network 192.168.2.0
 no auto-summary
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
ip route 192.168.1.0 255.255.255.0 10.10.10.1
ip http server
snmp-server community public RO
snmp-server enable traps tty
dial-peer cor custom
gateway
line con 0
 exec-timeout 0 0
 password lcd1700m
 login
line aux 0
line vty 0 4
 password -----
 login
end
0
 
Joel_SiskoCommented:
ip-helper is used on the Cisco IOS, it directs packets that are not normally routed over a WAN to the specified Ip address that you configure when using the command.

Hoe did you deterimine that multi-cst is enabled on the interfaces? I do do not see that in the aboce configurations.

0
 
Joel_SiskoCommented:
Any headway resolving the issue as of yet?
0
 
rfowleromaAuthor Commented:
Not yet - I have to get in this weekend and reset the enable pw on one of the boxes so we can play around with it again.

Once I do that, we'll make sure multicast routing is turned on on both sides, and implement ip-helper.  Then I'll post the updated config files if we're still having trouble.
0
 
Joel_SiskoCommented:
I will keep an eye on the posts this weekend if you run into any issues.
0
 
Joel_SiskoCommented:
How did things go this weekend?
0
 
Joel_SiskoCommented:
rfow,

Were you able to resolve your problems?
0
 
rfowleromaAuthor Commented:
Sorry Joel - we've finally got back into the other router and have both router configs available.  Posted as follows:

Original Location w/NBX100
------------------------------

Using 1182 out of 129016 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname fsdgw01
!
enable password 7 13131645595C0B272A267C39
!
ip subnet-zero
!
!
ip name-server 192.168.1.251
!
ip multicast-routing
ip multicast auto-enable
!
!
!
interface Ethernet0/0
 description connected to EthernetLAN
 ip address 192.168.1.51 255.255.255.0
 half-duplex
!
interface Serial0/0
 description connected to CorporateNetwork
 ip address 10.10.10.1 255.255.255.0
 ip helper-address 192.168.1.250
 service-module t1 remote-alarm-enable
!
router rip
 version 2
 passive-interface Serial0/0
 network 192.168.2.0
 no auto-summary
!
ip default-gateway 192.168.1.251
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.251
ip route 10.10.10.0 255.255.255.0 10.10.10.2
ip route 192.168.2.0 255.255.255.0 10.10.10.2
no ip http server
!
snmp-server community public RO
snmp-server location 10172OMA
snmp-server enable traps tty
banner motd ^C
ID: FSDGW01       Location: 10172OMA
-
Private Network.  Unauthorized Access Prohibited.
^C
!
line con 0
 exec-timeout 0 0
 password 7 151E0808557D7B7425
 login
line aux 0
line vty 0 4
 password 7 151E0808557D7B7425
 login
!
end
0
 
rfowleromaAuthor Commented:
Remote Office
---------------------------

Using 1461 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname icggw01
!
enable secret 5 $1$mkdE$fIz4/d9eiCuKEDfHKSXkj0
enable password 7 04750E1145374D195B490A1A1309580E
!
ip subnet-zero
!
!
ip name-server 192.168.2.254
!
ip multicast-routing
ip multicast auto-enable
ip audit notify log
ip audit po max-events 100
!
call rsvp-sync
!
!
!
!
!
!
gw-accounting h323 vsa
gw-accounting voip
!
!
interface FastEthernet0/0
 description connected to EthernetLAN
 ip address 192.168.2.253 255.255.255.0
 ip helper-address 192.168.1.255
 speed auto
 full-duplex
 no mop enabled
!
interface Serial0/0
 description connected to CorporateNetwork
 ip address 10.10.10.2 255.255.255.252
 ip helper-address 192.168.1.250
 ip router isis
 service-module t1 remote-alarm-enable
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router isis
!
router rip
 version 2
 passive-interface Serial0/0
 network 192.168.2.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
ip route 192.168.1.0 255.255.255.0 10.10.10.1
ip http server
!
!
snmp-server community public RO
snmp-server enable traps tty
!
dial-peer cor custom
!
!
!
gateway
!
!
banner motd ^C
ID: ICGGW01      Location: 10051OMA
-
Private Network.   Unauthorized Access Prohibited.
^C
!
line con 0
 exec-timeout 0 0
 password 7 0507050B701B1E5914
 login
line aux 0
line vty 0 4
 password 7 060A0C251D19594908
 login
!
end
0
 
Joel_SiskoCommented:
So you still have ongoing problems?
0
 
Joel_SiskoCommented:
Looks as if you have two seperate address for the ip helper-addres? ip helper-address 192.168.1.255 and ip helper-address 192.168.1.250


nterface FastEthernet0/0
 description connected to EthernetLAN
 ip address 192.168.2.253 255.255.255.0
 ip helper-address 192.168.1.255
 speed auto
 full-duplex
 no mop enabled
!
interface Serial0/0
 description connected to CorporateNetwork
 ip address 10.10.10.2 255.255.255.252
 ip helper-address 192.168.1.250
0
 
rfowleromaAuthor Commented:
That's a mistake - should the ip-helper-address be the NCP or?

0
 
rfowleromaAuthor Commented:
As for ongoing problems we are having good luck with incoming/outgoing and most basic routing features .. we still have issues with conference calling and the time synchronization.
0
 
Joel_SiskoCommented:
It should be the next hop, not the NCP. By default certian packets are not forwarded by the router (this is more than likely why the certian features are not working and some are). Here is a link that explains in detail, go down about half way to forwarding broadcasts.

http://www.cisco.com/univercd/cc/td/doc/product/software/ssr83/rpc_r/48383.htm
0
 
rfowleromaAuthor Commented:
Okay I've changed the ip-helper address at site 2 on the ethernet and serial interfaces.  They are both pointed to the next router-hop on the network.  Config file from both routers to follow:

Site 1:
Current configuration : 1182 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname fsdgw01
!
enable password 7 13131645595C0B272A26
!
ip subnet-zero
!
!
ip name-server 192.168.1.251
!
ip multicast-routing
ip multicast auto-enable
!
!
!
interface Ethernet0/0
 description connected to EthernetLAN
 ip address 192.168.1.51 255.255.255.0
 ip helper-address 192.168.1.251
 half-duplex
!
interface Serial0/0
 description connected to CorporateNetwork
 ip address 10.10.10.1 255.255.255.0
 ip helper-address 192.168.1.251
 service-module t1 remote-alarm-enable
!
router rip
 version 2
 passive-interface Serial0/0
 network 192.168.2.0
 no auto-summary
!
ip default-gateway 192.168.1.251
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.251
ip route 10.10.10.0 255.255.255.0 10.10.10.2
ip route 192.168.2.0 255.255.255.0 10.10.10.2
no ip http server
!
snmp-server community public RO
snmp-server location 10172OMA
ip route 10.10.10.0 255.255.255.0 10.10.10.2
ip route 192.168.2.0 255.255.255.0 10.10.10.2
no ip http server
!
snmp-server community public RO
snmp-server location 10172OMA
snmp-server enable traps tty
banner motd ^C
ID: FSDGW01       Location: 10172OMA
-
Private Network.  Unauthorized Access Prohibited.
^C
!
line con 0
 exec-timeout 0 0
 password 7 151E0808557D7B7425
 login
line aux 0
line vty 0 4
 password 7 151E0808557D7B7425
 login
!
end

-Begin Site 2 Router Config-
icggw01#sh running-config
Building configuration...

Current configuration : 1494 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname icggw01
!
enable secret 5
enable password 7
!
ip subnet-zero
!
!
ip name-server 192.168.2.254
!
ip multicast-routing
ip multicast auto-enable
ip audit notify log
ip audit po max-events 100
!
call rsvp-sync
gw-accounting h323 vsa
gw-accounting voip
!
!
interface FastEthernet0/0
 description connected to EthernetLAN
 ip address 192.168.2.253 255.255.255.0
 ip helper-address 192.168.1.251
 speed auto
 full-duplex
 no mop enabled
!
interface Serial0/0
 description connected to CorporateNetwork
 ip address 10.10.10.2 255.255.255.252
 ip helper-address 192.168.1.251
 ip router isis
 service-module t1 remote-alarm-enable
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router isis
!
router rip
 version 2
 passive-interface Serial0/0
 network 192.168.2.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
ip route 192.168.1.0 255.255.255.0 10.10.10.1
ip http server
!
!
snmp-server community public RO
snmp-server enable traps tty
dial-peer cor custom
!
!
!
gateway
!
!
banner motd ^C
ID: ICGGW01      Location: 10051OMA
-
Private Network.   Unauthorized Access Prohibited.
^C
!
line con 0
 exec-timeout 0 0
 password 7
 login
line aux 0
line vty 0 4
 password 7
 login
!
end

Cheers,
-RF
0
 
rfowleromaAuthor Commented:
We ended up having a SONET ring placed between the two sites.  Obviously this fixed the problem almost instantantly.  

Thanks for all of the input
_RF
0

Featured Post

Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

  • 11
  • 9
Tackle projects and never again get stuck behind a technical roadblock.
Join Now