[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 519
  • Last Modified:

Notes with Internet Explorer inetermittent browser hang (R6.x)

I have a well established intranet running with no problems on a Domino 6.5 server with Notes 5.0.x clients using the Notes with Internet Explorer embedded browser option. I now have a requirement to upgrade the clients to R6.5 and have rolled this out to a small test group.
I have hit an immediate show-stopper problem that I have been unable to find a solution to through trawling the internet. I also have a support call in with Lotus, but they have been unable to help.
The problem is that, intermittently, the browser will just hang when a user is navigating the site. The status bar will count progress up to 39% and will stop there (always at 39%) and become unresponsive. The only way to progress is to restart Notes. The page in question can then be navigated to with no problem and the user can carry on until the next hang.
I have begun to remove some of the more complex elements of the site (JavaScript, Style Sheets, etc.) to see if that has an effect, but the problem is still there. Obviously though, I would rather find a solution to the underlying problem than have to remove functionality or design from the site.
Has anyone here come across this before ?
0
hotsnot
Asked:
hotsnot
  • 7
  • 4
  • 3
  • +1
7 Solutions
 
lmicalleCommented:
Have you tried deleting and re-creating the perweb.nsf (and ensure that this is built from the R6.5 perweb.ntf) ?
0
 
hotsnotAuthor Commented:
Tried the perweb.nsf trick ... all test users are on R6 perweb.nsf
0
 
HemanthaKumarCommented:
Is this happening for any specific web site or in general ?

Sometimes your windows socks is the culprit... coming to that what version of windows are you using?

~Hemanth
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
qwaleteeCommented:
I have a strange question.  Why are you using the embedded internet explorer option?  Most users find the external internet explorer optio so much easier to use.  The only advantage embedded gives you is that it brings tabbed browser windows to explorer (like Opera and Mozilla).  But everything else is SO much better when IE runs as itself.

Also, it is unclear to me what level of "halg" you are getting:

1) All of Notes hangs when this occurs
2) All web browsing in Notes hangs when this occurs, i.e., you can't even open another browser screen within Notes
3) Everything works normally, but this particular URL is stuck fir the rest of the session.  If you enter a different URL, it oads, even as the problem URL is still stuck.  (And if this is the case, can you close the problem web tab, and re-enter the URL?)
0
 
hotsnotAuthor Commented:
Is this happening for any specific web site or in general ?

>> It's an intranet with no general external internet access.

What version of windows are you using?

>> All machines are running Win2k.

1) All of Notes hang when this occurs ?

>> No - only the browser sessions in Notes 6.5.* clients. All other PC operations and Notes functions work.

2) All web browsing in Notes hang when this occurs ? (i.e. you can't even open another browser screen within Notes)

>> Correct - all browser activity in Notes.

3) Everything works normally, but this particular URL is stuck for the rest of the session ? If you enter a different URL, it loads, even as the problem URL is still stuck. (And if this is the case, can you close the problem web tab, and re-enter the URL?)

>> No all browser activity hangs when the intranet hangs.

Thanks for the help so far ... it's a tricky one I know.
I reckon there must be a clue in the 39% progress on the status bar.
Someone else has come across this before ( http://notes.net/nd6forum.nsf/0/3a2ea2dd7a1014ee85256ec2003e9f5f ), but he can't be contacted (even tried Googling his name to no avail).
0
 
HemanthaKumarCommented:
It could be a connectivity issue to the web server.. try pinging it using -t option and note the response and let us know..
0
 
hotsnotAuthor Commented:
Ping times are normal.
The issue is only present in R6.x clients.
Prior to upgrade, the issue was not present and is now present only in this test group of about 30 R6.x clients.
The remaining 700 R5.0.x clients are not experiencing the issue.
0
 
HemanthaKumarCommented:
What does this page contain ? Any large data or tables or pictures ?

Second make sure the user client doesn't have unecessary ports enabled other than tcpip !
0
 
hotsnotAuthor Commented:
It's happening on random pages. Some very simple, others rather complex.
I'm not sure I see where you're going on the ports angle.
We're using embedded Internet Explorer in Notes. How would the port settings affect that ?
0
 
HemanthaKumarCommented:
Ports are somtimes the culprit which is always overlooked...Notes performs transaction on these ports to find the best possible path..
0
 
hotsnotAuthor Commented:
Thanks to everyone for their help, but it looks like this one is unsolvable at present.
Here's the feedback we got from Lotus:

"... I have been able to find the problem. As the failure occurs when you get consecutive lines from 1% to 39%, then just 39% repeating, this problem is related to Lotus Notes SPR # JUYA5XY5WN (Brief Description: Notes with IE does not work and a blank page was shown) which has status Open / Reproduced.

The failing SPR scenario seems to be very close to your problem scenario. The only one difference seems to be that you don't get any blank page, however the most important point is that your page download fails on "39% completed" like in the SPR, so I am sure that we have found the problem in a consistent manner.

I can confirm that the problem just happens setting "Notes with Internet Explorer" and Lotus Development is currently working with Microsoft on this problem. There is no solution at this time and no clear indication of whether the solution will be a change to Notes client or to Microsoft dlls, so we cannot be sure that this problem will be resolved in the next release 6.5.4."
0
 
qwaleteeCommented:
It may help to look at the HTTP session data with both clients (5+IE and 6+IE) requesting teh same page in teh same exact sequence of steps (including user login).  You can then see how far it got before it broke down, and whether what it got matched what the 5 client got.

If they do match, it is clearly a rendering problem, and there is no way you will solve it in the current release; giving this data to Lotus may help them debug it for a future release.  If they don't match, then you may be able to glean some additional information in how the page is contructed that will help yuo modify it.  It could still be an intermediate rendering+followup session request issue.
0
 
hotsnotAuthor Commented:
Gonna leave this with Lotus as unsolved and split the points here.
Have to select an accepted answer, so selecting qwaletee's only because it's the last one posted.
Thanks again to all.
0
 
qwaleteeCommented:
You have an open ticket with Lotus on this?  What did they say?
0
 
hotsnotAuthor Commented:
I posted their feedback here on 12/01 ... go up 4 comments from here and you'll see it.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 7
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now