vbSendMail Doesn't seem to work on some computers...

Hello Experts!

I've written a program which uses the VBAcellerator vbSendMail DLL and have got it successfully working on the computer it's being developed on.  I've now tried installing it on another computer and it doesnt seem to work.  No errors are shown, it seems to do the trick but the email never seems to come through.  The computers i tested it on both have Norton Firewall and the XP Firewalls turned on.  The development PC does have the XP Firewall turned on but no Norton Firewall.  Could this be it?

Does anyone else know of this happening? I've got a deadline of tomorrow for this program so could do with any advice really quickly!!

Thanks very much in advance.

Bob
LVL 3
BobeoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Éric MoreauSenior .Net ConsultantCommented:
Is your server correctly set? Are you trying to do relay (send outside your domain)? In this case, does your server allow the relay?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SethiCommented:
Have you installed Winsock control along with the vbSendMail control on the other machine? It is dependent upon that control.

Secondly, is the SMTP server being used a SMTP server on the local machine itself? If yes, then you may face the problem as I faced this problem in the past and could not find any solution to that.
0
BobeoAuthor Commented:
Hi guys,

thanks emoreau, you hit the nail on the head!  Tried changing the SMTP Server to the one for the ISP being used on each machine and it worked a treat.

Cheers for your help,

Bob
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Programming Languages-Other

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.