Eudora http link open in IE instead of the default browser (Firefox)

Hi

I have Firefox (1PR) as my default browser (when I click on a html file, it opens in Firefox), but when I click on a http link in Eudora (5.2) it opens in Internet Explorer.

I think my registry is corrupted or something. There are some file associations related to myIE in the Folder Options, but I uninstalled myIE much before I installed Firefox.

Other strange thing is that even if I configure Internet Explorer to check if it is the default browser, when it opens it doesn't ask me if I want IE to be the default browser.

Thanks in advance.
gandhirsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Asta CuTechnical consultant & graphic designCommented:
There are a number of additional hyperlinks within this link towards the bottom; may get us going.
How to Make Internet Explorer the Default Web Browser
http://support.microsoft.com/kb/q284456/

Aside from redoing the IE setting for checking Default Browser, check your pref.js file; may need to open it using Notepad and edit the line which says default browser defaults that are blocking you.

Not at my system, so my resources aren't available to me this morning, but this may get you started.
0
Asta CuTechnical consultant & graphic designCommented:
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

gandhirsAuthor Commented:
I know that I have to select the "Internet Explorer should check to see whether it is the default browser check box" in order to make Internet Explorer the Default Web Browser. Bu it doesn't work. The message "Internet Explorer is not currently your default browser. Would you like to make it your default browser?" does not appear.

Anyway, I want to keep Firefox as my default browser. I don't want to uninstall Internet Explorer (or hide it in a way that I can't open it when I need). And I want to be able to open the http links in Eudora using Firefox.

My [HKLM\Software\Clients\StartMenuInternet] data is FIREFOX.EXE, and I don't have a [HKCU\Software\Clients\StartMenuInternet] entry.

0
sramesh2kCommented:
See if DefaultBrowser utility helps:
http://windowsxp.mvps.org/defaultbrowser.htm

Internet Explorer should check to see whether it is the default browser - option does not work:
http://windowsxp.mvps.org/ie/nopromptdefault.htm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gandhirsAuthor Commented:
0
sramesh2kCommented:
You're welcome!

BTW, the procedure in this page, system requires a reboot:
http://windowsxp.mvps.org/ie/nopromptdefault.htm
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.