windows network issue

Ok, here is what silliness I have to deal with atm:

At a store our company supports is a small LAN with a server and 3 workstations that are part of a point of sale system. At another location is an office for the store. At the office is the internet gateway (DSL). But the link from the office to the store is some sort of leased line 128k.

Now, for some reason the internet respo se is crappy from the store, and the managers there need to surf to buy crap. They requested I bring in a laptop, with wireless access. Reason is that the store is next to Star Bucks (where a t-mobile access point is). So, that is setup, and the laptop gets great connection speed. Now they want to print from the laptop to a printer on the local store network.

So on this laptop I have two network connections, one wireless, and one ethernet. I have not gotten both to work at the same time. When I disable the ethernet, the wireless works fine, and vice versa. It is windowsXP, and server 2000. And they are on a workgroup there, not a domain.

Even more, they thought it would be cool to use the laptops great internet connection (wireless through t-mobile) for access of theo ther LAN systems to the web.

I have not been able to get the laptop to connect with the wireless (wireless takes on some ip from provider), and the ethernet (dynamic ip) to allow the laptop to be on the wireless internet and to print to the local network printers?

Can the connections be bridged?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

this refers to 98 but applie4s to xp
multi homed machines
you can try multiple gateways;EN-US;Q262397

When two network adapters are present in a computer (multihomed), a default gateway should only be assigned

to one of the network adapter's TCP/IP properties. If one of the network adapters is used to connect

to the Internet, the default gateway should be assigned to that network adapter. In many cases, the

default gateway, as well as the other necessary TCP/IP information is assigned automatically by the

Internet Service Provider by using Dynamic Host Configuration Protocol (DHCP). This can be confirmed

by using the IP Configuration utility (Winipcfg.exe) to view the TCP/IP properties for the network adapter

you are using to connect to the Internet.

For the network adapter that is connected only to the Local Area Network (LAN), such as a home or corporate

network, a static routing entry must be entered into the computer's routing table if the computer needs

to obtain access to network resources across a router or multiple routers. For example, if the router

interface on the same subnet has an IP address of and the router is connecting the

network to a network, the following command would need to be entered either at a command

prompt within Windows or from a batch file:


This command instructs Windows to send all traffic that is destined for the network to the interface on the router. To verify that the ROUTE ADD command was successful, use the ROUTE

PRINT command to view the current routing table. If multiple routers are being used on the LAN segment,

a separate ROUTE ADD is needed for each router.

Note that the routing entry is not persistent in Windows 98/95, even with the -p switch, and is lost

after you restart the computer. To have this entry automatically added for every Windows session, create

a batch file with the necessary ROUTE ADD command(s) and place it in the Windows StartUp folder to be

executed each time Windows starts.

If DHCP is used to assign IP addresses on the LAN, the DHCP server should be configured to not provide

a default gateway.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
troyhicksAuthor Commented:
ok, still having trouble!

I have the network adapter for the internet (wireless) configured. The other adapter has a static ip, and no gateway. But still, only when I get rid of the wireless part can I connect to anything on the LAN.

The lan side adapter is set up as static and no gateway.

The wireless is dhcp. It currently has an ip of mask is and the gateway is

when I run the 'route print' command, it shows only the as being a default gateway.

now - I just need the machine to see the LAN ( so it can get connected to a printer there.

when I turn off the wireless network adapter (internet) part, I can see the LAN just fine with the LAN adapter. And I can print just fine. But when the wireless adapter is turned back on, then the LAN part stops to work.

I need both parts to work!!

I tried the route command,

route add mask  ---- because is the gateway when dhcp does the job

this did not get me the LAN

I also tried the route add mask  ----- in case.

this did not work either.

What the heck am I doing wrong?

before you waste too much time setting things up be aware that your neighbour may have issues with you using their bandwidth and may eventually put in an address block of your laptop. :-(

You would be back where you started.

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

troyhicksAuthor Commented:
nah. The wireless connection is paid. it is a t-mobile account. The laptop is allowed to connect to the wireless network. And that part works fine. Now I just need the laptop to also see the LAN it is hard plugged into, and print crap to the printers.

with both turned on, go to a prompt and type these sommand (paste the results here please)
ipconfig /all
and then
route print
troyhicksAuthor Commented:

Looks like only when I make the lan side automatic (finds a dhcp) will it work. And the wireless side must be on dhcp, that is the only option. I cannot force the router for the wireless to NOT send a default gateway.

So it looks like I cannot make this work!

When I start up the laptop, the lan side will work, and the wireless side is stuck - until I get rid of the default gateway on the lan side and put in static ip. Then the lan side stops finding the lan, and the wireless part starts to work and can access the web.

I guess I have to put a printer on this laptop, locally. just that there is not really room where it is.


If no one can respond and give me a good alternative to try, then go ahead and close this issue ...
try a static ip on the LAN side, and use dhcp on the wireless
make sure to enter the correct ip info (ip, subnet mask)
should work fine
How about printing to your printer externally through your dsl connection, not the best solution but ...
troyhicksAuthor Commented:
ok, I am still working on this - please do not close the issue. I will post again in a few ...
asked another expert to look in on this one
no firewalls involved here are there?
Fatal_ExceptionSystems EngineerCommented:
Well, I can see how this would be a problem to setup, and I will need to sit back and think on this one.    (Of course my first response would have been to suggest a direct printer connection...  :)

Getting a bite and will be back..

Thanks for popping in FE
Truthfully I am suprised that the bridging option does not provide any basic solution for you, XP does automatically bridge connections....and server 2000 should be able to be set up to use the internet through another computer.  If you configure both to the point where they work individually simply going into the network connections, selecting both and right clicking and saying 'bridge conenctions' should work.  I've messed around with two NICs in a PC and used it between two networks, and achieved a working connection like that, this is a similar situation, however you are more restricted.  Windows will certaintly allow for the operation you are speaking about, if you can try re-configuring the server2000 and see what the networking options are for using a connection through another machine, you may want to try that.  
I agree with FE on the direct printer connection, it would be the eaisets thing, however if you really want the fast internet on the server that doesn't help much.

I really think you may end up setting manual IP addresses on the server and the wired NIC of the laptop.  
The modem in the office, if you can afford to, try removing that part of the network so that you're only automated outside infulence is from the internet connection comming over the laptop.  Basically the laptop will become your router.......i'm kind of thinking as I type here, but your setup is certaintly feasible, just having it connected twice to either the internet or a routing deivce could be causing the problem......
Fatal_ExceptionSystems EngineerCommented:
One thing that could be holding you up is the metric that has been set on the wired NIC...   Do a route print and see if the interface metrics for both connections are the same..  If not, then go into your TCP/IP properties and try that..  (if one of the interfaces has a higher metric, it will always use that interface..)
Fatal_ExceptionSystems EngineerCommented:
hmm..  oops..  I meant the lower metric..  sorry..  :)
troyhicksAuthor Commented:
ok, here is where I am now. I disable the wireless connection in device manager. And focus on the lan side. I simply want to configure the laptop to have a static ip and see the lan and be able to see the workgroup components.

When I use automatic ip settings (dhcp), this is all good to go. Though then I end up not able to have the wireless side work, because of two gateways. So, back to the static ip part ...

Now I have setup lots of machines with static ip's, on workgroups. I am having trouble with this one?

the lan here is on the private network. A sonicwall firewall router is and has dhcp. A windows 2000 server (not running a domain) is (it is running wins). And then there is 3-4 other client computers running as cash registers

The sonic wall dhcp server starts adding ip's at  and I know that the ip I assign to the laptop is ok to use. I assigned to the laptop. and have the gateway as (which will eventually be taken away as a gateway, as the laptop will have to use the dhcp wireless side gateway for the internet)

ok, the laptop is all static'ed out. But it will not browse and show workgroup computers? It will show them if I use dhcp, but as static I cannot see the network machines? I can ping and see it, from any machine.

The error I get it is: 'workgroup name' is not accessible. You might not have permission to use thhis network resource. Contact the administrator of this server to find out if you have access permissions."

The laptop is in fact on the correct workgroup. As evident when i switch to dhcp, and then see the workgroup - and can print to it. If I can get the lan side to work with static, then I should be home free.

What is stopping the laptop from having permission to access the workgroup? The laptop was on a domain, and was taken off and put on the workgroup. The user on the laptop is an admin login (for the local machine). I thought workgroup machines were each in charge of themselves?

here is the ipconfig:

ethernet adapter local area connection:

connection specific dns suffix:
ip address                          :
subnet mask                       :
default gateway                  :

route print looks normal. shows the gateway, etc. I am typing this on another machine atm, as I have to either have the laptop try to be on the lan or on the wireless (internet). So I cannot cut and paste. If i put the laptop on the internet - then the lan side did not work - so I will paste that in a few minutes.

this is all right now with the wireless part disabled.

again, not looking at metrics right now - first I need to get this machine to work on this workgroup with static ip!!! Why won't it work?

troyhicksAuthor Commented:

Seems to all work now. I told the dhcp server to allow the ethernet device (lan adapter on laptop) to be a static ip. Then setup static ip on the ethernet adapter - with no gateway. Then enabled the wireless adapter, and it has dhcp and gets assigned a gateway. Now the laptop has only one gateway. It can browse the lan as well, and print.

Seems that the whole problem was mostly the sonicwall dhcp server  -  if it did not get its hands on the laptop - the laptop would not get access to the LAN. Even if I put in static ip information? Now that the sonicwall knows that machine is static, all is well.

I will assign some points once I get back to the office. Thanks all, this issue can be CLOSED!!!

Fatal_ExceptionSystems EngineerCommented:
Very good, and thanks for the explanation.!!

troyhicksAuthor Commented:
last comment- I did not end up using any route command. It was not needed. As I left the laptop has wireless internet andcan print to the lan printers - and the laptop is NOT a gateway for the lan - the lan had its own internet gateway (just a little slower than the wireless connection).

I may turn on internet sharing at some point, but it is not needed now. Thanks to everyone who contributed - I learned a lot.
Glad we could help!, and ditoo the thanks on the explaination!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.