0x800CCC0F Your Server Unexpectedly terminated the Connection

I am running Exchanger Server 2000 behind a ISA Server Firewall.  Any client from the outside cannot use my smtp server to send e-mail.  They receive the error message above.  They receive e-mail just fine.  From inside the network everything works great.  I need help immediately and will try to respond quickly.  Thanks for the help in advance!
austintreAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

davy999Commented:
0
austintreAuthor Commented:
Been there done that.  No bandwidth throttling issues.  I have looked all over Microsoft's websites and expert exchange and cannot find an answer to this very perplexing problem.  Any more ideas would be great.  Thanks,
0
marc_nivensCommented:
There is an SMTP filtering option in ISA that can wreak havock with SMTP clients.  Try and disable the SMTP filter on ISA (sorry, I don't have the ISA mmc in front of me so I can't tell you exactly where it is).
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

austintreAuthor Commented:
I too believe it has something to do with the ISA Server and nothing to do with Exchange, but I haven't been able to figure out where it is.  I was excited to hear your idea but unfortunately I checked and I had that SMTP Filter turned off, it has been off ever since I implented ISA.  

I have gone through every single one of my rules re-creating them, trying to figure this thing out and still nothing.  I know there is a lot I don't know about ISA.  Any other thoughts would be great.  I appreciate the comment.
0
marc_nivensCommented:
Try telnetting to the Exchange server on port 25 from the client.  If you get a blank screen, then you will either need to set the default gateway on the Exchange server to be the internal inteface of the ISA machine, or (if thats not possible) install the firewall client on the Exchange server.
0
austintreAuthor Commented:
When I Telnet to port 25 it sits there for awhile and then says "Connected, Press any key to continue" and when I do it says connection lost.  Would this be the same type of error?  My default gateway is not the ISA Server due to the fact that it is part of a WAN and has the router that connects the other locations as the default gateway.  So that might be the problem.  I have never used the firewall client before, but will give it a try.
0
marc_nivensCommented:
This is probably your issue then.  If the DG is not the ISA server then Exchange must have the firewall client for port 25 publishing to work.
0
austintreAuthor Commented:
I don't see how I publish a port through the client gateway.  I did change the Default Gateway pointing it to the ISA Server and it still does not work.  So I am trying the client.  I don't see that there is too much to configure within the firewall client.
0
marc_nivensCommented:
Oh you don't have to publish anything on the client side, just install the firewall client.  The publishing configuration is all done on the ISA server side.  BTW you will know its worked when you can telnet to Exchange on port 25 and get the Exchange banner back.
0
austintreAuthor Commented:
Ok, firewall client installed.  Still same problem.  I am getting the black screen through telnet that you were telling me about. I even rebooted my mail server. Nothing has changed.
0
marc_nivensCommented:
Verfiy that the firewall client is pointing to the ISA server that is publishing port 25.  I can tell you that this problem is not Exchange related, it has to do with ISA.  Perhaps removing the mail server publishing rule and running the wizard again now that the FW client is installed will help.
0
austintreAuthor Commented:
Ok, the firewall client is point to the ISA Server,  removed and reloaded all of the ISA Rules for the mail server and rebuilt.  Still absolutely nothing.  Rebooted the ISA Server also.
0
austintreAuthor Commented:
No more suggestions?
0
marc_nivensCommented:
It's been a while since I've done an ISA setup so I'm probably leaving some details out.  Try going through this article just to make sure I'm not leaving anything out:

http://support.microsoft.com/default.aspx?scid=KB;EN-US;287646#7
0
austintreAuthor Commented:
Ok, so I figured it out.  It wasn't on my ISA Server after all.  It was how I had my Exchange SMTP Relay options set.  I took out the four domains that I host as the only domains that can relay, and put in the internal IP Address of my Exchange box.  And checked the "allow anyone to relay who authenticates" box and all is good.  Thanks for your help.
0
moduloCommented:
PAQed with no points refunded (of 500)

modulo
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.